PDA

View Full Version : Dead ECM, replaced it. No power, won't rev past 3500.


IHScoutJon
August 16th, 2017, 12:43
Picked up a 1995 Cherokee with a 4.7 stroker, 5 speed and a bunch of other work for the girlfriend. On the way home the radiator tank on the passenger side split. Towed home, drove up to my shop, replaced rad.... Won't start. Find out the ECM went bad. Replaced ECM and now it runs. But, hard starts, no power and won't rev past 3500 rpm. I'm going to check the fuel pressure tonite, anything else to check out while I'm digging around? Thanks!


http://cloud.tapatalk.com/s/59943f309c2f7/20170812_125356.jpg?

Sent from my SM-G920V using Tapatalk

mcguyver_xj
August 16th, 2017, 13:35
ecm might have to relearn parameters especially since its a stroker motor

IHScoutJon
August 16th, 2017, 13:41
That's what I was thinking, but it's borderline not drivable. I figured a half hour of idle to bleed the cooling system and a few laps around the block and it'd learn. No luck there.

Sent from my SM-G920V using Tapatalk

ehall
August 16th, 2017, 13:50
sounds like a bad fuel pump. if fuel pressure checks out I would look at the coil, might have burned it up. Crank and Cam sensors will also cause problems sometimes

IHScoutJon
August 16th, 2017, 13:59
sounds like a bad fuel pump. if fuel pressure checks out I would look at the coil, might have burned it up. Crank and Cam sensors will also cause problems sometimes
Going to check fuel pressure tonight. Whole distributor, cps and coil have been done recently. I think the guy i bought it from was starting to have ecm issues and fired the parts cannon at it.

Sent from my SM-G920V using Tapatalk

IHScoutJon
August 16th, 2017, 21:41
Got it. Left out the part I installed a new distributor. Was a tooth off. Doh!

Sent from my SM-G920V using Tapatalk