View Full Version : 2001 XJ Limited, no start no bus

October 7th, 2017, 16:11
So my son's jeep has been through quite the load of work the past 10 days. But today became a problem. After replacing all the brake rotors, pads, and the rear calipers (it has a zj disc conversion), the jeep started, pulled out of the garage, then shut off.

When we tried to start it again, it would not start and we get a "no bus" on the dash.

Just as a side note, we replaced the heater core last weekend and so many things were unplugged. But, it has been driven back and forth this week to school. My son said the only thing that was a problem was the radio (which appears to be a loose connection behind the radio after the dash re-install).

There were no signs of any other problems and no check engine lights.

I tried to use my scan tool, but it is not working.

I used the key technique to check for any engine codes and there were none.

Any suggestions?

October 7th, 2017, 18:28
From what I recall, "no bus" and no start is usually either a bad Crank Position Sensor. Have you tested the CPS yet? The connector is on the back side of the intake manifold.

October 7th, 2017, 18:48
Since original post, I have tried the following -

unplugged plugs going to pcm and replugged, no bus no start
unplugged crank position sensor, still says no bus
unplugged cam sensor, still says no bus.

if I've read what I can find correctly, unplugging the crank or cam sensors should get rid of the no bus error if they aren't any good.

Also, I wanted to clarify my statement of no start, it cranks but doesn't start. We got it to start for 2 seconds when we pulled it back out of the garage. Then it died immediately. It started once more for a second or two, then died and have had no luck since.

October 8th, 2017, 06:33
Cranks and cranks but will not start/run, a nobus displayed, and no connection to an OBD code scanner very strongly points to a faulty CPS or CPS wire harness issues. Test the CPS, and inspect the CPS wire harness for melted/chafed wires, corroded wire plugs, and pushed back wire plug pins. While extremely rare, a faulty CPS can cause PCM failure. Exhaust all the more common and likely causes of the symptoms before you consider buying a replacement PCM.

If faulty, be sure to buy a genuine Jeep CPS. Most auto parts stores sell cheap crappy Chinese made parts, some that even come with a "Lifetime Warranty". These parts are poorly manufactured and/or made from inferior materials. They are often out of specification, or even failed, right out of the box. The ones that are not faulty many times will have a short service life before they fail. Always buy top quality replacement parts and genuine Jeep engine sensors. Numerous threads detail long and frustrating searches for a "problem" that ended up being cured simply with genuine Jeep repair parts.

Cheap parts are cheap for a reason.

October 8th, 2017, 10:56
Well, I've checked the CPS with a ohmmeter. It reads infinite resistance between pins, which I believe is correct. The harness look ok and the pins look ok.

I pretty much unplugged every sensor I could reach and access in the engine bay one at a time to see if the problem changed. No luck so far.

I've also tried swapping in a different pcm since I had an extra laying in the shed. Same problem, no change. So I think I can rule PCM out.

My son is supposed to take the dash apart again later just to double check all the connections for tightness.


October 13th, 2017, 06:30
Ok, we replaced the CPS today. And we are still getting the same errors, won't start and no bus on the dash. Is there anything else we might double check before assuming its the computer?

October 13th, 2017, 09:56
As I'm double checking sensors, the sensor I took out measured infinite resistance on a 200K ohm scale (my meter only has 200 and 200K). The new sensor reads 4.7 on the 200K scale. I'm reading mixed things about whether that is acceptable range or not.

October 13th, 2017, 18:42
What brand CPS did you get? I recommend only the Mopar sensor because many of the Autozone, Oreilly, etc parts often come dead on arrival - I had 3 brand new sensors all show up dead.

With the latch catch positioned at the top, the middle and right pins should have infinite resistance (open). If you are measuring 4.7, that would lead me to believe the CPS part you have is bad.

October 14th, 2017, 14:19
my interpretation of the nobus error is the cluster is not seeing any data on the ccd bus. most data is fed from the pcm. so im wondering if the pcm is not fully powering up. did your scan tool fail to connect to the pcm? even if the crank sensor is bad it should still read a code. infact it would be a code for the crank sensor.

October 14th, 2017, 15:03
If there is a no-bus and the engine runs normal, there is a connection issue at the cluster connector. If there is a no-bus and the engine stalls and/or will not start the cluster is not involved, there is an OBD sensor or CCD/Bus wire harness issue. Failure of the PCM is very highly likely and should only be considered and a thorough and in-depth inspection and testing of all the 5 volt OBD sensors, their wire plugs, and their wire harnesses.

A short circuit of 12 volts positive to the CCD/Bus circuit 5 volt circuit which transmits the sensor data will most definitely cause issues. A CCD/Bus short circuit or a faulty CPS sensor will often cause the OBD trouble code scanner to be unable to connect.

CPS sensors should read Open or Infinite, even a small amount of resistance makes them suspect.

October 15th, 2017, 04:03
Thanks for helping to keep me on track.

Just updates, the scan tool doesn't connect to the pcm, it doesn't even see it.

There is no bus on the dash. The jeep cranks, but refuses to start. Having checked the voltage at the CPS and finding it low, I'm working to check through the other sensors.

Unfortunately, the jeep is outside and its supposed to rain all day. :(

October 15th, 2017, 07:24
The symptoms make me suspect a short circuit. Don't forget that one should suspect and re-check the most recent repairs or alterations when new symptoms appear. Make sure the main firewall pass thru wire harness is fully plugged in and snugged tight. I think the PCM is able to shutdown or go into self-protect mode when faced with 12 volts on a circuit that should only see either 5 volts, or no voltage at all. I am not a senior (or even junior) diagnostic tech, just a stubborn garage mechanic who reads lots of threads for trouble shooting ideas, and who has some basic understanding how Jeep stuff works. I would purchase the necessary genuine Jeep Service Manuals and begin by checking continuity of the wire harness from sensor to PCM for each sensor. Each ODB sensor should have 5 volts provided, a return to PCM signal wire, and a ground wire. Each OBD sensor does have/should have a testing process to look for internal short circuits, or basic failure. Don't overlook the Transmission Control Module and the O2 sensors and their wire harnesses as potential suspects.

Some random Jeep Things: Unplug the TCM, it can cause OBD faults. Unplug the horn relay, the clock spring can fail and allow 12 volts meant for the horn to short circuit to ground. The clock spring and the Throttle Position Sensor share the same ground.

October 15th, 2017, 09:12

The last two days, my son has been taking the dash back apart and checking all of the connections. We replaced the heater core a week before the failure and I told him he needs to double check all of the connections to make sure they are secure.

In the process of putting it back together and putting the cps back on to test things, he dropped a cps bolt in the bellhousing. So, that's the current task. As soon as he gets it out and we get it in place, we will see if we have made any progress.

If not, the tcm will be the next thing I try.