NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old November 24th, 2012, 13:30
88trailcrawler's Avatar
88trailcrawler 88trailcrawler is offline
NAXJA Forum User
 
Join Date: Oct 2007
Location: OC SoCal
Posts: 986
Injector swap

For clarity, I thought I'd just make a new thread on topic:

After going through several issues chasing down an emissions fail and rich condition, one thing I did was pull and check the fuel rail, injectors and pressure regulator. I cleaned and reinstalled all the existing parts. During that process I came across the recommendation of installing rebuilt injectors from Precision.

Purchase and delivery were painless and quick. A couple weeks later I got around to install. Keep in mind everything was clean and running well from previous work completed

Initial install issue was in trying to determine if the blue plastic tip was part of the injector or a shipping cap. Since it was different than the removed OEM my initial thought was to pop them off, but since they were on pretty secure I concluded they were intended to stay on. This was generally confirmed to be correct by some others.

Second install issue was that the grooves in the upper body were different than OEM which made install difficult and created some alignment and seemingly performance issues at initial install. The upper bodies would not as far into the fuel rail when clipped in. Although they did not leak, I think it contributed to the hard start issues and difficult alignment during the re-re install.

So after the first install the jeep ran good and there might have been some improved throttle response. Idle would sometimes settle in a bit high (1,100). And starting after sitting was randomly quick fire, crank no start or fire up but bogged down. I suspected a leaky injector and set out the next morning to chase the problem down.

The next morning I cleared out all the obstacles to ensure a clean reinstall. I pulled the vac lines, electrical connections and even pulled the throttle cable bracket (which makes a HUGE difference) I pulled the fuel rail out completely and was able to get the injectors to seat fully and sort of clip in. Reconnected the fuel rail and pressure tested to ensure no injectors were leaking.

When I reinstalled I noticed the retainer clips now interfered with the electrical connectors and the very soft fuel rail brackets had given way just a bit so that the injectors were not evenly seated into the intake manifold.

After a little manipulation of the clips (though still not in the positive engagement as OEM) and some gentle persuasion of the fuel rail brackets and alignment, I pressure tested it all again, and reconnected everything.

Restarts seem to be better, but time will tell. It still settles into a high idle occasionally, but I am suspecting an intake manifold leak (old issue possibly renewed by the pulling and tugging related to this install) performance is fine, but no obvious improvements. Peace of mind is 50/50. New clean injectors vs mis- aligned clips and possible reoccurring start issues.

Bottom line conclusion: probably would have been satisfied to keep the cleaned up OEM injectors in place.

Some things I learned:
- pull stuff out of the way, it only takes a few minutes and make pressure test and fitment much easier
- pull the throttle cable bracket
- use blue shop towels at each injector for leak test, they get dark with just a drop of fuel
- lube the o rings and wiggle the injectors into place nice and easy
- change the o rings and spacers at the fuel lines
- pull the fuel rail and fit the injectors into the rail on the bench with the clips
- pressurize the fuel rail and clipped in injectors before sticking them in the manifold, gives you peace of mind
- wiggle the injectors in evenly, and check that your fuel rail brackets are aligned so that they are all fully seated
- take the opportunity to clean all your disconnected electrical connectors

Now, time will tell if this was worth the effort or not.
Reply With Quote
  #2  
Old November 24th, 2012, 14:00
CobraMarty CobraMarty is offline
NAXJA Forum User
 
Join Date: Jan 2012
Location: PM me any questions
Posts: 1,021
Re: Injector swap

Were these 703 injectors or another part number?
Reply With Quote
  #3  
Old November 24th, 2012, 14:44
88trailcrawler's Avatar
88trailcrawler 88trailcrawler is offline
NAXJA Forum User
 
Join Date: Oct 2007
Location: OC SoCal
Posts: 986
Re: Injector swap

Receipt says #2360 for '87-'95 jeep 4.0. $129.95 for set
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Injector Swap kenny811 Modified Tech Discussion 4 February 28th, 2012 17:02
Injector swap problems tcpoland Modified Tech Discussion 9 June 26th, 2011 20:31
injector swap phillyxj570 Modified Tech Discussion 4 September 4th, 2010 13:26
injector swap questions CromeY90 OEM Tech Discussion 50 February 14th, 2010 21:08
injector swap cmr4by4 OEM Tech Discussion 4 January 22nd, 2005 21:25


All times are GMT -7. The time now is 22:57.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014