NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old October 8th, 2021, 15:43
JerryG11 JerryG11 is offline
NAXJA Forum User
 
Join Date: Oct 2021
Location: OR
Posts: 8
Crank No Start/No Fuel Pressure

Bit of an sos.

Necessary details: 92 XJ 4.0 4WD AUTO TRANS

I'm at my wits end with chasing a no start issue. I've been busy lately so this has been my weekend project as of late. About a month ago my XJ wouldn't start out of the blue. I replaced the CPS and it ran until the next day when I went to start it. After throwing a few parts at it thinking it couldn't possibly be the brand new CPS (all new throttle position sensor, idle air, coil pack, fuel pump, and fuel filter). This Jeep was in need of a solid tune up when I got it so throwing new parts on it was mostly for piece of mind.

That being said, I randomly lost fuel rail pressure and can't seem to figure out why. I've begun checking off the list. I put in a fuel regulator, no vacuum leaks, replace CPS and verified that it will run on starting fluid, I've taken out the injectors to clean them and have tested the injector circuit works with a test light. I also have swapped relays for the fuel pump as well as jumped the resistor that quiets the fuel pump.

Here's where I'm at currently: I just warranty swapped my fuel pump for a new one and replaced the filter. When I turn the ignition on I hear the pump engage but I get no pressure at the rail. It will crank and I can get it to start on ether and run but I never get pressure

If there is anything I missed or overlooked I'm all ears and greatly appreciate any input
Reply With Quote
  #2  
Old October 8th, 2021, 17:41
lawsoncl lawsoncl is offline
NAXJA Forum User
 
Join Date: Jan 2006
Location: North Idaho
Posts: 5,589
Re: Crank No Start/No Fuel Pressure

The ballast resistor actually provides a nice place to do some checking. Use the current setting on your meter to make sure the pump is running and drawing current (3-5 amps I think is normal). You can also jump power directly to the bypassed resistor from the battery to eliminate any upstream wiring issues, then check the fuel pressure and/or press the valve to see if you're getting any flow.
Reply With Quote
  #3  
Old October 8th, 2021, 18:42
JerryG11 JerryG11 is offline
NAXJA Forum User
 
Join Date: Oct 2021
Location: OR
Posts: 8
Re: Crank No Start/No Fuel Pressure

Thanks for the response!

I checked the current. With the key switched on I get a reading of 1.5 amps. This is the same if I jump to the pump from the battery and also if I try starting. Energizing the circuit also gave me no change in the fuel pressure. In wondering if I got another dud pump, I broke down and ordered a bosch replacement just in case.

Could I be missing something? I know the line isn't closed or anything. I syphoned fuel through the rail connector
Reply With Quote
  #4  
Old October 8th, 2021, 18:47
lawsoncl lawsoncl is offline
NAXJA Forum User
 
Join Date: Jan 2006
Location: North Idaho
Posts: 5,589
Re: Crank No Start/No Fuel Pressure

1.5 amps seems pretty low. I'd check the voltage and ground at the connector closer to the pump. http://cruiser54.com/?p=249 Then go read the rest of his great tips.
Reply With Quote
  #5  
Old October 8th, 2021, 18:56
lawsoncl lawsoncl is offline
NAXJA Forum User
 
Join Date: Jan 2006
Location: North Idaho
Posts: 5,589
Re: Crank No Start/No Fuel Pressure

Just measure my 89 at 3.2 amps.
Reply With Quote
  #6  
Old October 10th, 2021, 13:17
JerryG11 JerryG11 is offline
NAXJA Forum User
 
Join Date: Oct 2021
Location: OR
Posts: 8
Re: Crank No Start/No Fuel Pressure

I went through and upgraded my my ground for the pump as shown. Now when I test my current I don't get any reading. I'm super confused. I can hear the pump wine went ignition is turned on or when jumped from the battery but my multimeter sits at 0a. I also have seen no change to fuel pressure
Reply With Quote
  #7  
Old October 10th, 2021, 13:23
lawsoncl lawsoncl is offline
NAXJA Forum User
 
Join Date: Jan 2006
Location: North Idaho
Posts: 5,589
Re: Crank No Start/No Fuel Pressure

Quote:
Originally Posted by JerryG11 View Post
I went through and upgraded my my ground for the pump as shown. Now when I test my current I don't get any reading. I'm super confused. I can hear the pump wine went ignition is turned on or when jumped from the battery but my multimeter sits at 0a. I also have seen no change to fuel pressure
The pump gets power for a few seconds when you initially key-on. Then it turns off again until the engine computer senses rpm/cranking. I'm kinda wondering if part of the pump assembly detached and it's sucking air?
Reply With Quote
  #8  
Old October 10th, 2021, 13:38
JerryG11 JerryG11 is offline
NAXJA Forum User
 
Join Date: Oct 2021
Location: OR
Posts: 8
Re: Crank No Start/No Fuel Pressure

Disregard that post. My multimeter busted. The fuse was blown in the current circuit. Must have been from a drop.

I did try one thing and I'm fairly certain I got another dud fuel pump. I unplugged the fuel line and put it in a bucket. When I turn the key I hear that wine but not even a trickle of fuel comes from the pump
Reply With Quote
  #9  
Old October 10th, 2021, 13:39
JerryG11 JerryG11 is offline
NAXJA Forum User
 
Join Date: Oct 2021
Location: OR
Posts: 8
Re: Crank No Start/No Fuel Pressure

I will inspect the pump assembly
Reply With Quote
  #10  
Old October 10th, 2021, 14:15
JerryG11 JerryG11 is offline
NAXJA Forum User
 
Join Date: Oct 2021
Location: OR
Posts: 8
Re: Crank No Start/No Fuel Pressure

I pulled the pump and everything checks out. I have a quick 12v and it sounds just fine. Still nothing
Reply With Quote
  #11  
Old October 10th, 2021, 17:59
8Mud's Avatar
8Mud 8Mud is offline
NAXJA Forum User
 
Join Date: Sep 2003
Location: Central Germany
Posts: 8,676
Re: Crank No Start/No Fuel Pressure

A long shot but I had one with a jello-like varnish in the fuel lines. I disconnected at the filter and blew compressed air into the line and out the fuel rail at the regulator, an amazing amount of crap came out.
Reply With Quote
  #12  
Old October 11th, 2021, 10:58
JerryG11 JerryG11 is offline
NAXJA Forum User
 
Join Date: Oct 2021
Location: OR
Posts: 8
Re: Crank No Start/No Fuel Pressure

Well add another one to the books for shitty fuel pumps. My Bosch pump came into the mail today. It was just installed and it's running strong. Smh 4th time is the charm apparently.
Reply With Quote
  #13  
Old October 11th, 2021, 16:47
lawsoncl lawsoncl is offline
NAXJA Forum User
 
Join Date: Jan 2006
Location: North Idaho
Posts: 5,589
Re: Crank No Start/No Fuel Pressure

Quote:
Originally Posted by JerryG11 View Post
Well add another one to the books for shitty fuel pumps. My Bosch pump came into the mail today. It was just installed and it's running strong. Smh 4th time is the charm apparently.
What brand were the duds? For something like a fuel pump or wheel bearing hubs that are a pain to do, I always go for quality parts. I've been burnt too many times on cheap chinese grade parts.
Reply With Quote
  #14  
Old October 12th, 2021, 18:28
JerryG11 JerryG11 is offline
NAXJA Forum User
 
Join Date: Oct 2021
Location: OR
Posts: 8
Re: Crank No Start/No Fuel Pressure

Trugrade was the brand of pump that I used. $60 at AutoZone. Luckily I got a killer deal on the Bosch pump because it was "open box" on Amazon. $10 for an unused pump is A-OK in my book
Reply With Quote
  #15  
Old October 13th, 2021, 06:30
old_man's Avatar
old_man old_man is offline
NAXJA Member
 
Join Date: May 2003
Location: Loveland, Colorado
Posts: 15,869
Re: Crank No Start/No Fuel Pressure

I would have voted for a bad hose from the fuel pump to the tank exit, a clogged fuel filter, or clogged fuel lines.

Oh, by the way, it will run better if you put some gas in the tank
__________________
Tom Houston - Former Colorado Chapter President, current Treasurer , Terminal Adrenaline Junkie, and Rocket Scientist
Loveland, Colorado My teardrop build
You're just jealous because the voices don't talk to you.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1996 4.0l no crank/no fuel/no start SwampyMJ OEM Tech Discussion 2 September 2nd, 2020 19:45
No Crank, No Fuel, No Start, All Sens Pwr'd crwdwg OEM Tech Discussion 4 August 7th, 2018 11:44
Fuel pump help; crank, no start. kujito Colorado Chapter 0 July 7th, 2010 06:58
fuel pressure when key is on, lose fuel pressure when try and start k.allen90 OEM Tech Discussion 8 May 26th, 2010 16:43
spark fuel crank no start doaxj OEM Tech Discussion 13 November 15th, 2003 05:36


All times are GMT -7. The time now is 07:57.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014