NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old August 11th, 2017, 14:31
Tony the Liger Tony the Liger is offline
NAXJA Forum User
 
Join Date: Aug 2017
Location: USA
Posts: 38
Temperature jumping from warm to hot and back again

Just completed the following on my new-to-me '00 XJ: replaced the valve cover gasket, a pinion seal, steering stabilizer shock, two axle U-joints, one wheel cylinder, and one set of brake shoes. On my way home from the garage, the XJ started to overheat a bit.

This is the first time it has overheated on me. I've only had it a few weeks and haven't driven it much, but I bought it in a town that's around three hours away from me, so I drove it around town and on the interstate for well over three consecutive hours on the day I bought it and didn't experience any overheating whatsoever. After warming up today, the temp sat just a hair past 210, then gradually climbed to the first notch past 210. I made it home by that point and parked it for a couple hours. After letting it sit, I took it up the road and back, and in that time the temp climbed to the same point, sat for a few minutes, then out of nowhere it spiked to the notch below 260. It sat there for a few second, then dropped back to just above 210. Sat for a few more seconds, then did it all over again.

Hoping the thermostat's sticking and I can get by with a $12 or so fix. Any thoughts?
Reply With Quote
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
99 xj runs horrible warm pinging stalls hard restart when warm 96xjdennis OEM Tech Discussion 0 January 9th, 2015 05:50
Jumping Back In HossHoffer Colorado Chapter 1 April 16th, 2013 18:42
RPM's jumping around XJSteven OEM Tech Discussion 4 August 1st, 2012 21:14
JUmping the XJ Egodfrey North Atlantic Chapter 16 October 12th, 2011 11:06
Think he was jumping?? mattyj SoCal Chapter 10 July 14th, 2009 21:53


All times are GMT -7. The time now is 22:00.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014