NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old October 27th, 2007, 15:36
Fred's Avatar
Fred Fred is offline
NAXJA Member #15
 
Join Date: Jun 2002
Location: Colorado Springs, CO
Posts: 4,194
2000 XJ 4.0 Intermittent No Start

All right, actually it's 99 in a WJ, but the engine is the same as the 2000 XJ.

I've been having an intermittent no start problem. Seems to happen after the Jeep is warmed up when my wife is out running errands. It still turns over, just won't fire. It has never happened first thing in the morning going to work, or coming home in the evening. It seems as though if it is left to sit for at least 1/2 hour it will start with no problem.

It runs well. I've recently replaced the tranny speed sensor, and the neutral safety switch, which I thought might have been the problem. My OBD II reader does not show any problem when it is not starting.

I'm afraid I may actually have to take it to the dealer, and I'm also afraid they'll pronounce it "fixed." and it won't be. I'll just be out time and money.

Fred
__________________
[Q. Why do the British drink warm beer?
A. Lucas wires their refrigerators too.
Reply With Quote
  #2  
Old October 27th, 2007, 16:07
JNickel101's Avatar
JNickel101 JNickel101 is offline
NAXJA Forum User
 
Join Date: Apr 2007
Location: Alamogordo, NM
Posts: 5,501
Re: 2000 XJ 4.0 Intermittent No Start

is it throwing any codes????

EDIT: missed that part of your post....

it never throws the CEL? you dont even get a "no bus" on the odometer?
Reply With Quote
  #3  
Old October 27th, 2007, 16:27
JNickel101's Avatar
JNickel101 JNickel101 is offline
NAXJA Forum User
 
Join Date: Apr 2007
Location: Alamogordo, NM
Posts: 5,501
Re: 2000 XJ 4.0 Intermittent No Start

I'll probably get flamed for this, but my first guess would be the CPS (crank position sensor) - but usually if that is bad, it will throw a code.
Reply With Quote
  #4  
Old October 27th, 2007, 16:52
Fred's Avatar
Fred Fred is offline
NAXJA Member #15
 
Join Date: Jun 2002
Location: Colorado Springs, CO
Posts: 4,194
Re: 2000 XJ 4.0 Intermittent No Start

I'm inclined to that answer myself, but I don't understand why it doesn't throw a code.

Fred
__________________
[Q. Why do the British drink warm beer?
A. Lucas wires their refrigerators too.
Reply With Quote
  #5  
Old October 28th, 2007, 07:15
ahm's Avatar
ahm ahm is offline
NAXJA Forum User
 
Join Date: May 2006
Location: Long Island NY
Posts: 60
Re: 2000 XJ 4.0 Intermittent No Start

check the wiring along firewall(not the big one), it has wires for CPS & Cam sensor, and goes to computer. Check for contiuity from one end to other. I replaced cam & crank sensor & truck still runs sometimes and wont start others. Jeep checked sensors & they were good & they werent sure what to do next. goodluck
Reply With Quote
  #6  
Old October 28th, 2007, 21:42
scorpio_vette's Avatar
scorpio_vette scorpio_vette is offline
NAXJA Forum User
 
Join Date: Sep 2005
Location: Milwaukee Wisconsin
Posts: 1,626
Re: 2000 XJ 4.0 Intermittent No Start

there's a 50/50 chance of the cps throwing a code. to many people depend on the cps throwing a code and therefore overlook the cps sensor. often times it still turns out to be that.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
AC on 2000 XJ intermittent snowjeep OEM Tech Discussion 1 August 17th, 2007 06:25
2000 classic Cruise Control intermittent at best pwoens OEM Tech Discussion 15 August 10th, 2007 06:18
2000 XJ Sport A/C Intermittent Failure? rbarton OEM Tech Discussion 7 July 7th, 2007 14:03
flooding/no start intermittent thall OEM Tech Discussion 11 January 13th, 2007 12:13
VERY strange & intermittent no start TK99XJ OEM Tech Discussion 8 October 3rd, 2006 11:53


All times are GMT -7. The time now is 17:00.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014