NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old January 31st, 2006, 16:10
tgregg tgregg is offline
NAXJA Member #1444
 
Join Date: Jan 2006
Location: Oak Hills, CA top of Cajon Pass
Posts: 500
Just Turned Off

I'm reposting this to rephrase it. Today after running fine all morning the Jeep just turned off. Everything worked and it cranked over it was just dead. It sounded like when you crank the motor without the ignition turned on. After 30 minutes it fired right up. I did nothing but check all the PDC fuses. I'm scared now to take it out until I figure out what caused the problem as I don't want to get stranded. I'm thinking: vapor lock, auto shut down relay, ignition switch, or ??
Any thoughts?
Reply With Quote
  #2  
Old January 31st, 2006, 16:12
4xBob 4xBob is offline
NAXJA Forum User
 
Join Date: May 2003
Location: Prince George, BC, Canada
Posts: 434
Re: Just Turned Off

That is classic CPS failure. It can be temperature dependant, cutting out when it gets hot. There are other possibilities, but CPS is the most likely.
Reply With Quote
  #3  
Old January 31st, 2006, 17:00
tgregg tgregg is offline
NAXJA Member #1444
 
Join Date: Jan 2006
Location: Oak Hills, CA top of Cajon Pass
Posts: 500
Re: Just Turned Off

What is a CPS?? All these initials are new to me.
Reply With Quote
  #4  
Old January 31st, 2006, 17:50
tgregg tgregg is offline
NAXJA Member #1444
 
Join Date: Jan 2006
Location: Oak Hills, CA top of Cajon Pass
Posts: 500
Re: Just Turned Off

OK, crankshaft position sensor. I went through all the possibles in the FSM index. Is that consensus guys? Gets hot, quits, cools off runs. I sure like my 69 CJ5 better and better. I can work on it!!
It looks like I need to buy a code reader if I'm going to work on this thing. It seems constant.
Reply With Quote
  #5  
Old January 31st, 2006, 19:22
baldwins89xj's Avatar
baldwins89xj baldwins89xj is offline
NAXJA Forum User
 
Join Date: May 2005
Location: red lion pa
Posts: 44
Re: Just Turned Off

tgregg, i had the same problem with a 90 4cyl xj. once it was replaced(cps) it never gave me any more problems.i would say thats the culprit.
Reply With Quote
  #6  
Old January 31st, 2006, 20:02
ChiXJeff's Avatar
ChiXJeff ChiXJeff is offline
Curmudgeon
 
Join Date: May 2002
Location: SE MN
Posts: 8,818
Re: Just Turned Off

Almost certainly the crankshaft position sensor.

Mine crapped out on me a few years ago, at 70 mph in the center lane on I-94 southbound out of Milwaukee. No fun at all. Managed to get it to limp to within a few miles of home.
__________________
ChiXJeff
Lifetime member

"Jeeps are Cherokees. All other models are wannabes." Deb. K.
Reply With Quote
  #7  
Old January 31st, 2006, 20:08
tgregg tgregg is offline
NAXJA Member #1444
 
Join Date: Jan 2006
Location: Oak Hills, CA top of Cajon Pass
Posts: 500
Re: Just Turned Off

Thanks, a new one goes on tomorrow.
Reply With Quote
  #8  
Old February 1st, 2006, 20:50
lawsoncl lawsoncl is offline
NAXJA Forum User
 
Join Date: Jan 2006
Location: North Idaho
Posts: 5,250
Re: Just Turned Off

BTW, a bad CPS will generally not set an error code.
Reply With Quote
  #9  
Old February 2nd, 2006, 05:11
tgregg tgregg is offline
NAXJA Member #1444
 
Join Date: Jan 2006
Location: Oak Hills, CA top of Cajon Pass
Posts: 500
Re: Just Turned Off

OK, I changed it out yesterday. By the way the dealer charged me $136 for the sensor. Now I just wait nervously to see if it fixes the problem. Seems like it should but until I get it real HOT I won't be sure.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
unknown motor running after engine turned off ibjeepin821 OEM Tech Discussion 1 July 2nd, 2005 05:17
8.25" turned by hand does what...? Purple Modified Tech Discussion 13 April 17th, 2005 18:09
Spuddering when the key has been turned off. skog OEM Tech Discussion 7 September 16th, 2004 09:00
Can we get the img tags turned on in the Intermountain Chapter forum? Handlebars User Support, Questions and Suggestions 2 April 26th, 2004 21:52
Drums turned out of round vancebreck OEM Tech Discussion 3 October 21st, 2003 07:46


All times are GMT -7. The time now is 07:35.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014