NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old August 9th, 2005, 11:18
cbwymore cbwymore is offline
NAXJA Forum User
 
Join Date: Sep 2003
Location: Rhododendron, OR
Posts: 20
XJ No start. Getting code P1694

My wife was driving our 2000 XJ yesterday when it lost power and stopped running. It cranks but won't start. All electrical works but the gages and the excelerator pedal is about half way down.

I pulled the codes and got P1694, "Fault In Companion Module
No CCD/J1850 messages received from the powertrain control module-Asian transmission." The digital odometer is also displaying "No Bus"

I tried starting in N and 1/2 between N and P still no start. Fuses all look good.

Any help would be greatly appreciated.

Last edited by cbwymore; August 9th, 2005 at 11:21.
Reply With Quote
  #2  
Old August 9th, 2005, 12:13
Timber's Avatar
Timber Timber is offline
NAXJA Forum User
 
Join Date: Sep 2004
Location: Slohio
Posts: 1,779
Re: XJ No start. Getting code P1694

This comes from Mitchell manuals on-line.

"DTC P1694 will set if no CCd bus messages are received from PCM for 20 seconds or invalid messages are received for 20 seconds.

Possible Causes
CCD Bus (-) circuit open between PCM and TCM.
CCD Bus (+) circuit open between PCM and TCM.
Transmission CCD bus wiring damaged.
Faulty TCM.

Diagnostic Procedure
1. Using scan tool, clear TCM DTCs. Start engine and let idle for at least 2 minutes. Using scan tool, retrieve TCM DTCs. If DTC P1694 returns, go to next step. If DTC P1694 does not return, go to step 5.

2. Check instrument cluster gauges for proper operation. If fuel gauge and speedometer operate properly, go to next step. If fuel gauge and speedometer do not operate properly, see appropriate INSTRUMENT PANELS article.

3. Turn ignition off. Disconnect Gray PCM harness connector. PCM is located at left front of engine compartment. Disconnect TCM harness connector. Measure resistance of CCD BUS (-) circuit (White/Black wire) between TCM harness connector and Gray PCM harness connector. If resistance is more than 5 ohms, repair open in CCd BUS (-) circuit (White/Black wire). If resistance is 5 ohms or less, go to next step.

4. Measure resistance of CCD BUS (+) circuit (Violet/Brown wire) between TCM harness connector and Gray PCM harness connector. If resistance is more than 5 ohms, repair open in CCd BUS (+) circuit (Violet/Brown wire). If resistance is 5 ohms or less, replace TCM.

5. Conditions necessary to set DTC P1694 are currently not present. Inspect related wiring and harness connectors. See WIRING DIAGRAMS. Repair as necessary. If no problem is found, check for broken, bent, backed-out or corroded terminal pins. Check for chafed, pierced or partially broken wires inside insulation. Repair as necessary.
Reply With Quote
  #3  
Old August 9th, 2005, 13:03
cbwymore cbwymore is offline
NAXJA Forum User
 
Join Date: Sep 2003
Location: Rhododendron, OR
Posts: 20
Re: XJ No start. Getting code P1694

Thank you.

I deleted the code but engine does not start. After tring to start it the code comes back. Instrument cluster gauges do not work.
Reply With Quote
  #4  
Old August 9th, 2005, 20:51
cbwymore cbwymore is offline
NAXJA Forum User
 
Join Date: Sep 2003
Location: Rhododendron, OR
Posts: 20
Re: XJ No start. Getting code P1694

What/Where is the TCM?
thanks.
Reply With Quote
  #5  
Old August 9th, 2005, 23:24
MAP's Avatar
MAP MAP is offline
NAXJA Forum User
 
Join Date: Mar 2003
Location: Wilmington, California
Posts: 150
It's probably your CPS.

I had this happen last year on my 99XJ. The cluster wouldn't work and the odometer said no bus.

What happened is that the CPS shorted. This caused the engine computer to shut itself off(i.e. it has short protection circuitry)

Disconnect your crankshaft position sensor then put the ignition key in the on position.
If the instrument cluster starts to work, once the CPS is disconnected, then you know it is shorted. You can verify this by checking with an ohmeter.
Replace the CPS and it should be fine.

MAP
Reply With Quote
  #6  
Old August 10th, 2005, 07:04
cbwymore cbwymore is offline
NAXJA Forum User
 
Join Date: Sep 2003
Location: Rhododendron, OR
Posts: 20
Re: XJ No start. Getting code P1694

Thanks! I disconnect the CPS and the gages work now! How do I test it. Haynes manual says to check continuity between B and C there is 3 terminals and none are marked.

Thanks again!
Reply With Quote
  #7  
Old August 10th, 2005, 10:26
MAP's Avatar
MAP MAP is offline
NAXJA Forum User
 
Join Date: Mar 2003
Location: Wilmington, California
Posts: 150
Re: XJ No start. Getting code P1694

The CPS is shorted. On a good CPS, none of the pins should be shorted. Just test between any 2 terminals, I can almost guarantee 2 of those pins are shorted. You need to replace the CPS.

MAP
Reply With Quote
  #8  
Old August 10th, 2005, 11:48
cbwymore cbwymore is offline
NAXJA Forum User
 
Join Date: Sep 2003
Location: Rhododendron, OR
Posts: 20
Re: XJ No start. Getting code P1694

great thanks! i've replaced on an 95 so i know the drill.
thanks again guys!
Reply With Quote
  #9  
Old August 10th, 2005, 20:34
cbwymore cbwymore is offline
NAXJA Forum User
 
Join Date: Sep 2003
Location: Rhododendron, OR
Posts: 20
Re: XJ No start. Getting code P1694

That was it, replaced the CPS and runs fine. Thanks!
Reply With Quote
  #10  
Old October 30th, 2008, 22:18
ddryden9 ddryden9 is offline
NAXJA Forum User
 
Join Date: Aug 2007
Location: Tucson, Az
Posts: 1
Re: XJ No start. Getting code P1694

This thread helped me with my daughters 97 XJ, shorted Crankshaft sensor, shut down the PCM. The main clue is that none of the gauges work, no fuel no voltage, no workie!
This sensor has a long history in the 4.0L engine. Prior to 96 it was a connection problem getting the low voltage signal into the PCM. It's just a induction coil, does not go bad, it's the tin plated connector. Wiping the contacts clean every year of so keeps it working (as well as replacing the unit). On my 90 XJ I replace the connector with gold plated pins & sockets like on computer equipment no more problems...
Interesting the Chrysler added an Amplifier to the Crankshaft sensor that can short out and kill and engine instead of spending less $$ on gold plated connections.

Progress! Dave D.
Reply With Quote
  #11  
Old December 3rd, 2008, 18:19
XJ Ron XJ Ron is offline
NAXJA Forum User
 
Join Date: Aug 2006
Location: Bradenton, FL
Posts: 22
Re: XJ No start. Getting code P1694

Thanks God for this post!

Drove to work yesterday and all was fine...came out to head home and the 99 wouldn't start...noticed the gauges did not work ...everything else was fine...doorlocks, lights, powerseats etc....

myself and 3 others worked on it for 2 hrs....pulled every fuse/ connection we could fine....Was absolutly stumped!

got home and got on the net....man I love that advance search option!

checked the CPS...just like yours...disconnect the CPS and gauges work fine....replace CPS....started on first try!

YOU GOT TO LOVE THIS PLACE!

Thanks again!
Reply With Quote
  #12  
Old June 26th, 2010, 12:04
BULLDOGTEN BULLDOGTEN is offline
NAXJA Forum User
 
Join Date: Jun 2010
Location: Virginia
Posts: 1
Post Re: XJ No start. Getting code P1694

99 JEEP CHER CLASSIC WAS RUNNING AND THEN NO START. BOUGHT A CEN TEC SCANNER FROM HARBOR FREIGHT. ORIGINAL PRICE OF 99722 WAS $160, ON SALE FOR $90, WITH NRA HARBOR FREIGHT COUPON THE FINAL PRICE WAS $72. CAME WITH EVERYTHING INCLUDED.

ANYWAY, HAD CODE P1694. NEVER USED THIS SITE BEFORE. CHANGED CPS AND THAT WAS THE PROBLEM. I BOUGHT THE CPS FROM NAPA AND I DID THINK $85 WAS EXPENSIVE FOR THIS. YES, MY GAUGES WENT DEAD AS DID THE ENGINE STARTING. IT WOULD TURN OVER. AS SOON AS I UNPLUGED THE CPS THE GUAGES WORKED AND AUTO STARTED AS SOON AS I PLUGED IN THE NEW CPS.

JUST SIGNED UP. THANK YOU FOR A GREAT SITE AND THE VALUABLE INFORMATION.
Reply With Quote
  #13  
Old June 26th, 2010, 12:31
joe_peters joe_peters is offline
NAXJA Forum User
 
Join Date: Apr 2008
Location: Grants Pass, OryGun
Posts: 13,746
Re: XJ No start. Getting code P1694

Welcome to !

Glad you got yours fixed.

FYI, using all CAPS is like shouting, and it makes your post hard to read.
Reply With Quote
  #14  
Old July 24th, 2010, 08:11
jimbow912's Avatar
jimbow912 jimbow912 is offline
NAXJA Forum User
 
Join Date: Apr 2007
Location: Brockton
Posts: 129
Re: XJ No start. Getting code P1694

Quote:
Originally Posted by Timber View Post
This comes from Mitchell manuals on-line.

"DTC P1694 will set if no CCd bus messages are received from PCM for 20 seconds or invalid messages are received for 20 seconds.

Possible Causes
CCD Bus (-) circuit open between PCM and TCM.
CCD Bus (+) circuit open between PCM and TCM.
Transmission CCD bus wiring damaged.
Faulty TCM.

Diagnostic Procedure
1. Using scan tool, clear TCM DTCs. Start engine and let idle for at least 2 minutes. Using scan tool, retrieve TCM DTCs. If DTC P1694 returns, go to next step. If DTC P1694 does not return, go to step 5.

2. Check instrument cluster gauges for proper operation. If fuel gauge and speedometer operate properly, go to next step. If fuel gauge and speedometer do not operate properly, see appropriate INSTRUMENT PANELS article.

3. Turn ignition off. Disconnect Gray PCM harness connector. PCM is located at left front of engine compartment. Disconnect TCM harness connector. Measure resistance of CCD BUS (-) circuit (White/Black wire) between TCM harness connector and Gray PCM harness connector. If resistance is more than 5 ohms, repair open in CCd BUS (-) circuit (White/Black wire). If resistance is 5 ohms or less, go to next step.

4. Measure resistance of CCD BUS (+) circuit (Violet/Brown wire) between TCM harness connector and Gray PCM harness connector. If resistance is more than 5 ohms, repair open in CCd BUS (+) circuit (Violet/Brown wire). If resistance is 5 ohms or less, replace TCM.

5. Conditions necessary to set DTC P1694 are currently not present. Inspect related wiring and harness connectors. See WIRING DIAGRAMS. Repair as necessary. If no problem is found, check for broken, bent, backed-out or corroded terminal pins. Check for chafed, pierced or partially broken wires inside insulation. Repair as necessary.
help i have the same problem i did all this and found nothing what should i do now. please help
Reply With Quote
  #15  
Old July 24th, 2010, 08:13
jimbow912's Avatar
jimbow912 jimbow912 is offline
NAXJA Forum User
 
Join Date: Apr 2007
Location: Brockton
Posts: 129
Re: XJ No start. Getting code P1694

here's the thing the motor will die and will start u after a bit and run fine and no code pops up one time it did and i got the code P1694
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help, 92 XJ Sport Hard to Start; Rough Idle rumncoke2004 OEM Tech Discussion 5 April 28th, 2005 18:46
93 XJ WILL NOT START! Please help ASAP!! Dead in Parking Lot! NHxj4x4 OEM Tech Discussion 19 January 2nd, 2005 16:38
IN/OH/PA -> 88 XJ Parting out...PICTURES and SOME FREE JUNK! TheGirlfriendYJ For Sale: Private Party Only. XJ ITEMS ONLY 2 November 30th, 2004 17:16
Code reader for 1990 XJ 4.0??? bn6339 OEM Tech Discussion 4 October 5th, 2004 22:44


All times are GMT -7. The time now is 21:51.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014