NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old October 31st, 2017, 21:45
Willie474747 Willie474747 is offline
NAXJA Forum User
 
Join Date: Oct 2017
Location: Kansas city
Posts: 5
Only one headlight working

Only one headlight working . Tried 2 new headlights and still doesn’t work. Any ideas what to check next? Thanks
Reply With Quote
  #2  
Old October 31st, 2017, 22:31
Heavyopp Heavyopp is offline
NAXJA Member
 
Join Date: Jan 2017
Location: Middlesex, NJ
Posts: 518
Re: Only one headlight working

ground at the bad headlight would be my 1st thought
Reply With Quote
  #3  
Old November 1st, 2017, 05:44
Bent's Avatar
Bent Bent is offline
Only Slightly Psychotic
 
Join Date: Feb 2003
Location: REDLANDS, CA. (SoCal)
Posts: 7,446
Re: Only one headlight working

Broken/separated wire at the back side of the plug. Maybe dirty contacts in the plug.
__________________
Gravity is a fickle mistress.
Ethan: "What did you think would happen?"
'01 XJ • 4.0 • AW4 • 231 • Modified
'87 MJ • 4.0 • AW4 • 231 • D-44 • Stock-ish
SoCal Chapter VP
Reply With Quote
  #4  
Old November 1st, 2017, 09:13
Green Mesa XJ's Avatar
Green Mesa XJ Green Mesa XJ is offline
NAXJA Forum User
 
Join Date: Aug 2004
Location: Pensacola, FL
Posts: 1,130
Only one headlight working

On a 91 XJ I had the drivers side ground break at the plug. Soldered in a replacement socket to fix it.

Other place to check is the headlight harness plug near (sort of underneath ) the air filter housing and computer on the 1991-2 XJ


Sent from my iPhone using Tapatalk
Reply With Quote
  #5  
Old November 8th, 2017, 19:44
Willie474747 Willie474747 is offline
NAXJA Forum User
 
Join Date: Oct 2017
Location: Kansas city
Posts: 5
Re: Only one headlight working

Went to use high beams and both work. Not a plug issue or a ground issue but was a faulty 10a fuse low beam relay in cabin that had blown out from trying HId headlight kit. Problem fixed with a $1.00 part. Go figure
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
one headlight barely working? ptimhere OEM Tech Discussion 9 July 21st, 2017 07:01
radio quit working after headlight switch replace max419 OEM Tech Discussion 3 August 25th, 2011 11:39
headlight ? #2 f-a-t-b-o-y OEM Tech Discussion 8 November 17th, 2008 18:40
headlight PN shimmy OEM Tech Discussion 4 July 2nd, 2004 23:56
Headlight Harness Upgrade- Need to find stock headlight relay XJEEPER Modified Tech Discussion 5 September 26th, 2003 13:26


All times are GMT -7. The time now is 06:24.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014