NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old August 26th, 2011, 10:38
supertubesocks's Avatar
supertubesocks supertubesocks is offline
NAXJA Forum User
 
Join Date: Aug 2011
Location: Brea
Posts: 173
91 4.0 wont start please help!

Here's the quick version.
I have a 91 xj with 4.0 automatic 231j tcase.

The jeep was sitting for years and i just got it running. Then was forced to rebuild the engine. We got the engine back in and it wont start. The engine is getting fuel and spark. the exhaust is getting warm but just wont fire.

Here is the list of new parts.
plugs
plug wires
cap n rotor
Header
fuel pump and filter
crank position sensor
harmonic balancer
cam shaft

Please help with anything else to try.
Thanks in advance.
Reply With Quote
  #2  
Old August 26th, 2011, 11:25
87manche's Avatar
87manche 87manche is offline
NAXJA Forum User
 
Join Date: Oct 2005
Location: Ohio
Posts: 15,385
Re: 91 4.0 wont start please help!

timing

assuming you had the distributor out, double check it.
Reply With Quote
  #3  
Old August 26th, 2011, 11:34
kdub41 kdub41 is offline
NAXJA Forum User
 
Join Date: Oct 2009
Location: hemet
Posts: 798
Re: 91 4.0 wont start please help!

probably not it but check the neutral safety switch.I have a 96 cherokee and mine wouldnt start except for in neutral then it wouldnt start at all took out the safety switch and it was all gummed up. I had my buddy help me with it but i know how to do it now.
Reply With Quote
  #4  
Old August 26th, 2011, 12:28
RyanKnol's Avatar
RyanKnol RyanKnol is offline
NAXJA Forum User
 
Join Date: Jul 2011
Location: Chilliwack BC
Posts: 8
Re: 91 4.0 wont start please help!

are the injectors firing? I had that issue once where after cleaning the injectors and putting them back in, i messed up the order of the wires, and it wouldnt start.

But I dont think youd be getting spark or anything if this were the case.
Reply With Quote
  #5  
Old August 26th, 2011, 12:56
ehall's Avatar
ehall ehall is offline
NAXJA Member
 
Join Date: Dec 2007
Location: Southern Maryland
Posts: 9,408
Re: 91 4.0 wont start please help!

Quote:
Originally Posted by kdub41 View Post
probably not it but check the neutral safety switch
it wouldn't turn over with a bad NSS
__________________
.
my '91 beater rebuild
Reply With Quote
  #6  
Old August 26th, 2011, 12:59
ehall's Avatar
ehall ehall is offline
NAXJA Member
 
Join Date: Dec 2007
Location: Southern Maryland
Posts: 9,408
Re: 91 4.0 wont start please help!

Quote:
Originally Posted by supertubesocks View Post
We got the engine back in and it wont start. The engine is getting fuel and spark. the exhaust is getting warm but just wont fire.
Hold the throttle down while you crank and see if it catches, this will bypass the IAC.

How are you testing fuel to the cylinders?
__________________
.
my '91 beater rebuild
Reply With Quote
  #7  
Old August 26th, 2011, 14:00
supertubesocks's Avatar
supertubesocks supertubesocks is offline
NAXJA Forum User
 
Join Date: Aug 2011
Location: Brea
Posts: 173
Re: 91 4.0 wont start please help!

I've checked the fuel using the relief valve on the rail, and also used a stethascope on the injectors, they are all clicking.
We suspect timing is the issue, but it seems like the rotor is pointing at plug#1. Is there any other components in the ignition system to check?
The engine cranks and tries to fire but just wont run.
Reply With Quote
  #8  
Old August 26th, 2011, 14:14
kdub41 kdub41 is offline
NAXJA Forum User
 
Join Date: Oct 2009
Location: hemet
Posts: 798
Re: 91 4.0 wont start please help!

whooops i didnt see that is was turning over.
Reply With Quote
  #9  
Old August 26th, 2011, 17:00
nblanton nblanton is offline
NAXJA Forum User
 
Join Date: Sep 2006
Location: Raleigh, NC
Posts: 120
Re: 91 4.0 wont start please help!

Do you have spark?
Reply With Quote
  #10  
Old August 26th, 2011, 17:14
supertubesocks's Avatar
supertubesocks supertubesocks is offline
NAXJA Forum User
 
Join Date: Aug 2011
Location: Brea
Posts: 173
Re: 91 4.0 wont start please help!

Quote:
Originally Posted by nblanton View Post
Do you have spark?
Yes, we pulled the wires and put an old plug on them.

Originally we were only getting one spark but then i replaced the cps and it's getting good spark.

Could it have anything to do with the wiring harness hooked up incorrectly?
There were 3 wires with ring terminals on the left side of the engine bay that i just grounded to the engine block.

Is there an ignition control module that i can check?
Reply With Quote
  #11  
Old August 27th, 2011, 06:38
djgrayxj djgrayxj is offline
NAXJA Forum User
 
Join Date: Nov 2008
Location: West Covina
Posts: 496
Re: 91 4.0 wont start please help!

Note from DJ
You might take a look at this posting
Renix distributor install walkthrough
http://www.naxja.org/forum/showthread.php?t=964617
Reply With Quote
  #12  
Old August 27th, 2011, 10:00
supertubesocks's Avatar
supertubesocks supertubesocks is offline
NAXJA Forum User
 
Join Date: Aug 2011
Location: Brea
Posts: 173
Re: 91 4.0 wont start please help!

Quote:
Originally Posted by djgrayxj View Post
Note from DJ
You might take a look at this posting
Renix distributor install walkthrough
http://www.naxja.org/forum/showthread.php?t=964617
Does that apply to HO distributors?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
86 2.8L wont start it turnsover but it wont start black86xj OEM Tech Discussion 12 April 2nd, 2010 15:38
Wont start; Rough Idle and then stalls when it does start MudslinginXJ OEM Tech Discussion 17 February 24th, 2008 07:30
wont crank wont start nothing 90xjpos OEM Tech Discussion 13 February 6th, 2007 10:52
turns over once, wont start sounds dead but wont jump maxaud OEM Tech Discussion 5 November 16th, 2006 15:07


All times are GMT -7. The time now is 00:48.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014