NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old December 8th, 2010, 18:18
hudson2000 hudson2000 is offline
NAXJA Forum User
 
Join Date: Dec 2010
Location: Antioch , Tn
Posts: 2
Need some insight and knowledge please !

I have a problem with my 1999 Jeep Cherokee. It has 177,000 miles, 10w30, 4.0 I6, 2x4. My problem is when I start the engine the oil pressure is where it should be. When I drive for ten to fifthteen min and the oil heats up and then I come to a stop or place the Jeep in park the oil pressure gauge drops to zero. There is no noise in the engine and no knocking that I can hear, the check gauges light comes on. When I put it back it drive , the gauge jumps back up where it is suppose to be and the light goes off. I change my oil every four to five thousand miles, rotate my tires, check fluids every other week.

Can somebody help me make sense of it. Or what they think I should do ? Thank you in advance.
Reply With Quote
  #2  
Old December 8th, 2010, 19:41
hubs97xj's Avatar
hubs97xj hubs97xj is offline
NAXJA Forum User
 
Join Date: May 2008
Location: Fort Wayne, IN
Posts: 4,433
Re: Need some insight and knowledge please !

Rent/borrow/buy an oil pressure test gauge, and see if your problem is really low pressure, or just a bad sender.
Reply With Quote
  #3  
Old December 8th, 2010, 19:45
in4aride's Avatar
in4aride in4aride is offline
NAXJA Member
 
Join Date: Jun 2008
Location: Montrose
Posts: 13,820
Re: Need some insight and knowledge please !

agreed, more likely to be a bad sensor. pressure drops a bit, but 0 sounds sketch
__________________
Grab a gear, let's go.
Reply With Quote
  #4  
Old December 8th, 2010, 19:54
hubs97xj's Avatar
hubs97xj hubs97xj is offline
NAXJA Forum User
 
Join Date: May 2008
Location: Fort Wayne, IN
Posts: 4,433
Re: Need some insight and knowledge please !

Yeah, that's my guess, but the tester is cheaper than the sender, and a lot cheaper than being wrong.
Reply With Quote
  #5  
Old December 8th, 2010, 19:57
in4aride's Avatar
in4aride in4aride is offline
NAXJA Member
 
Join Date: Jun 2008
Location: Montrose
Posts: 13,820
Re: Need some insight and knowledge please !

ha! isnt that the damn truth. check it out for sure
__________________
Grab a gear, let's go.
Reply With Quote
  #6  
Old December 8th, 2010, 20:19
Dads XJ Dads XJ is offline
NAXJA Forum User
 
Join Date: Dec 2009
Location: Milton WA
Posts: 126
Re: Need some insight and knowledge please !

Had same problem, replaced sender, all is well.
Reply With Quote
  #7  
Old December 8th, 2010, 22:27
98XJLongBuild 98XJLongBuild is offline
NAXJA Forum User
 
Join Date: May 2010
Location: San Jose, CA.
Posts: 382
Re: Need some insight and knowledge please !

Problem # 1 - ITS TWO WHEEL DRIVE hahahha JK atleast you made the right decsion and got a HEEP.

Problem # 2 - Replace the oil pressure sending unit, very common for cherokees. If you look right above the oil filter you will see it there. What I did was I just put an Auto Guage on and I know it reads right all the time now.

With it going to zero and the CEL turning on it aounds like the sending unit. Also I tried a heavy grade oil like some 50W. The stock gauge seems to be able to read that about 98% of the time and for a daily driver thats pretty good.
Reply With Quote
  #8  
Old December 9th, 2010, 04:30
birchlakeXJ's Avatar
birchlakeXJ birchlakeXJ is offline
NAXJA Forum User
 
Join Date: Jan 2008
Location: Melrose, MN
Posts: 2,778
Re: Need some insight and knowledge please !

If your pressure TRULY was going to zero, you would hear it in the engine.

Most likely the oil pressure sending unit. I buy these directly from Jeep for best reliability/accuracy/mating with your factory gauge. Worth the extra $20. I have had poor luck with aftermarket oil pressure sending units.

As mentioned, getting your mitts on a MECHANICAL oil pressure gauge and confirming it is another step to peace of mind. Many parts stores rent this tool for a few bucks.
Reply With Quote
  #9  
Old December 9th, 2010, 05:28
Kevin108's Avatar
Kevin108 Kevin108 is offline
NAXJA Forum User
 
Join Date: Jul 2009
Location: Virginia Beach, VA
Posts: 362
Re: Need some insight and knowledge please !

This is very common and is almost always the sending unit. The exception is usually an 0331 head that cracked and was ignored letting ran watered-down gradually kill the bearings.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Some insight please mavrick OEM Tech Discussion 6 May 31st, 2009 08:45
Sigh...need new insight Tampa_XJ OEM Tech Discussion 15 June 13th, 2007 19:32
Those who are/have served, could use some insight... freerider15 Non-Tech / Off Topic 28 February 27th, 2007 08:58
With all of the probs I've had, need some insight. XJ91 Modified Tech Discussion 1 July 7th, 2004 17:07
Does any one have any insight?? To the following. XJ91 OEM Tech Discussion 9 August 2nd, 2003 18:56


All times are GMT -7. The time now is 12:24.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014