NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old April 11th, 2019, 13:25
Kuhnboy Kuhnboy is offline
NAXJA Forum User
 
Join Date: Apr 2019
Location: NY
Posts: 3
93 XJ Electrical problems

Hello all, this is my first post on here. To start with, I have a 1993 XJ 4.0 sport HO, four door, 4wd, with an auto trans. Ever since I got into an accident with it (rear ended a Nissan Murano and needed to replace the rad, and all the passenger side lights, and bent something in the front end) I've been having a problem where it will sputter and die. I noticed last night that while it's running, and I open my rear hatch, the outer taillight bulbs come on and the motor is about to shut off. And when the hatch is open and I hit the brake pedal, the lights by the shifter come on. So I know it's back feeding, but I'm not sure where. Recently I've replaced all spark plugs and wires, coil, cap and rotor, fuel pump, and crank position sensor. Could this be a ground that just got knocked loose? I haven't found any information anywhere on similar problems, so anything would be appreciated. Thank you for reading

Sent from my VS990 using Tapatalk
Reply With Quote
  #2  
Old April 11th, 2019, 18:22
mongolchuck mongolchuck is offline
NAXJA Forum User
 
Join Date: Sep 2010
Location: Iowa
Posts: 73
Re: 93 XJ Electrical problems

Definitely would start with grounds.
Reply With Quote
  #3  
Old April 11th, 2019, 21:59
Heavyopp Heavyopp is offline
NAXJA Member
 
Join Date: Jan 2017
Location: Middlesex, NJ
Posts: 729
Re: 93 XJ Electrical problems

Grounds -- refresh them all
Reply With Quote
  #4  
Old April 12th, 2019, 07:10
Kuhnboy Kuhnboy is offline
NAXJA Forum User
 
Join Date: Apr 2019
Location: NY
Posts: 3
93 XJ Electrical problems

Thank you for replying. I've gone through some grounds in the engine bay. I know there's more, and I believe there's one on the interior of the firewall? But how many in the rear of the vehicle?

Sent from my VS990 using Tapatalk
Reply With Quote
  #5  
Old April 12th, 2019, 07:41
Black1990jeep Black1990jeep is offline
NAXJA Forum User
 
Join Date: Apr 2018
Location: california
Posts: 223
Re: 93 XJ Electrical problems

there is a ground point in my 1990 xj on left side rear, behind the interior trim panel inside the cargo area, the panel behind the spare tire below the quarter window..
Reply With Quote
  #6  
Old April 12th, 2019, 11:40
Ghost's Avatar
Ghost Ghost is offline
Member Number 257
 
Join Date: Jun 2002
Location: Hartsville, South Carolina
Posts: 17,384
Re: 93 XJ Electrical problems

IIRC there is also a ground near the fuel pump pass through and the back of the body.
__________________
"...I need to wheel to be rejuvenated to fix things to wheel. It's a vicious cycle, but I love it."
Rick Pewe Ed: Petersons 4 Wheel and Off Road
member since 3/05/2001
Reply With Quote
  #7  
Old April 12th, 2019, 12:36
Kuhnboy Kuhnboy is offline
NAXJA Forum User
 
Join Date: Apr 2019
Location: NY
Posts: 3
93 XJ Electrical problems

I just pulled off the interior panel behind where the spare tire should be, and that ground was nasty. I cleaned it up, and it seemed to fix it. Now I just need to put some miles on and so some more testing. I'm surprised I didn't notice it a couple months ago when I was in there to fix the factory splice for the taillights. Thank you everyone for replying, I'll keep going through grounds if the problem persists.

Sent from my VS990 using Tapatalk
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
electrical problems XJRunner Modified Tech Discussion 4 April 17th, 2011 16:02
Electrical problems jimgrms Colorado Chapter 13 November 4th, 2009 14:39
WJ Electrical Problems Ertsride1 Tow Rigs and Trailers 4 November 2nd, 2009 15:15
Electrical (I hate electrical problems) Fidget360 OEM Tech Discussion 1 April 11th, 2009 22:09
Electrical Problems!!! Aquit45 OEM Tech Discussion 1 October 25th, 2005 18:47


All times are GMT -7. The time now is 05:48.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014