NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > Modified Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

Modified Tech Discussion Forum for Tech related discussion for Modified XJ's and MJ's.

Reply
 
Thread Tools Display Modes
  #1  
Old December 16th, 2012, 19:39
nev3636 nev3636 is offline
NAXJA Forum User
 
Join Date: Dec 2012
Location: fort carson
Posts: 5
i just finished aw4 to ax15 swap.. dash, blinkers, and tail/brake lights not working

i just joined this forum about 2 minutes ago so forgive me if i am doing something wrong, but here is my issue. i just finished swapping my aw4 for an ax15. all went well as far as mechanical aspects. when i started it i had no gauges working, no brake/tail lights, and no blinkers. i have a 98 xj 4.0, and it was an auto. i took the ax15 out of a 97, along with the clutch, flywheel, and ECU. to get the jeep to start i spliced the 7 and 8 wires on the gray harness that goes to the nss (bypassed the nss)... i checked all fuses and they are good. the other harness (black one) that went to the aw4 were speed sensors. im not sure what the other wires on the (grey harness) neutral safety module thing do but i am guessing they might have something to do with the dash and other lighting issues? anyone know what i should do here?
Reply With Quote
  #2  
Old December 17th, 2012, 03:24
TRAILREADYXJ's Avatar
TRAILREADYXJ TRAILREADYXJ is offline
NAXJA Forum User
 
Join Date: Nov 2004
Location: Raleigh NC
Posts: 1,118
Re: i just finished aw4 to ax15 swap.. dash, blinkers, and tail/brake lights not work

You aren't doing anything wrong (except it looks like you accidentally double posted, lol), and welcome!
Those things don't have anything to do with the ECU. It really sounds like you have a blown fuse...have you checked the ones under the hood?
The NSS affects weather or not it will start as well as the reverse lights. You said you spliced wires together here, so there's a chance you shorted out the back up lights, therefore blowing a fuse.
The main harness to the AW4 controls the shift and tc lockup solenoids, so it won't have to do with that either. Your speed sender is on the transfer case.
Reply With Quote
  #3  
Old December 17th, 2012, 08:10
nev3636 nev3636 is offline
NAXJA Forum User
 
Join Date: Dec 2012
Location: fort carson
Posts: 5
Re: i just finished aw4 to ax15 swap.. dash, blinkers, and tail/brake lights not work

Ok thanks... i checked all fuses last night and all looked good but i will check again here soon.
Reply With Quote
  #4  
Old December 17th, 2012, 08:56
sidewaysstarion's Avatar
sidewaysstarion sidewaysstarion is offline
Coffee Drinker
 
Join Date: Jan 2012
Location: Torrance, CA
Posts: 2,989
Re: i just finished aw4 to ax15 swap.. dash, blinkers, and tail/brake lights not work

Check the fuses in the passenger side kick panel as well.
Reply With Quote
  #5  
Old December 17th, 2012, 09:10
kastein's Avatar
kastein kastein is offline
NAXJA Member
 
Join Date: Jul 2009
Location: Longbranch WA / Central MA
Posts: 14,240
Re: i just finished aw4 to ax15 swap.. dash, blinkers, and tail/brake lights not work

You're probably going to get a CEL without a manual programmed ECU, but it will drive fine.

Sounds like a fuse to me, check the blue 15A minifuses in the PDC. I blew the engine management system one wheeling my 98 a while ago due to a shorted O2 sensor harness and ended up swapping out another of the 15A minifuses for it in the middle of the woods to get home, it worked great but exactly the things you listed stopped working when I did it.
__________________
My yard looks like Sanford & Sons.
Current crapcan fleet: LS swapped bobbed 79 J10 Honcho, 4x4 auto 4.0 8.25 swapped metric ton 88 MJ
CTeunuch: Sometimes I really wonder if this sport makes you insane, or it just attracts the mentally unstable.
Reply With Quote
  #6  
Old December 17th, 2012, 10:19
nev3636 nev3636 is offline
NAXJA Forum User
 
Join Date: Dec 2012
Location: fort carson
Posts: 5
Re: i just finished aw4 to ax15 swap.. dash, blinkers, and tail/brake lights not work

All fuses are good.. I found the problem, when i swapped out the pedal assembly the new one was bigger with the clutch and it knocked loose the junction block on the driers side i wiggled it and everything works properly now. Thanks alot for your suggestions and help.
Reply With Quote
  #7  
Old December 17th, 2012, 10:34
kastein's Avatar
kastein kastein is offline
NAXJA Member
 
Join Date: Jul 2009
Location: Longbranch WA / Central MA
Posts: 14,240
Re: i just finished aw4 to ax15 swap.. dash, blinkers, and tail/brake lights not work

Glad you got it fixed! And thanks for posting up the resolution, I never would have expected that to be the problem.
__________________
My yard looks like Sanford & Sons.
Current crapcan fleet: LS swapped bobbed 79 J10 Honcho, 4x4 auto 4.0 8.25 swapped metric ton 88 MJ
CTeunuch: Sometimes I really wonder if this sport makes you insane, or it just attracts the mentally unstable.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
high idle caused my dash lights/tail lights to go out?? wgregt OEM Tech Discussion 55 December 16th, 2012 18:16
i just finished aw4 to ax15 swap.. dash, blinkers, and tail/brake lights not working nev3636 Modified Tech Discussion 0 December 16th, 2012 18:15
'89 Comanche - front parking lights/dash lights not working YELLAHEEP OEM Tech Discussion 5 December 4th, 2008 15:56
Brake & Tail lights not working bubXJ OEM Tech Discussion 7 August 13th, 2007 21:23
tail light and dash lights not working 87xjeep OEM Tech Discussion 3 June 23rd, 2005 22:07


All times are GMT -7. The time now is 10:24.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014