NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old November 12th, 2005, 21:45
hulk hulk is offline
NAXJA Forum User
 
Join Date: Apr 2005
Location: hemet
Posts: 18
Angry new computer

Hey have any of you guys replaced your computer? And if so any advice? like did you only stick too the stealership? or did you have any aftermarket succes. i have a 95 XJ that keeps shutting off when i hit bumps. yeah its sort of weird. any ways i have replaced everything at least 3 times or more. the CPS- relays- fuel pump-ignition sitch-all connectors- and so forth. i have sent my computer in twice to be rebuilt. the company acknowledges a problem- but the problem never gets fixed. So i am done with it. WHERE SHOULD I BUY A NEW COMPUTER&HARNESS? SAVE ME BEFORE I GO TO A ZJ. THANKS IN ADVANCE FOR YOUR HELP.
Reply With Quote
  #2  
Old November 13th, 2005, 04:16
langer1's Avatar
langer1 langer1 is offline
NAXJA Forum User
 
Join Date: Jun 2005
Location: Mineral City,Ohio
Posts: 5,006
Re: new computer

I doubt the computer is your problem, a rebuilt computer is not even the same one. It would be hard to beleve you got two of them with the same problem.
Do you have a anti-thieft system?
Reply With Quote
  #3  
Old November 13th, 2005, 06:29
UNCC_99XJ's Avatar
UNCC_99XJ UNCC_99XJ is offline
Twisted Up
 
Join Date: Jan 2005
Location: Harrisburg, NC
Posts: 8,896
Re: new computer

I also doubt the computer is the issue, sounds like a loose wire somewhere. Have you started tracing wires at all?
Reply With Quote
  #4  
Old November 13th, 2005, 06:35
AJPulley AJPulley is offline
NAXJA Forum User
 
Join Date: Nov 2005
Location: South-eastern MA
Posts: 634
Re: new computer

You know, it could be the computer. My 87's will not de-energize the EGR solenoid. Really. I finally troubleshot it until I tested the correct wire comming right out of the computer. I don't understand it, but it still runs fine. So, I capped the vacume supply to the solenoid and since I had a new cat installed four years ago, I still pass emisions, in MA, with flying colors. Picces me off too since I spent a small chunk for a new EGR. So, just maybe it is.
Reply With Quote
  #5  
Old November 13th, 2005, 08:43
CheapXJ's Avatar
CheapXJ CheapXJ is offline
NAXJA Forum User
 
Join Date: Jun 2002
Location: 570, 813 or 303
Posts: 1,359
Re: new computer

Quote:
Originally Posted by hulk
SAVE ME BEFORE I GO TO A ZJ.
you want something less reliable?

go to a junkyard and grab another engine harness.

there will be a sticker on your comp w/ a number on it, match that nubmer if you can. if not, just make sure that you get the comp from another 91-95 w/ the same tranny.
Reply With Quote
  #6  
Old November 13th, 2005, 21:04
hulk hulk is offline
NAXJA Forum User
 
Join Date: Apr 2005
Location: hemet
Posts: 18
Thumbs down Re: new computer

Well its pretty odd guys. i have traced the wires, and did the old shake it till it almost breaks. but of course it wont respond in my driveway, but on the freeway, oh yeah not a problem. it is pretty odd. the first time my computer was rebuilt, when it would stall, it would shut off, but the ignition lights would stay on. like check engine, oil, and tempature, you know the lights you have right before you start your jeep. now when my xj stalls, everything goes dead, no power at all. then like both instances, if i wait about 30 secs the SOB fires right up, no problem. then when i check the codes, it tells me the old 55. HOW CAN THAT POSSIBLY BE.
Reply With Quote
  #7  
Old November 14th, 2005, 05:01
langer1's Avatar
langer1 langer1 is offline
NAXJA Forum User
 
Join Date: Jun 2005
Location: Mineral City,Ohio
Posts: 5,006
Re: new computer

There are a few electrical things the computer don't monitor.
If you had a failing ignition switch, that would not cause a code.
And explain why everything goes off, a bad relay in the anti-thieft could also cause it.

Last edited by langer1; November 14th, 2005 at 05:06.
Reply With Quote
  #8  
Old November 14th, 2005, 07:28
old_man's Avatar
old_man old_man is offline
NAXJA Member
 
Join Date: May 2003
Location: Loveland, Colorado
Posts: 15,973
Re: new computer

I have seen a bad battery cause what you describe. When it got bumped a couple of plates would short out. This is actually not that uncommon if the battery isn't tied down. Make sure the ground from the head to the firewall is intact. Around here a ECU from pull-n-save runs around $30.
__________________
Tom Houston - Former Colorado Chapter President, current Treasurer , Terminal Adrenaline Junkie, and Rocket Scientist
Loveland, Colorado My teardrop build
You're just jealous because the voices don't talk to you.
Reply With Quote
  #9  
Old November 14th, 2005, 07:38
langer1's Avatar
langer1 langer1 is offline
NAXJA Forum User
 
Join Date: Jun 2005
Location: Mineral City,Ohio
Posts: 5,006
Re: new computer

Quote:
Originally Posted by old_man
I have seen a bad battery cause what you describe. When it got bumped a couple of plates would short out. This is actually not that uncommon if the battery isn't tied down. Make sure the ground from the head to the firewall is intact. Around here a ECU from pull-n-save runs around $30.
Wouldn't that cause a code 12 "battery disconnect" code?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ITS not the TRANNY computer.....what is it? hangubus OEM Tech Discussion 14 May 27th, 2005 14:00
Differences between a 96 computer and a 99 computer xjj33p3r OEM Tech Discussion 6 March 13th, 2005 21:27
Computer reset question casm OEM Tech Discussion 0 September 5th, 2004 09:42
Engine computer - can someone help me please? jma OEM Tech Discussion 11 November 20th, 2003 10:58
Is the computer in my 90'(4.0,AW4,231) tuneable? goldxj OEM Tech Discussion 5 July 22nd, 2003 07:29


All times are GMT -7. The time now is 04:08.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014