NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old November 30th, 2007, 16:22
Ecomike's Avatar
Ecomike Ecomike is offline
NAXJA# 2091
 
Join Date: Dec 2006
Location: MilkyWay Galaxy
Posts: 15,367
96 OBD II engine misfire codes and rough idle

I need some ideas guys! My sons Ford Taurus, 96 lost the coolant recently due to a hose rupture. We fixed that. Now it wants to throw random cylinder # misfire codes, and it idles real rough especially when its cold, first start of the day. The idle smooths out when it warms up, and it stops throwing codes once it is good and hot!
I have a code scanner, and I have cleared the codes, and run it hot and cold, running tests in the driveway in gear and in park after clearing the codes. Only codes it has thrown so far are engine missfire cylinder numbers, and not always the same cylinder. It also posted a single Cl-fault on fuel system #2 once, but has not repeated that code since I cleared it.

Ideas????

My problem is I think it is the HV coil or secondary system, wires or ECM for the spark based on some other tests ( Iam planing more tests there right now), but it started right after it overheated???

Any good Ideas out there???

Oh, And just pretend it is a 96 Jeep 6 banger I am asking about!
__________________
Quote=8Mud: "Go ahead and put up the best fence you can build, I'll bet on some Mexican with a few dollars of nails and a pile of scrap lumber."
34 MPG , '85 2WD Cherokee Pioneer with custom installed, 64 hp, 2.2 L Nissan SD22 Diesel 5 spd Manual; & 4 Renix XJs, '87 Wagoneer 4.0, 4WD, 89-Cherokee, 4WD, '87 Cherokee 2WD, & '89 Cherokee Pioneer 2WD, all 4dr. #2091
Reply With Quote
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
4.0L Rough Engine Idle After Restart Following a Hot Soak wcbuyer OEM Tech Discussion 7 June 25th, 2007 01:02
Engine - rough idle & low temp Spidey OEM Tech Discussion 6 November 7th, 2006 21:54
Check engine light and rough idle! shelbyluvv OEM Tech Discussion 2 October 25th, 2006 18:42
Rough idle and dieing once engine is warm NitroDuck OEM Tech Discussion 11 September 13th, 2005 16:26
misfire off-idle beav350 OEM Tech Discussion 5 March 5th, 2005 22:31


All times are GMT -7. The time now is 14:51.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014