NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old November 21st, 2018, 15:57
xjcollecter's Avatar
xjcollecter xjcollecter is offline
NAXJA Forum User
 
Join Date: Nov 2018
Location: livermore CO
Posts: 5
87 xj cranks but wont start

OK i have an 87 xj two door with the 4.0 and a 5 speed. one day driving to work my throw out bearing went out. so when i got it home i replaced the bearing and went to pull it out of the garage but it just cranked. so i did some tests. Fuel presser is at 42 psi, but no spark or injector pulse. so i put a new cps in, and it fired up...... and then died. Started it again rpms went to around 2500 and it then died. After that it would only crank and still no spark or injector pulse. So another cps and it fired up once and ran and drove great. next morning no go, just cranking over. So with that said ive put a new icu,coil,adjusted the tps, and even tried a new ecu from my other 87. but ive gotten nothing. Anything helps.
Thanks
Reply With Quote
  #2  
Old November 21st, 2018, 16:49
lawsoncl lawsoncl is offline
NAXJA Forum User
 
Join Date: Jan 2006
Location: North Idaho
Posts: 4,863
Re: 87 xj cranks but wont start

Is the wiring to the CPS damaged?
Reply With Quote
  #3  
Old November 21st, 2018, 18:47
xjcollecter's Avatar
xjcollecter xjcollecter is offline
NAXJA Forum User
 
Join Date: Nov 2018
Location: livermore CO
Posts: 5
Re: 87 xj cranks but wont start

Quote:
Originally Posted by lawsoncl View Post
Is the wiring to the CPS damaged?
no,the wires are clean and not messed up in any way
Reply With Quote
  #4  
Old November 22nd, 2018, 06:52
cruiser54's Avatar
cruiser54 cruiser54 is offline
NAXJA Forum User
 
Join Date: Nov 2009
Location: Prescott, Az
Posts: 6,557
Re: 87 xj cranks but wont start

Quote:
Originally Posted by xjcollecter View Post
no,the wires are clean and not messed up in any way

Test the CPS output. http://cruiser54.com/?p=50

Clean the C101 connector. http://cruiser54.com/?p=24
Reply With Quote
  #5  
Old November 28th, 2018, 21:23
xjcollecter's Avatar
xjcollecter xjcollecter is offline
NAXJA Forum User
 
Join Date: Nov 2018
Location: livermore CO
Posts: 5
Re: 87 xj cranks but wont start

ok, ill try cleaning it in the morning and let you know what happens
Reply With Quote
  #6  
Old November 30th, 2018, 15:53
Ecomike's Avatar
Ecomike Ecomike is offline
NAXJA# 2091
 
Join Date: Dec 2006
Location: MilkyWay Galaxy
Posts: 15,264
Re: 87 xj cranks but wont start

Quote:
Originally Posted by xjcollecter View Post
ok, ill try cleaning it in the morning and let you know what happens
Just reinstall the CPS and move it closer to the Flex plate by making the mounting hole larger. I also found, at least on mine, that super thin washer between the bell housing and the CPS arm, doubled my cranking AC voltage.

My battery barely works right now, old like me, LOL, this month and she still fires right up after sitting for week. Also stock CPS mounting you need solid battery power at the starter to get peak cranking rpms to get enough CPS voltage for the ECU to see.
__________________
Quote=8Mud: "Go ahead and put up the best fence you can build, I'll bet on some Mexican with a few dollars of nails and a pile of scrap lumber."
34 MPG , '85 2WD Cherokee Pioneer with custom installed, 64 hp, 2.2 L Nissan SD22 Diesel 5 spd Manual; & 4 Renix XJs, '87 Wagoneer 4.0, 4WD, 89-Cherokee, 4WD, '87 Cherokee 2WD, & '89 Cherokee Pioneer 2WD, all 4dr. #2091
Reply With Quote
  #7  
Old November 30th, 2018, 17:01
cruiser54's Avatar
cruiser54 cruiser54 is offline
NAXJA Forum User
 
Join Date: Nov 2009
Location: Prescott, Az
Posts: 6,557
Re: 87 xj cranks but wont start

Quote:
Originally Posted by Ecomike View Post
Just reinstall the CPS and move it closer to the Flex plate by making the mounting hole larger. I also found, at least on mine, that super thin washer between the bell housing and the CPS arm, doubled my cranking AC voltage.

My battery barely works right now, old like me, LOL, this month and she still fires right up after sitting for week. Also stock CPS mounting you need solid battery power at the starter to get peak cranking rpms to get enough CPS voltage for the ECU to see.
C101 can be a huge factor in this and other running issues. Never a bad idea to clean it.

Also, unplugging the CPS and plugging it back in, and if it starts, indicates that connector needs attention.
Reply With Quote
  #8  
Old December 9th, 2018, 21:51
xjcollecter's Avatar
xjcollecter xjcollecter is offline
NAXJA Forum User
 
Join Date: Nov 2018
Location: livermore CO
Posts: 5
Re: 87 xj cranks but wont start

finally got some time to mess with the jeep again and i cleaned the c101 and it still wouldn't fire but decided to replace the cps with another one i had and it fired up and runs great again, thanks for the input.
Reply With Quote
  #9  
Old December 9th, 2018, 22:04
cruiser54's Avatar
cruiser54 cruiser54 is offline
NAXJA Forum User
 
Join Date: Nov 2009
Location: Prescott, Az
Posts: 6,557
Re: 87 xj cranks but wont start

Good to hear.

Did you try the unplugging and plugging back in of the CPS before replacing it?
Reply With Quote
  #10  
Old December 12th, 2018, 21:38
xjcollecter's Avatar
xjcollecter xjcollecter is offline
NAXJA Forum User
 
Join Date: Nov 2018
Location: livermore CO
Posts: 5
Re: 87 xj cranks but wont start

i did not, honestly didnt think about it
Reply With Quote
  #11  
Old December 13th, 2018, 04:45
cruiser54's Avatar
cruiser54 cruiser54 is offline
NAXJA Forum User
 
Join Date: Nov 2009
Location: Prescott, Az
Posts: 6,557
Re: 87 xj cranks but wont start

Quote:
Originally Posted by xjcollecter View Post
i did not, honestly didnt think about it
try it.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cranks but no start ran great shut it off wont start now scottybeach OEM Tech Discussion 18 October 23rd, 2013 16:05
00 cranks but wont start nismochasse OEM Tech Discussion 17 April 7th, 2011 20:50
97 cranks but wont start Anker26 OEM Tech Discussion 5 June 18th, 2010 22:14
wont start but cranks solidnake1761 OEM Tech Discussion 1 March 7th, 2009 07:40
Cranks but wont start Gray XJ OEM Tech Discussion 10 May 19th, 2004 14:19


All times are GMT -7. The time now is 14:39.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014