NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old April 16th, 2019, 09:16
dirtybird78 dirtybird78 is offline
NAXJA Forum User
 
Join Date: Aug 2008
Location: frisco,tx
Posts: 43
Starting issue

Need a little help. Bought a 99 XJ. More often than not,it will start,take throttle,then die. I cannot keep it running when it does this. It may do it 6-7 times in a row. Then it will finally start and run fine. Any ideas? Crank sensor I donít believe it would start at all. IAC it would start and I would be able to keep it running. I have checked fuel pressure. Key on around 45,running around 49-50. HELP lol
Reply With Quote
  #2  
Old April 16th, 2019, 10:19
Tim_MN's Avatar
Tim_MN Tim_MN is offline
Freakish Hand Strength
 
Join Date: Mar 2003
Location: Minneapolis, MN
Posts: 6,523
Re: Starting issue

If the start/stall is not a fuel issue, then it either an OBD engine sensor issue, or a low battery voltage issue.

Test the Crankshaft Position Sensor and the Throttle Position Sensor. Clean the battery terminals. Load Test the battery.
__________________
.
.

Quote:
Originally Posted by bimmerjeeper

I'm starting to realize people on the Jeep forums are highly expert mechanics .....
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cherokee multiple cranks, starting issue. Very unusual starting / fuel issue. Intellect OEM Tech Discussion 6 November 17th, 2017 09:48
Starting issue Aquit45 OEM Tech Discussion 1 October 24th, 2012 21:22
Starting Issue Bleckers3 OEM Tech Discussion 1 October 18th, 2010 22:07
Starting Issue 01 XJ ebjones7 OEM Tech Discussion 9 July 21st, 2009 05:08
Random non starting issue to not starting at all XJ project Arizona Chapter 11 April 20th, 2009 08:37


All times are GMT -7. The time now is 04:02.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014