NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Chapters > NorthWest Chapter
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

NorthWest Chapter Discussion of Chapter issues. Please keep Tech Topics on the Tech Forums.

Reply
 
Thread Tools Display Modes
  #1  
Old May 14th, 2015, 20:43
LockdUpXJ's Avatar
LockdUpXJ LockdUpXJ is offline
NAXJA Forum User
 
Join Date: Dec 2007
Location: Federal Way
Posts: 43
Another P1391 code post. cam sensor? dist? crank sensor?

I have looked up many threads on cel P1391 but I can't find how to troubleshoot and diagnose what the actual problem is. I was driving home from work on i5 from Tacoma to federal way and going through fife the jeep stuttered and the rpms would spike way up under middle throttle then as I was getting to federal way it got worse and worse so I pulled Over and it stuttered even at idle and it died and through a code. I have a Bluetooth code reader in the jeep and it said it was P1391. Any thoughts as to where to start? I don't want to just throw money at replacing things that aren't the problem
Reply With Quote
  #2  
Old May 15th, 2015, 08:52
mtbxj87 mtbxj87 is offline
NAXJA Forum User
 
Join Date: Jun 2013
Location: Bend, OR
Posts: 371
Re: Another P1391 code post. cam sensor? dist? crank sensor?

year and engine, trans? ill look it up
Reply With Quote
  #3  
Old May 15th, 2015, 08:59
mtbxj87 mtbxj87 is offline
NAXJA Forum User
 
Join Date: Jun 2013
Location: Bend, OR
Posts: 371
Re: Another P1391 code post. cam sensor? dist? crank sensor?

if its 97+. p1391 intermittent loss of crank position or cam position signal.
Look at the connectors for both sensors, corrosion, broken wires, pulled terminals. then check grounds, voltage input and voltage output
Reply With Quote
  #4  
Old May 17th, 2015, 14:49
LockdUpXJ's Avatar
LockdUpXJ LockdUpXJ is offline
NAXJA Forum User
 
Join Date: Dec 2007
Location: Federal Way
Posts: 43
Re: Another P1391 code post. cam sensor? dist? crank sensor?

Its a 99 XJ 4.0. I'll check the connectors and go from there
Reply With Quote
  #5  
Old May 31st, 2015, 17:02
LockdUpXJ's Avatar
LockdUpXJ LockdUpXJ is offline
NAXJA Forum User
 
Join Date: Dec 2007
Location: Federal Way
Posts: 43
Re: Another P1391 code post. cam sensor? dist? crank sensor?

I checked the sensors at the end of the pigtails where they plug in, disconnected and reconnected them. Drove it and a few miles in the jeep started doing the same thing. Today I will pull the sensors and look at them clean them up perhaps. If that doesn't work I will have to start replacing the parts till it goes away
Reply With Quote
  #6  
Old June 5th, 2015, 08:50
LockdUpXJ's Avatar
LockdUpXJ LockdUpXJ is offline
NAXJA Forum User
 
Join Date: Dec 2007
Location: Federal Way
Posts: 43
Re: Another P1391 code post. cam sensor? dist? crank sensor?

I am starting to get frustrated..... yesterday i noticed the jeep was throwing coolant around the engine bay because the fan had worn a hole in the hose between the radiator and the coolant overflow so I replaced it, filled up coolant that it was a quart low on. today i turn it on and its idle is garbage and it now says check gauges.... the voltmeter isnt working..... it drives just fine (minus the idle) 10 miles to work on the interstate. ANY ideas?!?!?!?!
Reply With Quote
  #7  
Old June 5th, 2015, 14:14
LockdUpXJ's Avatar
LockdUpXJ LockdUpXJ is offline
NAXJA Forum User
 
Join Date: Dec 2007
Location: Federal Way
Posts: 43
Re: Another P1391 code post. cam sensor? dist? crank sensor?

HELP!!!!! does anyone have any ideas?

Update, I drove it again to lunch and the idle is such garbage it died a few times. the voltmeter is not working then worked... then didnt work after a few min (may be unrelated????)
Reply With Quote
  #8  
Old June 7th, 2015, 08:50
GordoSmasho's Avatar
GordoSmasho GordoSmasho is offline
Sierra Chapter Treasurer
 
Join Date: Aug 2008
Location: Pleasant Hill, CA
Posts: 3,227
Another P1391 code post. cam sensor? dist? crank sensor?

Have you replaced the sensors. I would start with the cam sensor. Crank would shit off the motor due to spark loss. But just replacing both is good insurance. Just make sure and test the new sensors before install. They sometimes arrive bad.
Reply With Quote
  #9  
Old June 7th, 2015, 08:52
GordoSmasho's Avatar
GordoSmasho GordoSmasho is offline
Sierra Chapter Treasurer
 
Join Date: Aug 2008
Location: Pleasant Hill, CA
Posts: 3,227
Another P1391 code post. cam sensor? dist? crank sensor?

Cam sensor testing
http://www.naxja.org/forum/showthrea...1003757&page=2

Crank sensor test
http://www.naxja.org/forum/showthread.php?t=1062496
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
stutters, crank and camshaft position sensor code when cold iluv83vettes OEM Tech Discussion 0 January 8th, 2015 10:34
Swapping cam positioning sensor into a dist. motor 1975Ironhead OEM Tech Discussion 9 March 19th, 2012 07:39
crank sensor help? willow72 OEM Tech Discussion 3 October 8th, 2007 14:48
02 sensor code....Bank 1, Sensor 2 black2door OEM Tech Discussion 9 September 24th, 2006 08:50
92+ ABS sensor and braking power dist. Greg_pl OEM Tech Discussion 0 December 20th, 2005 14:27


All times are GMT -7. The time now is 15:59.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014