NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > Modified Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

Modified Tech Discussion Forum for Tech related discussion for Modified XJ's and MJ's.

Reply
 
Thread Tools Display Modes
  #1  
Old January 21st, 2007, 19:27
casm's Avatar
casm casm is offline
NAXJA Forum User
 
Join Date: Mar 2004
Location: Oklahoma
Posts: 5,115
C4x4 double-tube rocker guard fitment issue

I finally got around today to mostly fitting one of the C4x4 double-tube rocker guards I ordered a few weeks ago. Ran out of daylight so will have at it again tomorrow, but was curious if anyone else had run into the following:

- If the angle iron meant to run along the rocker panel was mounted flush against it, the lower hole on the rear mounting bracket would be below the level of the rear spring hanger.

- Dropping the angle iron down approximately 1/16" from the rocker panel allowed the rear spring hanger to mount properly. All six bolts drilled through the pinch seam lined up OK as well.

- At this point, trying to mount the front T-bracket to the frame rails resulted in its holes not lining up with those drilled on the front guard bracket. When lined up, the T-bracket would have its bottom two holes below the frame rail.

Right now it's attached at the six pinch seam bolts as well as the two at the rear spring hanger which is good enough to keep it in place until tomorrow, but obviously it's not serviceable. My best plan of attack at this point is to redrill the T-bracket to accomodate the current location of the front mounting bolts, but I'm a little surprised at how off-kilter things are.

Has anyone else run into similar issues? There's no obvious damage to the pinch seam or spring hangers on that side - and while I realise that moving the entire guard down slightly is deviating from how it's meant to be mounted, following the instructions to the letter makes everything not quite work. Is it possible that I got a kit that wasn't quite to spec, or is this relatively normal with this product?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
C4x4 double tube guards and RE drop brackets MN-Cherokee Modified Tech Discussion 8 April 30th, 2006 19:33
Calling all XJs with C4X4 double tube sliders HeavyMetal Modified Tech Discussion 9 March 30th, 2006 20:19
C4x4 double-tube rail install online! Robertb Modified Tech Discussion 5 October 7th, 2003 07:34
C4x4 double tube rock rails Lawn Cher' For Sale: Private Party Only. XJ ITEMS ONLY 3 September 9th, 2003 05:47


All times are GMT -7. The time now is 22:23.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014