NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old August 24th, 2009, 11:44
kastein's Avatar
kastein kastein is offline
NAXJA Member
 
Join Date: Jul 2009
Location: Longbranch WA / Central MA
Posts: 14,237
Transmission issue? Engine issue?

For a few months my '96 XJ (127k, 4.0L I6 automatic, NP231) has been giving me issues occasionally... it starts fine, it runs fine until I try to accelerate ever so slightly, as in pulling out of a residential street corner, then it sorta hesitates/chokes/runs rough for a few seconds, giving almost no power, and suddenly snaps back into normal operation. It does this only right after I start it, and only once in a while, but it's worrying me - I suspect PCM or transmission problems.

Some things I've already done:
* plugs, wires, distributor cap and rotor. Problem went away for a while, or it could have been luck, I'm not sure. Engine idles MUCH smoother now.
* intake/valve/whatever cleaner - seafoam. Runs better now, but the random issue still happens with about the same frequency.

I know that my alternator is fine (system at 14V as expected), and the transmission is not going into limp-in mode as it drives fine after the one issue right at the start of a run. It never turns on the check engine lamp, though I don't actually know if there is a bulb in there... I will check that at my first opportunity.

Any ideas? I've looked around at some other threads but haven't found anything that quite fits the symptoms.
__________________
My yard looks like Sanford & Sons.
Current crapcan fleet: LS swapped bobbed 79 J10 Honcho, 4x4 auto 4.0 8.25 swapped metric ton 88 MJ
CTeunuch: Sometimes I really wonder if this sport makes you insane, or it just attracts the mentally unstable.
Reply With Quote
  #2  
Old August 24th, 2009, 11:52
joe_peters joe_peters is offline
NAXJA Forum User
 
Join Date: Apr 2008
Location: Grants Pass, OryGun
Posts: 13,746
Re: Transmission issue? Engine issue?

Well, I would check/test/clean the idle air controller (IAC), the throttle position sensor (TPS), and the throttle body (TB).

The IAC is a stepper motor that handles both the idle and transition circuits in conjunction with the TPS inputs to the ECU (PCM).
Reply With Quote
  #3  
Old August 24th, 2009, 12:24
kastein's Avatar
kastein kastein is offline
NAXJA Member
 
Join Date: Jul 2009
Location: Longbranch WA / Central MA
Posts: 14,237
Re: Transmission issue? Engine issue?

Thanks, I'll definitely look at that. All of the parts you mention seem a good deal cheaper than the PCM/ECU, so I'll try them before it... probably will try cleaning, then junkyard parts, then dealership parts (from what I have read, I want nothing to do with aftermarket car electronics).
__________________
My yard looks like Sanford & Sons.
Current crapcan fleet: LS swapped bobbed 79 J10 Honcho, 4x4 auto 4.0 8.25 swapped metric ton 88 MJ
CTeunuch: Sometimes I really wonder if this sport makes you insane, or it just attracts the mentally unstable.
Reply With Quote
  #4  
Old August 24th, 2009, 15:20
kastein's Avatar
kastein kastein is offline
NAXJA Member
 
Join Date: Jul 2009
Location: Longbranch WA / Central MA
Posts: 14,237
Re: Transmission issue? Engine issue?

Another thing that's making me curious is why it only does it the first time right after I start it - I figured the TPS probably wouldn't do that, as it'd flake out randomly whenever it wanted to, which is making me think it's more likely to be the IAC because that could get stuck before it gets actuated a few times. I might just be nuts though...
__________________
My yard looks like Sanford & Sons.
Current crapcan fleet: LS swapped bobbed 79 J10 Honcho, 4x4 auto 4.0 8.25 swapped metric ton 88 MJ
CTeunuch: Sometimes I really wonder if this sport makes you insane, or it just attracts the mentally unstable.
Reply With Quote
  #5  
Old August 24th, 2009, 15:29
winterbeater's Avatar
winterbeater winterbeater is offline
NAXJA Forum User
 
Join Date: Jul 2008
Location: Royal Oak, Michigan
Posts: 5,315
Re: Transmission issue? Engine issue?

IAC is more for idle control. I'd lean toward the TPS. Maybe it makes better contact after it's worked a few times after sitting.
Reply With Quote
  #6  
Old September 7th, 2009, 11:30
kastein's Avatar
kastein kastein is offline
NAXJA Member
 
Join Date: Jul 2009
Location: Longbranch WA / Central MA
Posts: 14,237
Re: Transmission issue? Engine issue?

Update - haven't had a chance to do anything about this, but I've noticed that the engine will surge randomly to 4k RPM while cruising with cruise control (for maybe a tenth of a second per surge) so I'm leaning more and more toward the TPS.
__________________
My yard looks like Sanford & Sons.
Current crapcan fleet: LS swapped bobbed 79 J10 Honcho, 4x4 auto 4.0 8.25 swapped metric ton 88 MJ
CTeunuch: Sometimes I really wonder if this sport makes you insane, or it just attracts the mentally unstable.
Reply With Quote
  #7  
Old September 7th, 2009, 11:45
jkelley330's Avatar
jkelley330 jkelley330 is offline
NAXJA Forum User
 
Join Date: Sep 2009
Location: texas
Posts: 1
Re: Transmission issue? Engine issue?

The iac will cause surge problems. Yes aftermarket is junk esp when it comes from auto zone. But the BWD brand is just as good as factory.
Reply With Quote
  #8  
Old September 9th, 2009, 11:48
kastein's Avatar
kastein kastein is offline
NAXJA Member
 
Join Date: Jul 2009
Location: Longbranch WA / Central MA
Posts: 14,237
Re: Transmission issue? Engine issue?

Thanks - looks like I'll be getting both at the junkyard this Saturday and hoping for the best. At least they haven't given out completely yet, it's just mildly annoying at this point.
__________________
My yard looks like Sanford & Sons.
Current crapcan fleet: LS swapped bobbed 79 J10 Honcho, 4x4 auto 4.0 8.25 swapped metric ton 88 MJ
CTeunuch: Sometimes I really wonder if this sport makes you insane, or it just attracts the mentally unstable.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission Issue? steve796 OEM Tech Discussion 13 August 30th, 2009 20:35
transmission issue IRPancake OEM Tech Discussion 13 June 7th, 2009 20:23
engine lagging issue 98CherokeeSport Jeep Street and Performance 17 April 12th, 2009 16:35
Engine Temp Gauge issue Ben824 OEM Tech Discussion 10 December 4th, 2007 02:12
Engine Power Issue after Regear Tom R. Modified Tech Discussion 17 August 8th, 2003 13:37


All times are GMT -7. The time now is 22:10.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014