NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old September 11th, 2019, 19:43
vabeachtennis vabeachtennis is offline
NAXJA Forum User
 
Join Date: Feb 2010
Location: Va Beach
Posts: 110
Coolant Temperature Sender Unit

I had my flexplate replaced this afternoon, so far so good but when I looked at my temperature gauge it remained pegged to the left under 100. When I hooked my scanner up the temperature ranged between 167 and 1 or 2 degrees more or less. I'm thinking that the CTSU got loose or may be broken. Any suggestions on aftermarket CTSU's. I will check it tomorrow morning and see if it's still connected.
Reply With Quote
  #2  
Old September 11th, 2019, 21:48
lawsoncl lawsoncl is online now
NAXJA Forum User
 
Join Date: Jan 2006
Location: North Idaho
Posts: 5,125
Re: Coolant Temperature Sender Unit

Up through 1996, the Cherokee had two coolant temp sensors. One in the thermostat housing for the engine computer which your seeing with the scanner, and for the instrument panel. That one is located on head sticking up near the back of the valve cover on the drivers side. I'll bet they knocked the wire loose, or broke it off if the engine tipped backwards when they pulled the transmission.
Reply With Quote
  #3  
Old September 11th, 2019, 21:50
lawsoncl lawsoncl is online now
NAXJA Forum User
 
Join Date: Jan 2006
Location: North Idaho
Posts: 5,125
Re: Coolant Temperature Sender Unit

Reply With Quote
  #4  
Old September 11th, 2019, 21:53
lawsoncl lawsoncl is online now
NAXJA Forum User
 
Join Date: Jan 2006
Location: North Idaho
Posts: 5,125
Re: Coolant Temperature Sender Unit

Reply With Quote
  #5  
Old September 12th, 2019, 06:52
vabeachtennis vabeachtennis is offline
NAXJA Forum User
 
Join Date: Feb 2010
Location: Va Beach
Posts: 110
Re: Coolant Temperature Sender Unit

Quote:
Originally Posted by lawsoncl View Post
Up through 1996, the Cherokee had two coolant temp sensors. One in the thermostat housing for the engine computer which your seeing with the scanner, and for the instrument panel. That one is located on head sticking up near the back of the valve cover on the drivers side. I'll bet they knocked the wire loose, or broke it off if the engine tipped backwards when they pulled the transmission.
That was it! I looked under the hood this morning and it was unplugged. I bet it did tip backwards when they pulled the transmission. They were confused and said that they didn't do anything to the top of the engine. I thought that they may have pulled it out if they were disconnecting the crank sensor. Thanks for the information.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Part # for the Coolant Temperature Sending Unit 1996 4.0L Classic Distended OEM Tech Discussion 10 November 4th, 2011 21:00
Coolant temperature gauge sender #? iwannadie OEM Tech Discussion 3 July 4th, 2011 12:56
Coolant Temperature Sender Broken Scirocco84 OEM Tech Discussion 7 April 30th, 2011 10:58
Temperature Sender creekscout OEM Tech Discussion 6 April 6th, 2009 01:09
Temp sender/ engine coolant sender, same thing? Angus OEM Tech Discussion 8 March 29th, 2004 11:59


All times are GMT -7. The time now is 16:58.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014