NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old August 29th, 2009, 14:55
johnferg69 johnferg69 is offline
NAXJA Forum User
 
Join Date: Aug 2009
Location: Texas
Posts: 67
Brake & Hazard lights not working

According to my trusty???? Haynes repair manual the two have one common link besides ground and that's a 20 amp "CLK HAZ STOP" fuse. I don't have a "CLK HAZ STOP" fuse in the fuse box. I see one for clock, turn/bu and a hazard relay.

I haven't found ANY blown fuses in the fuse box under the dash or under the hood. Or any bad bulbs although the only lights I pulled and checked where the rear lights.

Any advise??
Reply With Quote
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake & Tail lights not working bubXJ OEM Tech Discussion 7 August 13th, 2007 21:23
brake lights not working altierior OEM Tech Discussion 5 July 6th, 2007 16:03
Brake & hazard lights out tvisXJ OEM Tech Discussion 5 May 31st, 2006 20:34
Brake lights not working! FU-UR OEM Tech Discussion 6 November 4th, 2005 15:57
Rear Brake Lights Not Working . . . Red1 OEM Tech Discussion 6 April 2nd, 2003 21:14


All times are GMT -7. The time now is 02:07.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014