NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old March 22nd, 2017, 13:54
NeXJ NeXJ is offline
NAXJA Forum User
 
Join Date: Sep 2003
Location: Los Angeles
Posts: 336
Idle speed going through the ROOF on warming up : 97 XJ 4.0 HO

I have no idea what's happening - though I wonder if it's related to my cooling system having a blockage - been only using my vehicle for short local trips as a result. previously - throwing the hot air blower on has kept things to temp for trips over ten min... but suddenly now my revs have been climbing to 3000 plus at idle once i've been driving and engine running for five minutes or so... I'm going to take it in to have someone fix up my cooling system (not something i relish doing myself) but I'm wondering where this behavior might be coming from. Anyone want to take a stab in the dark?? I checked the TB cable etc - and no issues there. it's not moving - the rest position doesn't change...
Reply With Quote
  #2  
Old March 22nd, 2017, 15:50
CharlesS's Avatar
CharlesS CharlesS is offline
NAXJA Member
 
Join Date: Mar 2003
Location: Carmel Mountain Ranch, CA
Posts: 2,459
Re: Idle speed going through the ROOF on warming up : 97 XJ 4.0 HO

Could be that you Idle Air Controller solenoid that is attached to the passenger side of the TB is dirty and hanging up. IIRC the IAC is held on with two T15 torx screws. You can clean the TB, IAC and ports with throttle body cleaner.
__________________
1998 XJ 4.0L (SOLD),
2011 JK 3.8L
Reply With Quote
  #3  
Old March 22nd, 2017, 16:13
NeXJ NeXJ is offline
NAXJA Forum User
 
Join Date: Sep 2003
Location: Los Angeles
Posts: 336
Re: Idle speed going through the ROOF on warming up : 97 XJ 4.0 HO

Quote:
Originally Posted by CharlesS View Post
Could be that you Idle Air Controller solenoid that is attached to the passenger side of the TB is dirty and hanging up. IIRC the IAC is held on with two T15 torx screws. You can clean the TB, IAC and ports with throttle body cleaner.
hmmmm - okay thanks sounds like an easy enough thing to check... open to other ideas too... in case there are others
Reply With Quote
  #4  
Old March 22nd, 2017, 16:40
Greenspan's Avatar
Greenspan Greenspan is offline
NAXJA Member
 
Join Date: Aug 2016
Location: Los Angeles
Posts: 123
Re: Idle speed going through the ROOF on warming up : 97 XJ 4.0 HO

Yeah, try cleaning your TB and IAC. My Jeep was revving high on startup, a can of TB cleaner fixed the problem. I followed this guys instructions:

https://www.youtube.com/watch?v=_UUozF7LkUU
Reply With Quote
  #5  
Old March 22nd, 2017, 16:58
NeXJ NeXJ is offline
NAXJA Forum User
 
Join Date: Sep 2003
Location: Los Angeles
Posts: 336
Re: Idle speed going through the ROOF on warming up : 97 XJ 4.0 HO

one thing confuses me however - how does the IAC increase the fuel flow to the TB? Surely it must be doing that if my revs are off the chart... seems the engine can't rev higher without more fuel flowing? or could this possibly be a computer/fuel injector problem?
Reply With Quote
  #6  
Old March 22nd, 2017, 20:47
cherokeefan_1 cherokeefan_1 is offline
NAXJA Forum User
 
Join Date: Jul 2008
Location: Portland(for now)
Posts: 277
Re: Idle speed going through the ROOF on warming up : 97 XJ 4.0 HO

The IAC is allowing more air in and the computer is on a rich fuel mixture due to cold engine this higher revs. Pull the throttle body, clean with carb cleaner, reinstall. Fixed my issue with the same problem. You could also try using amsoil powerfoam or whatever but I'd rather all that gunk not go through my engine.
Reply With Quote
  #7  
Old March 23rd, 2017, 00:43
NeXJ NeXJ is offline
NAXJA Forum User
 
Join Date: Sep 2003
Location: Los Angeles
Posts: 336
Re: Idle speed going through the ROOF on warming up : 97 XJ 4.0 HO

OK thanks! were you going up so high as well? (3K ?) or just 1200 rpm or so?

though mine's not doing it from a cold start - only when it gets hot enough ... anyway I'll take your advice - just trying to make some sense of how this works...
Reply With Quote
  #8  
Old March 23rd, 2017, 06:41
Original_MudButt's Avatar
Original_MudButt Original_MudButt is offline
NAXJA Forum User
 
Join Date: Jan 2008
Location: In the eighth dimension
Posts: 3,555
Re: Idle speed going through the ROOF on warming up : 97 XJ 4.0 HO

Could also be injector o-rings leaking...
Reply With Quote
  #9  
Old March 23rd, 2017, 06:47
md21722 md21722 is offline
NAXJA Forum User
 
Join Date: Feb 2014
Location: Colorado Springs
Posts: 2,395
Re: Idle speed going through the ROOF on warming up : 97 XJ 4.0 HO

I have seen a failing TPS do some strange things too, but I would start with the IAC.
Reply With Quote
  #10  
Old March 23rd, 2017, 19:21
cherokeefan_1 cherokeefan_1 is offline
NAXJA Forum User
 
Join Date: Jul 2008
Location: Portland(for now)
Posts: 277
Re: Idle speed going through the ROOF on warming up : 97 XJ 4.0 HO

Mine did it occasionally when warm. It would start then slowly rev to about 1800. Cleaned it good and never another issue. Your problem could be something else, never know. But a $5 gasket and some carb cleaner or TB cleaner is worth a shot.
Reply With Quote
  #11  
Old March 23rd, 2017, 19:37
ehall's Avatar
ehall ehall is offline
NAXJA Member
 
Join Date: Dec 2007
Location: Southern Maryland
Posts: 9,223
Re: Idle speed going through the ROOF on warming up : 97 XJ 4.0 HO

If its 3000 RPM I'd probably look for crack in the manifolds
__________________
.
my '91 beater rebuild
Reply With Quote
  #12  
Old March 23rd, 2017, 20:02
Ecomike's Avatar
Ecomike Ecomike is offline
NAXJA# 2091
 
Join Date: Dec 2006
Location: MilkyWay Galaxy
Posts: 15,300
Re: Idle speed going through the ROOF on warming up : 97 XJ 4.0 HO

The IAT/MAT Intake (manifold) Air Temperature sensor can do that when it goes bad. You can test the hot and cold resistance of the sensor with an ohm meter when the power/ignition is off versus the OEM specs in the manual. The data is in many old threads here.
__________________
Quote=8Mud: "Go ahead and put up the best fence you can build, I'll bet on some Mexican with a few dollars of nails and a pile of scrap lumber."
34 MPG , '85 2WD Cherokee Pioneer with custom installed, 64 hp, 2.2 L Nissan SD22 Diesel 5 spd Manual; & 4 Renix XJs, '87 Wagoneer 4.0, 4WD, 89-Cherokee, 4WD, '87 Cherokee 2WD, & '89 Cherokee Pioneer 2WD, all 4dr. #2091
Reply With Quote
  #13  
Old May 18th, 2017, 13:20
NeXJ NeXJ is offline
NAXJA Forum User
 
Join Date: Sep 2003
Location: Los Angeles
Posts: 336
Re: Idle speed going through the ROOF on warming up : 97 XJ 4.0 HO

OOPS! thanks guys for the additional responses ... for some reason I didn't get any notifications about them since... I haven't touched it yet but it's nice to have the additional advice... thanks again and sorry for the delay
Reply With Quote
  #14  
Old May 18th, 2017, 13:24
old_man's Avatar
old_man old_man is offline
NAXJA Member
 
Join Date: May 2003
Location: Loveland, Colorado
Posts: 15,646
Re: Idle speed going through the ROOF on warming up : 97 XJ 4.0 HO

High idle is commonly caused by vacuum leaks. Do a quick search on tracking them down.
__________________
Tom Houston - Former Colorado Chapter President , Terminal Adrenaline Junkie, and Rocket Scientist
Loveland, Colorado My teardrop build
You're just jealous because the voices don't talk to you.
Reply With Quote
  #15  
Old May 18th, 2017, 14:11
NeXJ NeXJ is offline
NAXJA Forum User
 
Join Date: Sep 2003
Location: Los Angeles
Posts: 336
Re: Idle speed going through the ROOF on warming up : 97 XJ 4.0 HO

Quote:
Originally Posted by old_man View Post
High idle is commonly caused by vacuum leaks. Do a quick search on tracking them down.
well - i'm not sure if i'd call it 'high' so much as 'accelerating' or 'runaway' idle - it just keeps increasing and increasing - i had to cut the motor a few times when it got to be around the 4000 plus mark - i'm sure it would go as high as it needed to throw a rod though... if i just left it...
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Idle problem. Gets really shaky after warming up. AnthonyZ28 OEM Tech Discussion 5 March 22nd, 2013 10:09
fyi...Idle Speed Stepper Motor - (aka Idle Air Controller / I.A.C.) sixditchoffroad OEM Tech Discussion 10 October 11th, 2009 08:26
Stop Global Warming, paint your roof bigalpha Non-Tech / Off Topic 20 May 6th, 2009 17:07
89 I6 Idle speed RTFM OEM Tech Discussion 5 December 14th, 2007 05:40
Idle speed cardboard OEM Tech Discussion 6 September 29th, 2004 14:13


All times are GMT -7. The time now is 15:53.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014