NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old March 8th, 2005, 09:24
Soul's Avatar
Soul Soul is offline
NAXJA Forum User
 
Join Date: Dec 2004
Location: Moscow Idaho
Posts: 11
Potential Ignition starter switch problem.

First to start off - After an autoshop in my hometown replaced a recall on the shifter (Now I have to push the button in to actually shift). Anyway, after they were done and I was on my way back to college I noticed I didnt have a dome light anymore, and I had no dinging when i left the lights on or left my keys in the ignition...and now..
I have been having starter issues for a few weeks, the first time I was in a parking lot and couldnt get any response, I had all power but no clicking or anything from the starter, the lights dont even dim. I got out, wacked the starter with a hammer and got back in and it started right up.I assumed a bad starter..Poor college kid, i figured I would milk it for a few..anyway happened another time, I wacked it, it didnt start, got back under there and wacked it a couple more times and it started.
Ended up not starting a few days later..then when I went for one last try the day i was going to change the starter (i wanted to work on it in the garage, is that too much to ask?) it started right up, with no banging.
I replaced the starter and everything was fine..for a day. I am now realizing something. Everytime i got out to hit it I moved the key around, when that didnt work, i hit the starter and then moved the key around some more and it would eventually start...
Am I actually having an ignition starter switch problem and not a starter problem at all?? I have tried starting it in neutral and that doesnt work..my reverse lights are fine. I replaced the starter relay a few months ago (but i know that means nothing). So, before I go down and blow a whopping $10 what do you guys think? No dome lights, no dinging sounds, no starting all related to the switch?
Also, Im in an 87 wagoneer limited..thanks:-)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible ignition wiring problem Audiophile Modified Tech Discussion 9 February 22nd, 2005 21:44
starter solenoid problem afjeep2082 OEM Tech Discussion 1 September 1st, 2004 10:16
88 xj Ignition Switch rattler43 OEM Tech Discussion 5 August 23rd, 2004 14:52
changing ignition switch utahxjer OEM Tech Discussion 3 December 5th, 2003 13:14
Ignition problem JCWjeeper OEM Tech Discussion 5 June 6th, 2003 21:02


All times are GMT -7. The time now is 11:42.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014