NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > Modified Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

Modified Tech Discussion Forum for Tech related discussion for Modified XJ's and MJ's.

Reply
 
Thread Tools Display Modes
  #1  
Old January 7th, 2019, 16:16
Futal87 Futal87 is offline
NAXJA Forum User
 
Join Date: Jan 2019
Location: Australia
Posts: 3
transmission upgrade/issue

Hi guys,

Over the last few days I swapped in a Lower mile gearbox and while I was at it I installed a transgo shift kit SK 340. (probably not the best idea as the box wasn't tested unmodified)

Situation I have now is I have reverse and no forward gears. I can hear the revs pick up a little when shifting into D but no drive at all.

what do you guys think? the forums here in Australia are ver limited in their knowledge when it comes to transmissions.

I'm planning on testing the solenoids first up..

Thanks a lot. its a bit of a worry..
Reply With Quote
  #2  
Old January 7th, 2019, 19:36
cal's Avatar
cal cal is offline
NAXJA Warranty Voider
 
Join Date: Nov 2004
Location: Hammertown, USA
Posts: 17,204
Re: transmission upgrade/issue

Unplug the tcu and put it in 1. Bypasees solenoid.

Sounds like a bad shift kit install though.
__________________
I'm not a complete idiot - there are parts missing.
Reply With Quote
  #3  
Old January 8th, 2019, 03:14
Futal87 Futal87 is offline
NAXJA Forum User
 
Join Date: Jan 2019
Location: Australia
Posts: 3
transmission upgrade/issue

Yep sounds like Iíve made a mistake somewhere along the install of the kit.

Does anyone have any resources on this kit? Or on the valve body for an aw4?


Sent from my iPhone using Tapatalk
Reply With Quote
  #4  
Old January 8th, 2019, 04:57
RCP Phx RCP Phx is offline
NAXJA Forum User
 
Join Date: Mar 2003
Location: Phoenix,Az
Posts: 11,955
Re: transmission upgrade/issue

A little insight.....
https://naxja.org/forum/showthread.php?t=1147175
Reply With Quote
  #5  
Old January 8th, 2019, 05:28
Futal87 Futal87 is offline
NAXJA Forum User
 
Join Date: Jan 2019
Location: Australia
Posts: 3
transmission upgrade/issue

Thanks a lot. Seems like a similar problem. Iíll make make sure to check the prv


Sent from my iPhone using Tapatalk
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission Issue egiznad OEM Tech Discussion 3 November 7th, 2015 21:25
transmission/transfercase upgrade? 2stix SoCal Chapter 31 January 20th, 2010 09:41
Transmission issue? Engine issue? kastein OEM Tech Discussion 7 September 9th, 2009 11:48
Transmission Upgrade SUA SPONTE Modified Tech Discussion 11 June 1st, 2007 07:52
Idling Issue After Injector Upgrade XJVenom Jeep Street and Performance 7 October 4th, 2006 17:57


All times are GMT -7. The time now is 14:24.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014