NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old January 14th, 2018, 16:56
kyle_inreallife kyle_inreallife is offline
NAXJA Forum User
 
Join Date: Dec 2017
Location: California
Posts: 31
Shifting issue after rains

87 wagoneer 4.0 aw4

It rained last week. I drove around through some deep puddles and everything was fine. After it stopped raining I was just driving home normally, came to a stop light, it turned green and I accelerated and all of a sudden my tranny decided it didn't want to come out of first. I pulled all connectors from trans to throttle body cleaned and dried them out and still the same issue.

If i pull the in line tcu fuse, I can shift manually just fine. I pulled and cleaned nss, tested power to tcu (fine) so I started thinking TPS issue.

I fiddled around with it some and got it to shift automatically for a time, although it waited until about 2500-3000 to upshift.

I had spare TPS and after doing cruiser54s sensor ground upgrades I put it on. I was able to adjust tps/ecm voltages to just about right and it ran smoothly, however it is the same adjustment for the tps/tcu voltages and i can't seem to get those right.

Bad tcu or bad tps?


Also, PO put in hood vents so I'm sure some water got onto the tps/ throttle body area...what threw me off was that I didn't have any issues until after it had stopped raining entirely and I was driving on dry asphalt.

Sent from my iPhone using Tapatalk

Last edited by kyle_inreallife; January 14th, 2018 at 17:00.
Reply With Quote
  #2  
Old January 14th, 2018, 18:44
Hypoid's Avatar
Hypoid Hypoid is offline
NAXJA Member
 
Join Date: Jul 2006
Location: Golden, CO
Posts: 7,186
Re: Shifting issue after rains

Bad TPS.
__________________
The Lost Boys' motto: We don't know where we are going, but we'll be there for awhile...
Reply With Quote
  #3  
Old January 15th, 2018, 06:53
kyle_inreallife kyle_inreallife is offline
NAXJA Forum User
 
Join Date: Dec 2017
Location: California
Posts: 31
Shifting issue after rains

Okay I'll try a brand new one thanks


Sent from my iPhone using Tapatalk
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2-3 shifting issue dante2 Modified Tech Discussion 9 July 3rd, 2017 14:10
Weird Shifting issue Clearwater Ken Modified Tech Discussion 3 November 15th, 2014 16:37
92 cherokee shifting issue cole92xj8" OEM Tech Discussion 1 July 1st, 2014 15:36
shifting issue poomero OEM Tech Discussion 11 January 4th, 2011 18:47
AW4 electronics/ shifting issue Lightfoot OEM Tech Discussion 0 April 19th, 2009 15:02


All times are GMT -7. The time now is 18:44.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014