NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old December 13th, 2014, 19:31
klint96xj klint96xj is offline
NAXJA Forum User
 
Join Date: Nov 2008
Location: Tennessee
Posts: 24
4.0 swap and now it smokes

Hi everyone! I just swapped a 4.0 crate motor I to my 2000 jeep. The engine came from a rolled over xj and has less than 2,000 miles on it. I drove the rolled jeep home about an hour and it didn't smoke at all.

I pulled the engine, transmission, and t case all out together and put it in the 2,000 jeep as one whole thing. After first start up it is smoking white smoke. Anyone have any ideas what might cause this?

When moving the engine I picked it up by the motor mounts and the tranny/tcase pointed almost directly towards the ground. Could fuild have done something weird in the engine? It doesn't look like there is any coolant in the oil and from what I've done, there shouldn't be any reason for this.

I filled up the coolant through the radiator.

I only ran the engine for about 45 seconds to a minute. It was dark so I decided to wait till morning to look closer at it.

Any valuable insight on this would be greatly appreciated!
Reply With Quote
  #2  
Old December 13th, 2014, 19:43
Talyn Talyn is offline
NAXJA Forum User
 
Join Date: Apr 2003
Location: Radford, Communistwealth of Virginia
Posts: 7,329
Re: 4.0 swap and now it smokes

Picking it up like that could cause the oil to shift into the cylinders, causing smoke. However, oil smoke is grey, not white. Try it in the day light and if it is truly white you have a coolant leak.
Reply With Quote
  #3  
Old December 14th, 2014, 07:58
klint96xj klint96xj is offline
NAXJA Forum User
 
Join Date: Nov 2008
Location: Tennessee
Posts: 24
Re: 4.0 swap and now it smokes

Looks like it may have just been condensation in the exhaust. After letting it run for about 15 minutes, it cleared up. Just gotta figure out the check engine light that decided to show itself...
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MTD ride on mower smokes nonnie Non-Tech / Off Topic 4 July 6th, 2009 13:56
Engine smokes BRIANHO13 OEM Tech Discussion 11 July 10th, 2008 12:02
Smokes after sitting... QRMTVI OEM Tech Discussion 7 July 10th, 2007 18:53
'98 4.0 engine smokes on hard acceleration lawlopez OEM Tech Discussion 12 October 22nd, 2006 21:31
'02 Mustang GT Smokes Occasionally, Dealer Says BrianB Tow Rigs and Trailers 4 October 20th, 2005 07:19


All times are GMT -7. The time now is 09:39.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014