NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old May 15th, 2020, 16:16
90xjDave 90xjDave is offline
NAXJA Forum User
 
Join Date: May 2003
Location: Auburn, Ca
Posts: 230
rough idle after VC gasket replaced

I'm working on my daughter's 01 xj, 4.0L

I replaced her valve cover gasket. Now the idle is rough. If I take the hose off of the CCV valve, (the rear one on the valve cover that connects to the intake manifold) idle goes up to about 1500. If I connect the hose, the engine dies. Is this a dealer only item? All of the parts stores in town say they don't carry a CCV valve and insist it's a PCV. Same difference? Not sure...
Reply With Quote
  #2  
Old May 15th, 2020, 18:10
lawsoncl lawsoncl is offline
NAXJA Forum User
 
Join Date: Jan 2006
Location: North Idaho
Posts: 5,221
Re: rough idle after VC gasket replaced

I doubt it's the vent hose or the orifice in the valve cover. It's there to draw some air through the engine and pull any vapors into the intake. The idle air controller should be able to compensate even if that hose is plugged. Look over the other hoses and see if you knocked something loose like the wiring to the idle air controller or maybe the vac line on the MAP sensor.
Reply With Quote
  #3  
Old May 16th, 2020, 06:53
Tim_MN's Avatar
Tim_MN Tim_MN is online now
Freakish Hand Strength
 
Join Date: Mar 2003
Location: Minneapolis, MN
Posts: 6,953
Re: rough idle after VC gasket replaced

There is no logical connection between the valve cover, and the idle speed. The likely suspects are anything you moved, bumped, or disconnected for the valve cover job. Go over your work checking for loose wire plugs, damaged wires or loose/split vent/vacuum tubes. If you were yanking wires all around you could have caused a failure in a wire harness wire splice.
__________________
.
.

Quote:
Originally Posted by bimmerjeeper

Go ahead and slam the liftgate down on a blanket, and see how long you are laughing.

Last edited by Tim_MN; May 16th, 2020 at 16:35.
Reply With Quote
  #4  
Old May 16th, 2020, 07:42
cruiser54's Avatar
cruiser54 cruiser54 is offline
NAXJA Forum User
 
Join Date: Nov 2009
Location: Prescott, Az
Posts: 6,743
Re: rough idle after VC gasket replaced

Very common:

http://cruiser54.com/?p=280
Reply With Quote
  #5  
Old May 16th, 2020, 16:21
90xjDave 90xjDave is offline
NAXJA Forum User
 
Join Date: May 2003
Location: Auburn, Ca
Posts: 230
Re: rough idle after VC gasket replaced

I disconnected all of the wire harnesses (IAC, Map Sensor, etc) and reconnected. It's running fine now. I must have pulled something loose.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Replaced head gasket: no fire no fuel saybye OEM Tech Discussion 7 February 2nd, 2016 11:23
replaced head gasket...over heating wishihad1 OEM Tech Discussion 3 August 19th, 2010 21:28
replaced head gasket....running a little rough off idle wishihad1 OEM Tech Discussion 4 August 16th, 2010 12:27
new valve cover gasket new rough idle blue95xj OEM Tech Discussion 4 March 28th, 2006 10:35
Rough Idle/Miss after valve cover gasket swap SeattleXJ OEM Tech Discussion 2 April 2nd, 2003 12:31


All times are GMT -7. The time now is 07:24.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014