NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old April 21st, 2005, 14:45
imprtfightr imprtfightr is offline
NAXJA Forum User
 
Join Date: Mar 2004
Location: Fenton, MI
Posts: 21
Please help! Alternator/Battery issue

My 88 XJ. 2.5L Non AC with 74 amp alternator. The other day, I dorve home from work. Parked. About 10 minutes later, I went to move it intot he garage and the battery was dead. Charged the battery for a couple hours. Started right up. Went out next morning, started, drove to work. Drove home 8 hours later. Parked. Went to restart, and it was dead. I replaced the alternator and battery. It seems as though the alternator isn't charging the battery. I can watch the voltage drop while its running (after I jump start it).

Could it be the regulator? Where is it, how do I check it?
Reply With Quote
  #2  
Old April 21st, 2005, 14:49
red91's Avatar
red91 red91 is offline
NAXJA Forum User
 
Join Date: Feb 2004
Location: exact location unknown
Posts: 6,789
Re: Please help! Alternator/Battery issue

IIRC... the regulator is Built into the alternator.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Modified Arizona XJs in 4wheel Drive Magazine Feb issue. ashmanjeepxj Non-Tech / Off Topic 7 January 27th, 2005 14:17
MJ no start - gas tank vent issue? xjblue OEM Tech Discussion 0 September 27th, 2004 12:21
XJ and garage door opener issue? C_M Non-Tech / Off Topic 3 December 7th, 2003 18:09
Strange performance issue (long) thudson OEM Tech Discussion 3 June 20th, 2003 16:36
(UT) RS2477 Roads Issue Is Pressed by Gov. Leavitt Ed A. Stevens Land Use Forum 0 April 8th, 2003 22:55


All times are GMT -7. The time now is 15:23.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014