NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Comanche MJ (1985 - 1992)
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

Jeep Comanche MJ (1985 - 1992) Jeep's Cherokee-based compact pickup technical forum.

Reply
 
Thread Tools Display Modes
  #1  
Old June 3rd, 2020, 18:59
RavenMocker's Avatar
RavenMocker RavenMocker is offline
NAXJA Forum User
 
Join Date: Jan 2014
Location: PNW
Posts: 13
MJ still wonít start! 🥺

1988 MJ 2.5 with manual. One day it just stopped running. So I troubleshoot it down to the fuel pump. Bought a new fuel pump and it ran. Everything was going well and then it wouldnít start. I can hear the fuel pump turn on when ever I turn on the ignition. I have spark and fuel but it wonít start.

I decided to do a tune up. It needed one anyway. Replaced spark plugs, rotor and cap, spark plug wires, the CPS. Even after all the cranking the battery still reads 13.7 vdc. I put new grounding straps in battery to body, body to engine, battery to engine. Still wonít start.

Iím at a dead end. Any other suggestions? This is driving me crazy.
Reply With Quote
  #2  
Old June 3rd, 2020, 19:19
RavenMocker's Avatar
RavenMocker RavenMocker is offline
NAXJA Forum User
 
Join Date: Jan 2014
Location: PNW
Posts: 13
Re: MJ still wonít start! 🥺

It tried to start and then popped and back fires thru the throttle body. I still have spark and fuel.
Reply With Quote
  #3  
Old June 3rd, 2020, 20:32
RavenMocker's Avatar
RavenMocker RavenMocker is offline
NAXJA Forum User
 
Join Date: Jan 2014
Location: PNW
Posts: 13
Re: MJ still wonít start! 🥺

Did I post this in the proper forum?
Reply With Quote
  #4  
Old June 4th, 2020, 11:09
smokeyyank smokeyyank is offline
NAXJA Forum User
 
Join Date: Jul 2014
Location: Littleton, Crawlarado
Posts: 1,094
Re: MJ still wonít start! 🥺

I'd start here http://cruiser54.com/

Then I'd go here.
https://comancheclub.com/
Reply With Quote
  #5  
Old June 4th, 2020, 18:28
RavenMocker's Avatar
RavenMocker RavenMocker is offline
NAXJA Forum User
 
Join Date: Jan 2014
Location: PNW
Posts: 13
Re: MJ still wonít start! 🥺

As you try to start it 98% of the time it won't fire up at all. It won't even act like its going to start. It just turns over and over again doing nothing. But the few times it tried to start the engine started and then rambled and popped and backfired through the throttle body.

I checked the CPS again and it ohms out correctly and the voltage it proper.

I eliminated C-101, one wire at a time and second checked all wires prior to solder and heat shrink. Still not starting up. I rechecked all the spark plug gaps, the new spark plug wires to be certain they are clicking down on the spark plug and the distributor cap. We still have spark. I checked all vacuum lines and other wiring and their connectors. The battery still reads 13.5 VDC. I have not ran number one cylinder up to TDC and checked the rotor bug. I wanted to try all this first.

We are getting fuel but I don't know what the new fuel pump is putting out in pressure.

This came from the factory as a 2.5L with an Automatic 2x4. The PO swapped it to a manual. I'm dreading pulling the dash and checking all wires and those running down the steering column.
Reply With Quote
  #6  
Old June 5th, 2020, 12:46
RavenMocker's Avatar
RavenMocker RavenMocker is offline
NAXJA Forum User
 
Join Date: Jan 2014
Location: PNW
Posts: 13
Re: MJ still wonít start! 🥺

I replaced the ECU with a known good unit and it wonít start. Cylinder one to TDC and rotor bug points to plug one on the distributor cap. I retested the new CPS and the ohms/voltage is dead on. Now moving onto the TPS and MAP.
Reply With Quote
  #7  
Old June 9th, 2020, 17:31
TheCodeMonk TheCodeMonk is offline
NAXJA Member
 
Join Date: Jul 2011
Location: Spokane, WA
Posts: 79
MJ still wonít start! 🥺

I mean...fuel, spark, air. That's all there is to it. You said you're confident in the fuel going into the cylinder? Spark tested at the spark plugs right? Beyond that, just verify valves are letting air in.

Sent from my Pixel 4 using Tapatalk
__________________
2001 White XJ (t-boned - RIP 5/27/19)
3.5" Long Arms (Full Traction) Lift + ACOS and HD Offroad shackle drop, 35x12.5r15, Bushwhacker Flat Flares, JCR Crusader [winch front bumper, non-tire carrier rear bumper, sliders, gas skid), Waggy D44 front w/elocker, 8.8 rear with worn out LSD.

1991 Blue MJ Pioneer - 5.3 LM7, 4L60e, NP231, 33s, 3.54 gears, D30/D44, SOA Lift (~5.5 in the front)
Reply With Quote
  #8  
Old June 11th, 2020, 00:53
RavenMocker's Avatar
RavenMocker RavenMocker is offline
NAXJA Forum User
 
Join Date: Jan 2014
Location: PNW
Posts: 13
Re: MJ still wonít start! 🥺

Cleaned all grounds and added a few others. Cleaned all terminals and sensors, like pretty much anything I havenít done and did a few over. I did notice the CPS male pins were bent to one side. The boy must have bent them... after I straightened them out and made certain they were in the female sides it started up and he has been driving it for the past two days. I hope to gawd thatís it.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard Start when warm, easy start when cold Pinocpao OEM Tech Discussion 4 December 2nd, 2016 17:50
cranks but no start ran great shut it off wont start now scottybeach OEM Tech Discussion 18 October 23rd, 2013 16:05
Wont start; Rough Idle and then stalls when it does start MudslinginXJ OEM Tech Discussion 17 February 24th, 2008 08:30
A short kills my Battery right after start up. it will only start with a jump help! paxj1112 OEM Tech Discussion 4 June 30th, 2007 21:22
'88 Chief Rough Idle or No Start or Perfect Start Hawaiian Style OEM Tech Discussion 8 June 9th, 2003 15:51


All times are GMT -7. The time now is 10:05.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014