NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Other Technical Forums > The Daily Driver
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

The Daily Driver A technical forum for the ride that gets you to work every day.

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old September 26th, 2020, 13:16
Rieper47 Rieper47 is offline
NAXJA Forum User
 
Join Date: Sep 2020
Location: Franklin, TN
Posts: 4
1995 Jeep Cherokee XJ. Multiple issues. Just purchased privately.

Hey yall. First post aside from introduction. Let me know if Iím out of line in post location or anything like that. Thanks!

I just purchased my 95 XJ yesterday. 202,587 original miles as far as the owner knows. The previous owner knows less about vehicles than I do and I donít know a whole lot.

The vehicles oil light comes on after driving for about 15-30 minutes. This seemingly only happens when I come to a stop. Iím assuming the worst in the blown gasket or cracked head situations. Previous owner did tell me it had overheating issues and a little smoke out of the exhaust area in the past. He said installing the fan with shroud near the steering pump seemed to have eliminated the smoke and most of the overheating issues. He did say he has to keep fluid in the coolant overflow. He said it boils. Havenít noticed it myself. I did notice a little bubbling after an hour plus of driving it. Maybe 3-5 bubbles popped up to the surface. I havenít noticed any power loss while driving. Iím not certain if itís actually overheating because it doesnít have a needle. It just has the warning light spot in the cluster. I canít see the oil pressure because again it doesnít have the gauge, just the indicator light. I understand Iíll have to get one to hook up manually. I believe this gets attached at the sending unit..?

The mount for the power steering pump appears to have broken at some point. Appears to have been JB welded into position at some point and that has become just about undone. Iím assuming the mount is an easy pull from the junk yard.

Worse than that there is a slight leak from what Iím assuming is the steering box. It is located below the pump and seems to be where my steering column ends. Right in front of the radiator. Iím assuming replacement isnít fun. I am willing to try. 😂

The hydraulics in the hatch are just about shot. Obviously a simple repair.

The hood is stuck. Worked fine when I inspected it yesterday. Now it is stuck. The previous owner did tell me he replaced the latch on the passenger side. That checked out.

I did notice a very small amount of what looked like tranny fluid dripping from one of the braided covered aluminum lines and onto the sway bar. This is something Iím unfamiliar with.

Once I get the hood open I will provide more information about my finds. Oil color/consistency/quantity.

Body is pretty good. A/c doesnít work as expected. Heat is probably awesome. 🤣 aftermarket stereo install is a little ugly but I donít care. Ashtray is lose. No big deal.

I would really appreciate any and all input for help with this situation. I waited for a long time to find something that looked decent that I could afford. I feel like I screwed the pooch here. After my Chevy 1500 tranny blew out, I figured this was my chance to get an XJ finally. I got the most stock one I could find with the best info possible. Ugh.

Thanks again, yall!


Sent from my iPhone using Tapatalk
Reply With Quote
  #2  
Old September 26th, 2020, 16:38
Rieper47 Rieper47 is offline
NAXJA Forum User
 
Join Date: Sep 2020
Location: Franklin, TN
Posts: 4
1995 Jeep Cherokee XJ. Multiple issues. Just purchased privately.

Got hood unstuck. Found a bad headlight bucket on my way there. 🙄

Under the hood I did notice a few things I missed.

Some sort of solenoid on the firewall on the passenger side. 🤷🏻*♂️ big ole metal coffee tin sized thing has a connection busted. Not sure what the heck that is.

Some tube that comes off of the manifold is cut and caped with a hex screw. 🤔

Another tube has just had its hose removed near front of manifold, I believe, by front of engine and close to valve cover area. Canít find a hose that connects to it. Maybe itís the hose that was cut.

No coolant in oil. Good.

Possible oil in coolant though. Eff me running.

Started engine from cold status with radiator cap removed and the coolant had a mild push of pressure and slopped a few table spoons onto the power steering reservoir. 😤 this is where I saw an oily hue in my coolant.

Didnít have time to check much else.

Thanks again.


Sent from my iPhone using Tapatalk
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1995 Jeep Cherokee mbogosia SEC For Sale / Wanted Forum 4 July 6th, 2011 17:21
few issues with my newly purchased 95 xj wsfd31 OEM Tech Discussion 1 September 11th, 2010 19:23
96 Jeep 4.0L Cherokee Multiple Cylinder Misfire JRU OEM Tech Discussion 5 October 7th, 2009 17:19
1995 Jeep Cherokee futbol4x4xj Arizona For Sale/Wanted 12 August 21st, 2008 19:11


All times are GMT -7. The time now is 23:38.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014