NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > Modified Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

Modified Tech Discussion Forum for Tech related discussion for Modified XJ's and MJ's.

Reply
 
Thread Tools Display Modes
  #1  
Old September 10th, 2019, 18:27
David_BNSF David_BNSF is offline
NAXJA Member
 
Join Date: Mar 2016
Location: Parkville
Posts: 16
Electrical Issue

I upgraded my wiring for my battery to starter, alternator and PDC with the 2 awg welding wire and a DB Electrical 136A alternator. Once I did that, my power door locks stopped working at time and would work intermittently. So I was thinking it was the window switches and replaced both of them with new ones and still they donít work. I have an aftermarket key fob and remote start kit installed as well. The door locks worked perfectly fine before the upgrades on my 99 Cherokee Sport. Any ideas? Thanks for any input.
Reply With Quote
  #2  
Old September 10th, 2019, 21:00
Heavyopp Heavyopp is offline
NAXJA Member
 
Join Date: Jan 2017
Location: Middlesex, NJ
Posts: 785
Re: Electrical Issue

Gotta take a look at the wires in the door jamb -- Very common for them to break right in the rubber boot -- pull the kick panel on the driver side to get a look at them
Reply With Quote
  #3  
Old September 11th, 2019, 04:56
David_BNSF David_BNSF is offline
NAXJA Member
 
Join Date: Mar 2016
Location: Parkville
Posts: 16
Re: Electrical Issue

That’s what I was thinking but what’s weird is every time I pull the key out of the ignition all the doors lock on their own.
Reply With Quote
  #4  
Old September 11th, 2019, 19:19
Heavyopp Heavyopp is offline
NAXJA Member
 
Join Date: Jan 2017
Location: Middlesex, NJ
Posts: 785
Re: Electrical Issue

Quote:
Originally Posted by David_BNSF View Post
Thatís what I was thinking but whatís weird is every time I pull the key out of the ignition all the doors lock on their own.

Ok sounds like a short in lock circuit -- I still bet its in the rubber boot

I chased that key thing for a few days when I 1st had my XJ -- sometimes they worked, sometimes they didn't -- Finally figured out that the doors won't lock with the key in and every time mine wouldn't work it was with the key in -- drove me crazy for a few days

What I bet is happening with yours is you have 2 wires touching in the door boot -- this is activating the door locks -- The key in the ignition overrides the door lock signal -- pull the key and the short is now allowed to lock the doors
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
99 XJ electrical fan issue Scotts99XJ OEM Tech Discussion 16 January 4th, 2013 10:04
odd (to me) electrical issue.... oldcancer OEM Tech Discussion 10 December 10th, 2012 14:50
98 with electrical issue...I think gabe4 OEM Tech Discussion 1 December 3rd, 2011 13:58
Electrical issue jrb4x4 OEM Tech Discussion 3 February 20th, 2009 22:26
Electrical issue? relyt OEM Tech Discussion 6 December 10th, 2008 14:30


All times are GMT -7. The time now is 21:09.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014