NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old October 26th, 2014, 20:55
HunterRivett HunterRivett is offline
NAXJA Forum User
 
Join Date: Oct 2014
Location: Arkansas
Posts: 7
1998 XJ Barely Starts, Sputters and Backfires at 2000 RPMS

Hello! I recently purchased a 1998 XJ Sport (4.0 I6, Auto, 4x4) The original motor was warped crazy and so I had it replaced with another 4.0 I6 from a 1996 XJ. This 1996 motor has 160XXX and the 1998 body has 130XXX. Upon start up, which only happens after a rough and long crank, it will idle relatively fine, and will advance to about 2000 RPMs and then sputter and backfire very rapidly. The spark from the plugs, which are new, is also relatively orange. Compression is good, however cylinder 3 is about 105psi (the lowest of them all) and to my bewilderment, the original engine which had bad compression showed the lowest in cylinder 3 as well. Please any and all help would be appreciated! Thanks.
Reply With Quote
  #2  
Old October 26th, 2014, 23:41
JeepNoob JeepNoob is offline
NAXJA Forum User
 
Join Date: Oct 2014
Location: Pueblo, Colorado
Posts: 381
Re: 1998 XJ Barely Starts, Sputters and Backfires at 2000 RPMS

Cylinder 3 is definitely outta spec. Out of curiousity, how are you running this compression test? Proper procedure calls for the engine warmed up, the throttle plate blocked open, and at least 4 rotations of the cylinder being tested. An easy way to test for why you have bad compression is to squirt a little bit of clean engine oil into that cylinder (and I mean A LITTLE BIT. Like, one or two pumps from an oil can. Don't wanna be hydrolocking that engine.) If you do the compression test again and your reading improves, you've got bad rings or a worn cylinder bore. If not, you've got valves that aren't sealing quite right. Any idiot or check engine lights going off? I've also heard of seemingly good but actually bad spark plug wires causing issues with engines, especially with the speeds you're talking about. Easy way to test that is to spray glass cleaner on them and bring the engine up to speed. From what I've heard, it'll make them glow if the wires are "leaking" high voltage.

Last edited by JeepNoob; October 26th, 2014 at 23:45.
Reply With Quote
  #3  
Old October 27th, 2014, 06:11
HunterRivett HunterRivett is offline
NAXJA Forum User
 
Join Date: Oct 2014
Location: Arkansas
Posts: 7
Re: 1998 XJ Barely Starts, Sputters and Backfires at 2000 RPMS

Yes I have done the compression test like you mentioned, I have not checked the rings with oil for I am happy enough at the moment with that pressure. I will triple check the wires. I have decent compression, spark, fuel, air, etc. everything it needs to run, and it does, but really bad and noisy as you advance. Is their something forgotten in the swap specific to a 1998 XJ? I have considered resetting the ECM, and doing then doing the loosen up trick on the ECM. I have also considered swapping the upmost O2 sensor and reinstalling a catalytic converter and the O2 sensor on it. (I probably should have said this before, but Im not thinking its the problem, there is no cat and respective O2 sensor.) No codes and no lights.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
starts, sputters, dies... tazam80 OEM Tech Discussion 3 October 8th, 2013 04:49
99 sputters at 2000 RPM bmpweXJ OEM Tech Discussion 10 February 11th, 2012 20:53
95xj everyday sputters, backfires through tb, wants to stall after startup only!!! 95cherjustin OEM Tech Discussion 11 September 8th, 2009 21:55
89 sputters and backfires (intake) XJ89Kentucky OEM Tech Discussion 4 April 13th, 2009 01:04
Starts, Idles, Sputters, Dies TN William OEM Tech Discussion 3 April 21st, 2003 07:28


All times are GMT -7. The time now is 06:59.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014