NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old June 18th, 2008, 15:15
new5000 new5000 is offline
NAXJA Forum User
 
Join Date: Dec 2007
Location: Green Lane, PA
Posts: 11
Charging System Trouble

OK I have an 87 4cyl. I recently replaced a dead battery and then discovered that the alternator was only charging at 12V so I had it checked at autozone and it was only generating 5A. So I replaced the alternator. With the new alt. the charging voltage is still only 12V not the norm 13-15V. Sooo...new alt. and batt. and I checked all of the connections and wires and all looks legit. By the way all of the accessories work fine.

What am I missing here? Is there more to the charging system???
Why only 12V when I definately had 14V before, when all was good?
Reply With Quote
  #2  
Old June 18th, 2008, 15:47
new5000 new5000 is offline
NAXJA Forum User
 
Join Date: Dec 2007
Location: Green Lane, PA
Posts: 11
Re: Charging System Trouble

thanks for all the help guys
Reply With Quote
  #3  
Old June 18th, 2008, 16:33
Saudade's Avatar
Saudade Saudade is offline
NAXJA Member
 
Join Date: May 2005
Location: SoCal
Posts: 2,311
Re: Charging System Trouble

Wow, you waited a whole 16 minutes before getting pissed off no one replied?
Reply With Quote
  #4  
Old June 18th, 2008, 22:24
Flyfisher's Avatar
Flyfisher Flyfisher is offline
NAXJA Forum User
 
Join Date: Sep 2003
Location: Billings, Montana
Posts: 835
Re: Charging System Trouble

I'd check, and re-check grounds. Jeeps are notious for bad grounds. Can cause all sorts of problems. Replace if in doubt.
Reply With Quote
  #5  
Old June 18th, 2008, 22:42
5-90's Avatar
5-90 5-90 is offline
NAXJA Forum User
 
Join Date: Mar 2003
Location: Hammerspace
Posts: 18,821
Re: Charging System Trouble

Quote:
Originally Posted by Flyfisher
I'd check, and re-check grounds. Jeeps are notious for bad grounds. Can cause all sorts of problems. Replace if in doubt.
Especially RENIX-era (1987-1990, gas engine) XJ and MJ.

Pay particular attention to the ground strap from the cylinder head to the firewall - a shonky connection there can cause all sorts of headaches for you.

And, give your question some time before it gets answered. It helps...
Reply With Quote
  #6  
Old June 19th, 2008, 00:15
wim hoppenbrouwers's Avatar
wim hoppenbrouwers wim hoppenbrouwers is offline
NAXJA Forum User
 
Join Date: Sep 2003
Location: Netherlands europe
Posts: 1,297
Re: Charging System Trouble

Hallo. It is better to take the measurements on the altenator itself. Did you?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Charging system gremlin Ernrok OEM Tech Discussion 4 January 1st, 2008 08:15
Questions about charging A/C system JoshRountree OEM Tech Discussion 12 October 26th, 2007 14:45
Charging system The Federation OEM Tech Discussion 4 October 25th, 2006 15:54
charging system rebelrat OEM Tech Discussion 2 July 10th, 2006 20:14
XJ charging trouble/fusable link? Chark Modified Tech Discussion 1 August 6th, 2005 08:11


All times are GMT -7. The time now is 05:46.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014