NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old May 10th, 2014, 05:26
50yearXJ's Avatar
50yearXJ 50yearXJ is offline
NAXJA Forum User
 
Join Date: Jan 2006
Location: PA
Posts: 24
Trouble codes 11 and 17?

So for the second time in 3 months my junk (96 i6 5spd d30F ChryCo8.25R, 225k on body and trans about 100k on motor, supposedly) has thrown trouble code 11 and 17. I've been doing my obligatory searching prior to posting but I'm not having the same symptoms as a lot of people with CPS issues. It starts fine. Doesn't cut out on me. The only symptom I noticed was a lack of power under load (could be 33s on 3.55 gears tho) and pinging under load. After replacing the Tstat, fuel filter, plugs and wires, Seafoam in the brake boost vac hose, and 2 bottles of Techron in the tank. It seems better but my concern is that code 11 should clear once the signal from the CPS is detected by the PCM, correct? Should I replace the CPS even tho I don't have the typical No Start or Cut out issue? I'm stumped.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Got some trouble codes for ya BlueWeasel Colorado Chapter 11 September 16th, 2011 09:09
More trouble codes 90NHXJ OEM Tech Discussion 1 June 14th, 2009 12:05
Help with Trouble Codes xjguy98 OEM Tech Discussion 4 July 25th, 2008 06:20
trouble codes 13 and 51...... Beezil OEM Tech Discussion 11 August 8th, 2004 09:00
Trouble codes... mean anything? Lucas OEM Tech Discussion 8 August 13th, 2003 16:35


All times are GMT -7. The time now is 10:33.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014