NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old May 31st, 2008, 14:54
bizkit642's Avatar
bizkit642 bizkit642 is offline
NAXJA Forum User
 
Join Date: Apr 2007
Location: Topeka, KS
Posts: 247
89 XJ cutting out....

The ONLY time it does it is taking off from a stop, it sputters for just a quick second, and then all is good.

Anything common on these Renix motors?

-Andrew
Reply With Quote
  #2  
Old May 31st, 2008, 16:43
Ecomike's Avatar
Ecomike Ecomike is offline
NAXJA# 2091
 
Join Date: Dec 2006
Location: MilkyWay Galaxy
Posts: 15,274
Re: 89 XJ cutting out....

TPS sensor going bad.
__________________
Quote=8Mud: "Go ahead and put up the best fence you can build, I'll bet on some Mexican with a few dollars of nails and a pile of scrap lumber."
34 MPG , '85 2WD Cherokee Pioneer with custom installed, 64 hp, 2.2 L Nissan SD22 Diesel 5 spd Manual; & 4 Renix XJs, '87 Wagoneer 4.0, 4WD, 89-Cherokee, 4WD, '87 Cherokee 2WD, & '89 Cherokee Pioneer 2WD, all 4dr. #2091
Reply With Quote
  #3  
Old May 31st, 2008, 16:55
bizkit642's Avatar
bizkit642 bizkit642 is offline
NAXJA Forum User
 
Join Date: Apr 2007
Location: Topeka, KS
Posts: 247
Re: 89 XJ cutting out....

Quote:
Originally Posted by Ecomike
TPS sensor going bad.
I'll give it a try.

Thank you.

-Andrew
Reply With Quote
  #4  
Old May 31st, 2008, 17:23
joeyschribar joeyschribar is offline
NAXJA Forum User
 
Join Date: Feb 2008
Location: Edmonton
Posts: 79
Re: 89 XJ cutting out....

yea i second that, same thing happened to me, do you find that your tranny dosent downshift when you stomp on the pedal at highway speeds?
Reply With Quote
  #5  
Old May 31st, 2008, 18:16
bizkit642's Avatar
bizkit642 bizkit642 is offline
NAXJA Forum User
 
Join Date: Apr 2007
Location: Topeka, KS
Posts: 247
Re: 89 XJ cutting out....

Quote:
Originally Posted by joeyschribar
yea i second that, same thing happened to me, do you find that your tranny dosent downshift when you stomp on the pedal at highway speeds?
Well kinda, this is the first time I've driven it since I bought it LOL 2 months ago.

I haven't even gotten up to highway speeds.

-Andrew
Reply With Quote
  #6  
Old May 31st, 2008, 18:20
mattbred's Avatar
mattbred mattbred is offline
NAXJA Forum User
 
Join Date: Apr 2007
Location: Canada
Posts: 753
Re: 89 XJ cutting out....

I wouldn't neccesarily say it's your TPS, though it could be a possibility. My '89 does the same thing, usually only when it's cold though. I've tested 3 TPS's with the same results. Hell I've had my TPS at .69 volts, at .7 volts and .8 volts and it hasn't really changed a thing. However it could be low fuel pressure.
Reply With Quote
  #7  
Old May 31st, 2008, 18:31
bizkit642's Avatar
bizkit642 bizkit642 is offline
NAXJA Forum User
 
Join Date: Apr 2007
Location: Topeka, KS
Posts: 247
Re: 89 XJ cutting out....

Mine does it hot and cold.

-Andrew
Reply With Quote
  #8  
Old June 7th, 2008, 21:42
bizkit642's Avatar
bizkit642 bizkit642 is offline
NAXJA Forum User
 
Join Date: Apr 2007
Location: Topeka, KS
Posts: 247
Re: 89 XJ cutting out....

Well replaced the TPS from another XJ I have sitting around. It fixes the being able to downshift on highway speeds, but still stutters taking off. How do you correctly adjust this or do you think I have other issues?

-Andrew
Reply With Quote
  #9  
Old June 8th, 2008, 14:46
Ecomike's Avatar
Ecomike Ecomike is offline
NAXJA# 2091
 
Join Date: Dec 2006
Location: MilkyWay Galaxy
Posts: 15,274
Re: 89 XJ cutting out....

There are many TPS failure symptoms. How do you know the other TPS is good?

Hesitation anywhere in the throttle range from idle to WOT can be a bad spot on the TPS. Also poor electrical contacts anywhere between the TPS and the ECU * can cause hesitation at take off. Hesitation during initial acceleration can be an O2 sensor going bad, specifically giving a slow response causing the hesitation, but working well enough to seem to be working and thus not giving a CEL yet. (* Note Renix was an ECU, Chrysler renamed it a PCM in 1996, OBD-II, I beleive).

The only other place I have seen this is a loose or leaking vacuum line to the MAP sensor, especially the connection at the bottom side of the throttle body. MAP sensor rarely fails.

Bad plug wires and bad rotors and caps can cause hesitation and misses, but it is usually more widespread, not just at idle take off. Same for low pressure, it usually shows up at more widespread rpms and acceleration conditions.

How about a sticking, or leaking EGR valve?????
__________________
Quote=8Mud: "Go ahead and put up the best fence you can build, I'll bet on some Mexican with a few dollars of nails and a pile of scrap lumber."
34 MPG , '85 2WD Cherokee Pioneer with custom installed, 64 hp, 2.2 L Nissan SD22 Diesel 5 spd Manual; & 4 Renix XJs, '87 Wagoneer 4.0, 4WD, 89-Cherokee, 4WD, '87 Cherokee 2WD, & '89 Cherokee Pioneer 2WD, all 4dr. #2091
Reply With Quote
  #10  
Old June 9th, 2008, 09:24
cygnus58 cygnus58 is offline
NAXJA Forum User
 
Join Date: May 2007
Location: pa/
Posts: 318
Re: 89 XJ cutting out....

egr x2
Reply With Quote
  #11  
Old June 9th, 2008, 18:45
mattbred's Avatar
mattbred mattbred is offline
NAXJA Forum User
 
Join Date: Apr 2007
Location: Canada
Posts: 753
Re: 89 XJ cutting out....

A bad EGR will usually raise it's ugly head at idle too. It would have a really hard time idling and taking off.

I'm pretty sure a vac leak could cause hesitation..
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cutting down the mj dellstopjeep Modified Tech Discussion 16 October 23rd, 2006 21:10
4.0 is cutting out, help! saybye Modified Tech Discussion 5 October 16th, 2006 08:21
AC Cutting Out StylerG OEM Tech Discussion 1 August 6th, 2006 20:41
why is it cutting out?? ryan7839 OEM Tech Discussion 1 July 29th, 2006 18:53
cutting rear quater panel, no really cutting. Weasel Modified Tech Discussion 19 November 22nd, 2003 16:03


All times are GMT -7. The time now is 21:05.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014