NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old June 4th, 2018, 17:48
chris420 chris420 is offline
NAXJA Forum User
 
Join Date: Jan 2007
Location: California
Posts: 665
High Idle Need Help

I just got my Jeep out of the shop I had it in for several issues one was high idle. My idle is around 1500 when in neutral or 1000 when In drive. The shop lubricated the cable cleaned the throttle body and cleaned the Mass airflow sensor. The high idle does not happen until the engine gets heat soaked after about 3o minutes of driving in 90 degree weather. I am going to take it back to the shop tomorrow does anyone have ideas of what may be causing the high idle?
Reply With Quote
  #2  
Old June 4th, 2018, 18:56
Czjeeper Czjeeper is offline
NAXJA Forum User
 
Join Date: Aug 2017
Location: S.w. Wa
Posts: 9
High Idle Need Help

You donít have a mass air flow sensor.
You need a new shop that knows what they are doing. Smoke the intake or spray to check for vacuum leaks, also the injector seals.
Verify the IAC position is correct.
Wiggle test the TPS.
Verify the throttle valve isnít dragging.
Reply With Quote
  #3  
Old June 4th, 2018, 19:01
blu3fan's Avatar
blu3fan blu3fan is offline
NAXJA Forum User
 
Join Date: Apr 2009
Location: california
Posts: 286
Re: High Idle Need Help

Lots of reasons.
Cracked headers.
Air leak at manifold.
IACV
MAPS
Reply With Quote
  #4  
Old June 4th, 2018, 19:09
chris420 chris420 is offline
NAXJA Forum User
 
Join Date: Jan 2007
Location: California
Posts: 665
Re: High Idle Need Help

Quote:
Originally Posted by Czjeeper View Post
You donít have a mass air flow sensor.
You need a new shop that knows what they are doing. Smoke the intake or spray to check for vacuum leaks, also the injector seals.
Verify the IAC position is correct.
Wiggle test the TPS.
Verify the throttle valve isnít dragging.
Reply With Quote
  #5  
Old June 4th, 2018, 19:11
chris420 chris420 is offline
NAXJA Forum User
 
Join Date: Jan 2007
Location: California
Posts: 665
Re: High Idle Need Help

Maybe they meant MAP sensor.
Reply With Quote
  #6  
Old June 4th, 2018, 20:06
chris420 chris420 is offline
NAXJA Forum User
 
Join Date: Jan 2007
Location: California
Posts: 665
Re: High Idle Need Help

One thing why is th idle only getting high when the engine is hot? If it were any of the issues mentioned wouldnít be happening all the time? I just started the Jeep after having it cool down for a for 2hours and idle is at 700 rpm. I let it run for 10minutes getting it to 210 and it still idled at 700 RPM.
Reply With Quote
  #7  
Old June 5th, 2018, 17:08
chris420 chris420 is offline
NAXJA Forum User
 
Join Date: Jan 2007
Location: California
Posts: 665
Re: High Idle Need Help

Today the high idle was back but not until the engine had been running for 45 minutes. I was driving it and it shut down. It literliy turned off around 25 mph like someone had pulled the plug. It would not start for 20 minutes. When it did start back up it was like it was being starved of gas ⛽️I had to keep turning it over while pumping the pedal and then boom it started back up. Itís at the shop now.
Reply With Quote
  #8  
Old June 5th, 2018, 17:56
RCP Phx RCP Phx is online now
NAXJA Forum User
 
Join Date: Mar 2003
Location: Phoenix,Az
Posts: 11,183
Re: High Idle Need Help

I would have to say that you need to do some data-logging to record what's happening!
Reply With Quote
  #9  
Old June 5th, 2018, 18:31
chris420 chris420 is offline
NAXJA Forum User
 
Join Date: Jan 2007
Location: California
Posts: 665
Re: High Idle Need Help

Quote:
Originally Posted by RCP Phx View Post
I would have to say that you need to do some data-logging to record what's happening!
I started recording videos and have been showing them to the shop.
Reply With Quote
  #10  
Old June 5th, 2018, 18:32
chris420 chris420 is offline
NAXJA Forum User
 
Join Date: Jan 2007
Location: California
Posts: 665
Re: High Idle Need Help

I hope we figure it out soon I hate breaking down at speed I lose power breaks and steering kind of sucks.
Reply With Quote
  #11  
Old June 5th, 2018, 18:35
chris420 chris420 is offline
NAXJA Forum User
 
Join Date: Jan 2007
Location: California
Posts: 665
Re: High Idle Need Help

Do you think it could be the fuel pump?
Reply With Quote
  #12  
Old June 5th, 2018, 19:34
RCP Phx RCP Phx is online now
NAXJA Forum User
 
Join Date: Mar 2003
Location: Phoenix,Az
Posts: 11,183
Re: High Idle Need Help

Quote:
Originally Posted by RCP Phx View Post
I would have to say that you need to do some data-logging to record what's happening!
Reply With Quote
  #13  
Old June 5th, 2018, 20:12
chris420 chris420 is offline
NAXJA Forum User
 
Join Date: Jan 2007
Location: California
Posts: 665
Re: High Idle Need Help

What kind of data are you referring to?
Reply With Quote
  #14  
Old June 6th, 2018, 05:51
cruiser54's Avatar
cruiser54 cruiser54 is offline
NAXJA Forum User
 
Join Date: Nov 2009
Location: Prescott, Az
Posts: 6,403
Re: High Idle Need Help

Do we have any idea what year this is?
Reply With Quote
  #15  
Old June 6th, 2018, 07:06
RCP Phx RCP Phx is online now
NAXJA Forum User
 
Join Date: Mar 2003
Location: Phoenix,Az
Posts: 11,183
Re: High Idle Need Help

The OP's profile says 2000.

Data like O2 readings, fuel trims, % throttle, map sensor readings, etc.....
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
'89 XJ - High Idle, high NOx (vehicle is in california) BulletMaker OEM Tech Discussion 5 January 12th, 2014 18:46
Rough idle, then high idle when warm. Renegade_Azzy OEM Tech Discussion 11 March 19th, 2013 10:49
High idle, and high rpms at start? Bad gas mileage bigboyslimjimbo OEM Tech Discussion 15 April 24th, 2012 19:36
1996 low idle/stumbling at start - high idle after driving CommandoXJ96 OEM Tech Discussion 12 November 28th, 2007 09:59
High pitched whine from the engine at high idle, running speed twisted_ed OEM Tech Discussion 3 September 30th, 2006 18:59


All times are GMT -7. The time now is 10:54.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014