NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #16  
Old June 6th, 2018, 09:36
chris420 chris420 is offline
NAXJA Forum User
 
Join Date: Jan 2007
Location: California
Posts: 665
Re: High Idle Need Help

Yes it is a 2000 so looks like I will need an OBD II reader to record the data.
Reply With Quote
  #17  
Old June 6th, 2018, 21:58
chris420 chris420 is offline
NAXJA Forum User
 
Join Date: Jan 2007
Location: California
Posts: 665
Re: High Idle Need Help

Shop informed me that the computer had a failed code for the CSPS and idler air control valve they replaced both and will be driving it for a few days to insure nothing else pops up. They also said the computer says the Jeep should have 4 o2 sensors but it only has 2 I told them thats probably because itís an Arizona vehicle and does not have pre cats can anyone verify my assumption is correct?
Reply With Quote
  #18  
Old June 7th, 2018, 00:32
RCP Phx RCP Phx is offline
NAXJA Forum User
 
Join Date: Mar 2003
Location: Phoenix,Az
Posts: 11,178
Re: High Idle Need Help

Federal emissions only has 2 O2 sensors, Cali emissions has 4 O2 sensors. But the PCM's and the wiring harness are different.
Reply With Quote
  #19  
Old June 7th, 2018, 00:50
RCP Phx RCP Phx is offline
NAXJA Forum User
 
Join Date: Mar 2003
Location: Phoenix,Az
Posts: 11,178
Re: High Idle Need Help

I just went thru this back in January........
https://naxja.org/forum/showthread.php?t=1145993
Reply With Quote
  #20  
Old June 7th, 2018, 05:49
chris420 chris420 is offline
NAXJA Forum User
 
Join Date: Jan 2007
Location: California
Posts: 665
Re: High Idle Need Help

Ok so I donít need to worry about anything then? Itís the original harness I have never changed it. Chrysler installed the same PCM for all XJís so it will always be looking for 4 02 sensors?
Reply With Quote
  #21  
Old June 7th, 2018, 08:51
RCP Phx RCP Phx is offline
NAXJA Forum User
 
Join Date: Mar 2003
Location: Phoenix,Az
Posts: 11,178
Re: High Idle Need Help

Quote:
Originally Posted by chris420 View Post
Chrysler installed the same PCM for all XJís so it will always be looking for 4 02 sensors?
No the PCM's are specific the year/emissions model.
Reply With Quote
  #22  
Old June 7th, 2018, 10:42
chris420 chris420 is offline
NAXJA Forum User
 
Join Date: Jan 2007
Location: California
Posts: 665
Re: High Idle Need Help

Why would the PCM looking for 4 02 sensors and the Jeep only has 2?
Reply With Quote
  #23  
Old June 7th, 2018, 11:42
RCP Phx RCP Phx is offline
NAXJA Forum User
 
Join Date: Mar 2003
Location: Phoenix,Az
Posts: 11,178
Re: High Idle Need Help

What does your VIN# say for type of emissions? If your not getting a CEL then every things ok!
Reply With Quote
  #24  
Old June 7th, 2018, 12:36
chris420 chris420 is offline
NAXJA Forum User
 
Join Date: Jan 2007
Location: California
Posts: 665
Re: High Idle Need Help

Ok thanks
Reply With Quote
  #25  
Old June 11th, 2018, 16:59
chris420 chris420 is offline
NAXJA Forum User
 
Join Date: Jan 2007
Location: California
Posts: 665
Re: High Idle Need Help

Jeep is fixed here is the conclusion
Stalling was caused by a bad Crank Shaft Positioning Sensor.
High Idle was caused by two things 1. Bad Idler Air Valve 2. One of the previous shops I took it to modified the throttle cable to compensate for the bad idler air valve and the throttle cable was getting hung up.
Reply With Quote
  #26  
Old June 11th, 2018, 20:53
cruiser54's Avatar
cruiser54 cruiser54 is offline
NAXJA Forum User
 
Join Date: Nov 2009
Location: Prescott, Az
Posts: 6,403
Re: High Idle Need Help

Quote:
Originally Posted by chris420 View Post
Jeep is fixed here is the conclusion
Stalling was caused by a bad Crank Shaft Positioning Sensor.
High Idle was caused by two things 1. Bad Idler Air Valve 2. One of the previous shops I took it to modified the throttle cable to compensate for the bad idler air valve and the throttle cable was getting hung up.
Thanks for the update. What crap that gets done never ceases to amaze me.
Reply With Quote
  #27  
Old June 12th, 2018, 20:42
chris420 chris420 is offline
NAXJA Forum User
 
Join Date: Jan 2007
Location: California
Posts: 665
Re: High Idle Need Help

In my conclusion I said the stalling was caused by a failed CPS. I picked it up today and it was a failed cam shaft position sensor not a failed CPS.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
'89 XJ - High Idle, high NOx (vehicle is in california) BulletMaker OEM Tech Discussion 5 January 12th, 2014 18:46
Rough idle, then high idle when warm. Renegade_Azzy OEM Tech Discussion 11 March 19th, 2013 10:49
High idle, and high rpms at start? Bad gas mileage bigboyslimjimbo OEM Tech Discussion 15 April 24th, 2012 19:36
1996 low idle/stumbling at start - high idle after driving CommandoXJ96 OEM Tech Discussion 12 November 28th, 2007 09:59
High pitched whine from the engine at high idle, running speed twisted_ed OEM Tech Discussion 3 September 30th, 2006 18:59


All times are GMT -7. The time now is 03:59.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014