NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old April 15th, 2005, 10:21
StuckXJ's Avatar
StuckXJ StuckXJ is offline
I have not Confirmed, or I used a BAD email Addy
 
Join Date: Mar 2004
Location: Massachusetts
Posts: 207
Unhappy Error codes

I just checked the codes after the check engin light whent on and it bogged down when throttle was applied then reved. It did this until it eventualy died. I managed to get it home by disconecting the battery tps mat and one other sensor in the area. After trying for about an hour it kicked over started rough then smoothed out. I pluged everything in real quick and got it home. The code I got were in this order, 12, 22, 51, 24, 23,55. Hynes says it is (respectivly), battery disconnected in the last 50 starts, coolent temp sensor, o2 sensor, tps, intake air temp sensor, and end code output. I suspect the coolant temp sensor is gone because the gauge only works sometimes. But the intake temp sensor may be causing this code because i disconected it. Befor i messed with it to try and start it when it died on me it was only reading one code a 2sumthing, i think tps. Does the boging then reving up sound symptomatic of a tps failure? or are all those sensors gone and it wont run till i fix them? Thanks for any help.
-Steve D
Reply With Quote
  #2  
Old April 15th, 2005, 10:23
StuckXJ's Avatar
StuckXJ StuckXJ is offline
I have not Confirmed, or I used a BAD email Addy
 
Join Date: Mar 2004
Location: Massachusetts
Posts: 207
Unhappy Re: Error codes

By the way, its a 1992 4.0 automatic
Reply With Quote
  #3  
Old April 15th, 2005, 10:27
olivedrabcj7's Avatar
olivedrabcj7 olivedrabcj7 is offline
NAXJA Member #1384
 
Join Date: Oct 2004
Location: Hot Springs, Arkansas
Posts: 1,059
Re: Error codes

probably a combination of tps and 02 sensors shooting false codes to the ECU making it run like shat. replace em both.
Reply With Quote
  #4  
Old April 15th, 2005, 10:32
StuckXJ's Avatar
StuckXJ StuckXJ is offline
I have not Confirmed, or I used a BAD email Addy
 
Join Date: Mar 2004
Location: Massachusetts
Posts: 207
Re: Error codes

thanks looks like im off to autozone
Reply With Quote
  #5  
Old April 15th, 2005, 10:54
StuckXJ's Avatar
StuckXJ StuckXJ is offline
I have not Confirmed, or I used a BAD email Addy
 
Join Date: Mar 2004
Location: Massachusetts
Posts: 207
Question Re: Error codes

I was calling around for prices... $30 at autozone for the tps, and map was also $30(replaced last night) but for the o2 sensor it $50-70!! is this average?
Reply With Quote
  #6  
Old April 15th, 2005, 10:56
olivedrabcj7's Avatar
olivedrabcj7 olivedrabcj7 is offline
NAXJA Member #1384
 
Join Date: Oct 2004
Location: Hot Springs, Arkansas
Posts: 1,059
Re: Error codes

that sounds about right. i think there are 2 O2 sensors under there. make sure you replace the right one.
Reply With Quote
  #7  
Old April 15th, 2005, 10:59
StuckXJ's Avatar
StuckXJ StuckXJ is offline
I have not Confirmed, or I used a BAD email Addy
 
Join Date: Mar 2004
Location: Massachusetts
Posts: 207
Re: Error codes

... never mind its $50-102. thats what it would cost at the dealership... The same bosch one at autozone for 2x the price!
Reply With Quote
  #8  
Old April 15th, 2005, 11:00
StuckXJ's Avatar
StuckXJ StuckXJ is offline
I have not Confirmed, or I used a BAD email Addy
 
Join Date: Mar 2004
Location: Massachusetts
Posts: 207
Re: Error codes

How do i know which is the right one? Thanks
Reply With Quote
  #9  
Old April 15th, 2005, 11:05
DXJ's Avatar
DXJ DXJ is offline
NAXJA Forum User
 
Join Date: May 2003
Location: Livermore, CA
Posts: 148
Re: Error codes

Your 92 should only have 1 Oxygen sensor. 96+ XJs have a second sensor after the cat.

Last edited by DXJ; April 15th, 2005 at 11:17.
Reply With Quote
  #10  
Old April 15th, 2005, 11:08
olivedrabcj7's Avatar
olivedrabcj7 olivedrabcj7 is offline
NAXJA Member #1384
 
Join Date: Oct 2004
Location: Hot Springs, Arkansas
Posts: 1,059
Re: Error codes

# 51 - Oxygen sensor stuck at lean position (Bob Lincoln wrote: may be tripped by a bad MAP sensor system causing a rich condition, and the O2 sensor trying to compensate. The O2 sensor may still be good. The MAP assembly consists of two pieces, the valve and the vacuum transducer (round plastic unit with cylinder on top and both electrical and vacuum connections) - If you get hot rough idle and stalling, especially on deceleration, accompanied by flooded engine and difficulty restarting, that can be a bad MAP sensor causing the O2 sensor to try to compensate. If you get poor cold driveability, stumbling and bucking, and acceptable warm driving with poor gas mileage (a drop of 10 mpg or more), that is usually the O2 sensor. [Webmaster note: MAP sensors seem to die regularly.]

im not sure how to tell. maybe somebody else can chime in who knows hwo to tell which one it is.
Reply With Quote
  #11  
Old April 15th, 2005, 11:12
StuckXJ's Avatar
StuckXJ StuckXJ is offline
I have not Confirmed, or I used a BAD email Addy
 
Join Date: Mar 2004
Location: Massachusetts
Posts: 207
Re: Error codes

The map sensor is only 16 hours old. Ran awsome last night (only drove 2miles) and the same a few min ago. It seems that the problems happen when It warms up.
Reply With Quote
  #12  
Old April 15th, 2005, 11:14
olivedrabcj7's Avatar
olivedrabcj7 olivedrabcj7 is offline
NAXJA Member #1384
 
Join Date: Oct 2004
Location: Hot Springs, Arkansas
Posts: 1,059
Re: Error codes

id replace the o2 sensor and see if that fixes it. if it doesnt, put it back in the box and get a refund.
Reply With Quote
  #13  
Old April 15th, 2005, 11:35
StuckXJ's Avatar
StuckXJ StuckXJ is offline
I have not Confirmed, or I used a BAD email Addy
 
Join Date: Mar 2004
Location: Massachusetts
Posts: 207
Re: Error codes

along with the tps or both... im 18 and its pay day... i get my wopping check that would cover both parts and only those... no gas so if i could get away with one which should i try... or just get them both and try to borrow some cash lol Thanck a ton for all the help.
Reply With Quote
  #14  
Old April 15th, 2005, 18:14
StuckXJ's Avatar
StuckXJ StuckXJ is offline
I have not Confirmed, or I used a BAD email Addy
 
Join Date: Mar 2004
Location: Massachusetts
Posts: 207
Re: Error codes

Any more imput befor i got parts shopping tommorow?
Reply With Quote
  #15  
Old April 15th, 2005, 19:16
StuckXJ's Avatar
StuckXJ StuckXJ is offline
I have not Confirmed, or I used a BAD email Addy
 
Join Date: Mar 2004
Location: Massachusetts
Posts: 207
Re: Error codes

The only reason im hesitant about buyin the o2 sensor is: the o2 sensor shouldn't cause then engine to stall. How many sensors do this? I thought the map sensor was one but that only helped, it still stalled.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 16:26.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014