NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old June 6th, 2019, 20:09
Pgw1995 Pgw1995 is offline
NAXJA Forum User
 
Join Date: Jun 2019
Location: Arkansas
Posts: 21
AW4 transmission hesitates going into reverse

Ok, guys, I have read a lot of forums and talked to people about my AW4 tranny. It hesitates going in to reverse when it has warmed up, when itís cold it does pretty good, maybe a slight hesitation. It seems like it slips from OD to 3rd a lot with regular highway driving shifts out fine. I havenít had the Jeep long. I unplugged the TCM, unlike I was told it should do it shifted through the gears with it unplugged. It did take an eternity for it to go in reverse though. I checked the TPS (not sure if that has anything to do with reverse) but I checked it. I have my 5v, now I heard the other 2 wires should be ground and .26v, I do have a good ground but the 3rd wire is .9v (no throttle). When I ease down on the throttle it has a good steady climb but stops at 3.9 which from what I read is dead bottom (it should be over 3.9). Leaving work today I taped up my brake switch, I think that fixed my OD to 3rd changing, not for sure, havenít driven it enough yet to know for sure. I havenít checked solenoids yet. Iím just confused on why I didnít have to manually shift it with TCM unplugged. The engine was cold when I did these tests, My TPM my be going bad. I just canít figure out why it takes so long to shift to reverse. Any help on what else to check please give me advice before I have to drop the tranny. Fluid looks great, I am going to go ahead and change it because I donít know what the previous owners used.
Reply With Quote
  #2  
Old June 6th, 2019, 20:58
lawsoncl lawsoncl is offline
NAXJA Forum User
 
Join Date: Jan 2006
Location: North Idaho
Posts: 4,959
Re: AW4 transmission hesitates going into reverse

Check the throttle body to transmission cable for proper adjustment.
https://www.youtube.com/watch?v=OdMGOVZ3QK8


The trans computer does not control reverse. Assuming you actually unplugged the tcm, it should have required shifting manually. If the brake switch is messed up, then it might have been locking and unlocking the torque converter (no downshifting from 4th into 3rd).
Reply With Quote
  #3  
Old June 6th, 2019, 21:51
Pgw1995 Pgw1995 is offline
NAXJA Forum User
 
Join Date: Jun 2019
Location: Arkansas
Posts: 21
AW4 transmission hesitates going into reverse

Yes, that is what I was thinking, the converter was unlocking. I didnít think the TCM would have anything to do with reverse. Thatís why I checked fluid first. So the cable can mess with reverse? The reverse issue has me stumped unless the trans is about to take a dump. I would think reverse is reverse, no logic to it, or could a solenoid cause that. I wonder about tightening the reverse band?
Reply With Quote
  #4  
Old June 6th, 2019, 21:53
lawsoncl lawsoncl is offline
NAXJA Forum User
 
Join Date: Jan 2006
Location: North Idaho
Posts: 4,959
Re: AW4 transmission hesitates going into reverse

The cable affects the line pressure, so I would assume it could affect the engagement of reverse
Reply With Quote
  #5  
Old June 6th, 2019, 21:53
Pgw1995 Pgw1995 is offline
NAXJA Forum User
 
Join Date: Jun 2019
Location: Arkansas
Posts: 21
AW4 transmission hesitates going into reverse

I was the TCM was under glovebox. The only green plug? Maybe not? But it did shift out fine unplugged.


Sent from my iPhone using Tapatalk
Reply With Quote
  #6  
Old June 6th, 2019, 21:55
Pgw1995 Pgw1995 is offline
NAXJA Forum User
 
Join Date: Jun 2019
Location: Arkansas
Posts: 21
AW4 transmission hesitates going into reverse

Ok, Iíll try to locate an adjustment procedure in the morning. Thanks


Sent from my iPhone using Tapatalk
Reply With Quote
  #7  
Old June 6th, 2019, 21:59
Pgw1995 Pgw1995 is offline
NAXJA Forum User
 
Join Date: Jun 2019
Location: Arkansas
Posts: 21
Re: AW4 transmission hesitates going into reverse

Also, could it be a bad converter?
Reply With Quote
  #8  
Old June 6th, 2019, 22:16
RCP Phx RCP Phx is offline
NAXJA Forum User
 
Join Date: Mar 2003
Location: Phoenix,Az
Posts: 12,279
Re: AW4 transmission hesitates going into reverse

Not if it's acting fine in the forward gears.
Reply With Quote
  #9  
Old June 7th, 2019, 05:37
Pgw1995 Pgw1995 is offline
NAXJA Forum User
 
Join Date: Jun 2019
Location: Arkansas
Posts: 21
AW4 transmission hesitates going into reverse

Ok, drove it to work again this morning with the brake switch bypassed. Shifted out great. So I believe it was the switch causing the converter to lock and unlock constantly. Now to figure out the reverse issue. Wrong kind of fluid? Reverse band? What else would deal with reverse? Is there a solenoid for reverse?
Reply With Quote
  #10  
Old June 7th, 2019, 05:40
Pgw1995 Pgw1995 is offline
NAXJA Forum User
 
Join Date: Jun 2019
Location: Arkansas
Posts: 21
AW4 transmission hesitates going into reverse

Quote:
Originally Posted by Pgw1995 View Post
Ok, drove it to work again this morning with the brake switch bypassed. Shifted out great. So I believe it was the switch causing the converter to lock and unlock constantly. Now to figure out the reverse issue. Wrong kind of fluid? Reverse band? What else would deal with reverse? Is there a solenoid for reverse?


It was idling a lot faster this morning than normal, all I did yesterday was bypass the brake switch and test TPS.
Reply With Quote
  #11  
Old June 7th, 2019, 06:03
cruiser54's Avatar
cruiser54 cruiser54 is offline
NAXJA Forum User
 
Join Date: Nov 2009
Location: Prescott, Az
Posts: 6,601
Re: AW4 transmission hesitates going into reverse

ADJUST THE CABLE!!!!
Reply With Quote
  #12  
Old June 7th, 2019, 15:57
Pgw1995 Pgw1995 is offline
NAXJA Forum User
 
Join Date: Jun 2019
Location: Arkansas
Posts: 21
AW4 transmission hesitates going into reverse

Ok, did the cable adjustment. Ran plunger all the way back pushed throttle all the way, guess what, it never went back in place, stayed back. Guess that means new cable?
Reply With Quote
  #13  
Old June 7th, 2019, 23:26
Pgw1995 Pgw1995 is offline
NAXJA Forum User
 
Join Date: Jun 2019
Location: Arkansas
Posts: 21
AW4 transmission hesitates going into reverse

Help please, TV cable adjustment didnít go back to home spot after I pushed throttle. I pulled a diagnostic test and it showed P0700 (transmission control system malfunction) P0720 (output speed sensor) and P1492 (battery temp sensor) it was unplugged. I erased all codes drove it around the block (not long) and now all I get is the P0700 code. TCM replacement or do I need to drive a bit more and see if the culprit shows back up?
Reply With Quote
  #14  
Old June 7th, 2019, 23:44
lawsoncl lawsoncl is offline
NAXJA Forum User
 
Join Date: Jan 2006
Location: North Idaho
Posts: 4,959
Re: AW4 transmission hesitates going into reverse

P0700 is likely from disconnecting the trans computer or pulling the fuse. Sounds like cable is either stretched or broken.
Reply With Quote
  #15  
Old June 7th, 2019, 23:58
Pgw1995 Pgw1995 is offline
NAXJA Forum User
 
Join Date: Jun 2019
Location: Arkansas
Posts: 21
AW4 transmission hesitates going into reverse

Ya, but havenít disconnected in a couple days. Erased all codes. That is the only code that shows. My airbag light stays on though. No horn or cruise. Backup lights work though. Donít think thatís my issue though
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for automatic trans reverse light color to wire in the reverse lights Atm3535 OEM Tech Discussion 0 January 19th, 2016 04:25
Engine hesitates sometimes BombThreat OEM Tech Discussion 6 June 17th, 2007 02:19
Transmission will not shift past reverse! Help Please! HeavyMetal OEM Tech Discussion 6 May 28th, 2006 22:29
Transmission is binding in reverse 1096xj OEM Tech Discussion 12 April 5th, 2006 23:07
Adjusting Low Reverse Band on Torqueflite 904 transmission xjpio OEM Tech Discussion 3 September 6th, 2005 00:18


All times are GMT -7. The time now is 11:08.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014