NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old July 9th, 2019, 07:50
GasguzzlinXJ GasguzzlinXJ is offline
NAXJA Forum User
 
Join Date: Jul 2019
Location: Nampa, Idaho
Posts: 5
Crank but no start

2000 XJ, 4.0, 5 SPDR, 109k miles... has run very well ever since I bought it, recently replaced the head and ran even better since then, always started right up, never idled high or low, never stuttered or died. Go to start it one night, and it cranks but wont start. Has fuel to it, all fuses are good, have flipped around relays, etc. 5v going to and from CPS. Brand new spark plugs, coil rail seems to be in good shape. Interestingly enough, we gave it a shot of fuel starter in the intake, and it wanted to start just a little. Went to the store to buy some more, got back and tried again, giving plenty of fuel starter to it, then there was NOTHING seems like an intermittent electrical issue... I'm not great with electronics so any help would be appreciated. I'm leaning towards ECM malfunction? My radiator cap had blown off a couple times because of backpressure caused by a clogged reservoir line (resolved), and the ECM is right next to it.... please help!
Reply With Quote
  #2  
Old July 9th, 2019, 08:32
RCP Phx RCP Phx is online now
NAXJA Forum User
 
Join Date: Mar 2003
Location: Phoenix,Az
Posts: 12,446
Re: Crank but no start

Could be a lot of things at this point. You need to put it on a scanner and see what's happening.
Reply With Quote
  #3  
Old July 9th, 2019, 10:32
Tim_MN's Avatar
Tim_MN Tim_MN is offline
Freakish Hand Strength
 
Join Date: Mar 2003
Location: Minneapolis, MN
Posts: 6,654
Re: Crank but no start

ECM failure should only be considered after a complete and in-depth diagnostics and trouble shooting of the more common, more likely, and more logical causes for a no-start.

Test the CPS.
__________________
.
.

Quote:
Originally Posted by bimmerjeeper

Go ahead and slam the liftgate down on a blanket, and see how long you are laughing.
Quote:
Originally Posted by soyjer

Tim MAY be 100% correct, but why would a person automatically pick him as the expert .....
Reply With Quote
  #4  
Old July 9th, 2019, 10:37
4x4JeePmaNthINg's Avatar
4x4JeePmaNthINg 4x4JeePmaNthINg is offline
NAXJA Forum User
 
Join Date: Nov 2008
Location: colorado, severance
Posts: 1,092
Re: Crank but no start

And check engine light?
X2 scanner

How new are the spark plugs and what kind?
Reply With Quote
  #5  
Old July 9th, 2019, 13:32
SlowXj SlowXj is offline
NAXJA Forum User
 
Join Date: Nov 2017
Location: East Tn
Posts: 90
Crank but no start

Is it getting spark? What about fuel injector pulse? That's my starting point.

Sent from my SM-G950U using Tapatalk
Reply With Quote
  #6  
Old July 9th, 2019, 15:42
GasguzzlinXJ GasguzzlinXJ is offline
NAXJA Forum User
 
Join Date: Jul 2019
Location: Nampa, Idaho
Posts: 5
Re: Crank but no start

No check engine light. We plugged in an OBII reader and nothing came up. Wiped it clean in case the computer was in a loop. Spark plugs are ngk iridium but I highly doubt it has anything to do with the plugs. I'm gonna check the cps when I get home. I've heard mopar is the best way to go for a new CPS if that is the issue. Confirmation of this? Thanks guys
Reply With Quote
  #7  
Old July 9th, 2019, 15:44
GasguzzlinXJ GasguzzlinXJ is offline
NAXJA Forum User
 
Join Date: Jul 2019
Location: Nampa, Idaho
Posts: 5
Re: Crank but no start

Slowxj, how would I figure out fuel injector pulse? I dont think its a fuel problem at this point but I could be wrong of course
Reply With Quote
  #8  
Old July 9th, 2019, 16:10
Tim_MN's Avatar
Tim_MN Tim_MN is offline
Freakish Hand Strength
 
Join Date: Mar 2003
Location: Minneapolis, MN
Posts: 6,654
Re: Crank but no start

Quote:
Originally Posted by GasguzzlinXJ View Post
I've heard mopar is the best way to go for a new CPS if that is the issue. Confirmation of this?
Most auto parts stores sell cheap crappy Chinese made parts, some that even come with a "Lifetime Warranty". These parts are poorly manufactured and/or made from inferior materials. They are often out of specification, or even failed, right out of the box. The ones that are not faulty many times will have a short service life before they fail. Always buy top quality replacement parts and genuine Jeep engine sensors. Numerous threads detail long and frustrating searches for a "problem" that ended up being cured simply with genuine Jeep repair parts.

Cheap parts are cheap for a reason.
__________________
.
.

Quote:
Originally Posted by bimmerjeeper

Go ahead and slam the liftgate down on a blanket, and see how long you are laughing.
Quote:
Originally Posted by soyjer

Tim MAY be 100% correct, but why would a person automatically pick him as the expert .....
Reply With Quote
  #9  
Old July 10th, 2019, 12:10
GasguzzlinXJ GasguzzlinXJ is offline
NAXJA Forum User
 
Join Date: Jul 2019
Location: Nampa, Idaho
Posts: 5
Re: Crank but no start

Tested the CPS and it shows OL. Infinite resistance. Any other suggestions as to what it might be?
Reply With Quote
  #10  
Old July 10th, 2019, 13:11
SlowXj SlowXj is offline
NAXJA Forum User
 
Join Date: Nov 2017
Location: East Tn
Posts: 90
Crank but no start

To check injector get a injector niod tester. They're cheap and that will point you in some kind of direction. Fuel,spark, and air make a boom...

Sent from my SM-G950U using Tapatalk
Reply With Quote
  #11  
Old July 11th, 2019, 08:16
GasguzzlinXJ GasguzzlinXJ is offline
NAXJA Forum User
 
Join Date: Jul 2019
Location: Nampa, Idaho
Posts: 5
Re: Crank but no start

FIXED! So I read on some other forums that even though the CPS dont show signs of going bad, some guys still replace it and it fixes the problem. CPS tested out and everything else was good so I decided to give it a shot, and voila, the jeep fired right up like it hadn't missed a beat. Had the engine light on right afterwards which we cleared and now it's good to go. Thanks for the help guys!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Another crank no start... SlowXj OEM Tech Discussion 7 December 12th, 2018 16:32
2000 xj loud noise at start of crank - no start bobhouseholder OEM Tech Discussion 28 September 1st, 2018 22:11
No crank no start 4x4JeePmaNthINg OEM Tech Discussion 25 March 31st, 2018 17:14
Crank, no start kujito Colorado Chapter 12 December 11th, 2009 09:04
crank-crank-crank-crank-cra... [wait...] crank-crank-START! iBran OEM Tech Discussion 20 October 21st, 2005 17:33


All times are GMT -7. The time now is 11:30.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014