NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > Modified Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

Modified Tech Discussion Forum for Tech related discussion for Modified XJ's and MJ's.

Reply
 
Thread Tools Display Modes
  #1  
Old December 23rd, 2004, 17:46
Goldeneagle Goldeneagle is offline
NAXJA Forum User
 
Join Date: Dec 2004
Location: Carlsbad, CA
Posts: 6
Took in some water...

Hello,

I'm new to the forum, & I've got a '98 XJ with a 4.5 Rusty's lift, TB spacer, air tube w/K&N, and Flowmaster cat-back sys, I used to live in NorCal (near Bridgeport), and I've since moved to SoCal (Carlsbad), work at Camp Pendleton; in both locations, I enjoy/ed moderate wheeling. Anyways, all that's besides the point, just some background info. Here's the deal: today, went wheeling, attempted to ford a crossing I thought wasn't as deep as it really was. Took in some water, immediately shut it down. Towed it to the shop, pulled the plugs, turned it over several times, spit a good amount of water out. After that, changed the oil, flushed the antifreeze, and fuel system. I intend to replace the plugs tomorrow. Now the thing runs like garbage, in that, around 50 or so, when I stomp on it, it won't down shift & accelerate hard, it just gradually accelerates no matter what speed I start from. I also looked a the ATF, it's still red, no strawberry shake. In addition, the "check engine" light is on. I understand there could be multiple things wrong as a result of the circumstances, I'm just looking for some of y'alls advice before I start payin' people to hose me, or asking my Marines stupid questions (anonymity is cool here). The stupid part is, my Marines were like, "C'mon sir, you got it!" I was like yeah I got, I went for it & took a bath, they love that stuff. Thanks for any suggestions, & never fear, I realize they're just that & wouldn't try be pissy if I tried something & it didn't work Thanks in advance, Happy Holidays
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Water Injection for Carbon Cleaning SPSERG Modified Tech Discussion 6 August 18th, 2004 06:04
water instead of oil... skipc OEM Tech Discussion 4 July 15th, 2004 00:34
Water Pump failure questions 2xtreme OEM Tech Discussion 2 December 6th, 2003 07:53
Water in Automatic Transmission XJMark OEM Tech Discussion 5 October 20th, 2003 13:42
(CA) BLM creates marshy bird habitat near Barstow - pumping water to create lake Ed A. Stevens Land Use Forum 0 March 20th, 2003 11:21


All times are GMT -7. The time now is 03:03.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014