NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old January 26th, 2009, 12:03
jeepman121's Avatar
jeepman121 jeepman121 is offline
NAXJA Forum User
 
Join Date: May 2007
Location: Ohio
Posts: 614
AW4 Solenoids?? NSS??? Both???

So over a YEAR ago after fording through some flood water I had a 5 minute issue where my jeep was starting from a stop in 2nd gear. After turning the key to half position and shifting from P to 1st back and forth it started up and went fine....I noticed in the last month that if I was to downshift the jeep manually lets say at 35 mph, that instead of it dropping into 1st at 25 mph like it should, it would sometimes not hit first untill 15 mph....then I had the 2nd gear start issue again for 5 minutes...and today I was at 35 mph dropped to 1-2 and it actually shifted into 1st (at 35) reved high then went to 2nd, then back to first...I left it in 1st stopped and took off and it shifted into 2nd at like 15 mph (when It should do that dumb redline shift that I hate) tried to drop it back in 1st and it would not go into 1st unless I stopped. turned it off and on and it drove fine. I'm confused.- 95 XJ 4.0 AX4 168,000
Reply With Quote
  #2  
Old January 26th, 2009, 13:12
jeepman121's Avatar
jeepman121 jeepman121 is offline
NAXJA Forum User
 
Join Date: May 2007
Location: Ohio
Posts: 614
Re: AW4 Solenoids?? NSS??? Both???

Is it a PITA to do the solenoids...I saw a quick fix for the NSS in JP magazine. If that's what it is....
Reply With Quote
  #3  
Old January 27th, 2009, 07:07
jeepman121's Avatar
jeepman121 jeepman121 is offline
NAXJA Forum User
 
Join Date: May 2007
Location: Ohio
Posts: 614
Re: AW4 Solenoids?? NSS??? Both???

*bump* .............?????
Reply With Quote
  #4  
Old January 29th, 2009, 06:54
jeepman121's Avatar
jeepman121 jeepman121 is offline
NAXJA Forum User
 
Join Date: May 2007
Location: Ohio
Posts: 614
Re: AW4 Solenoids?? NSS??? Both???

nothing??
Reply With Quote
  #5  
Old January 29th, 2009, 07:21
winterbeater's Avatar
winterbeater winterbeater is offline
NAXJA Forum User
 
Join Date: Jul 2008
Location: Royal Oak, Michigan
Posts: 5,315
Re: AW4 Solenoids?? NSS??? Both???

I believe that the NSS is just for starting and does not affect the transmission shifting. Weird shifting is often caused by the TPS. You could check that with an analog voltmeter. I'm not sure what the voltage range should be on your 95 but it needs to be a smoothe transition from closed throttle to wide open with no dead spots. I'm sure you could find the actual values for yours by searching threads.
Reply With Quote
  #6  
Old January 29th, 2009, 09:11
joe_peters joe_peters is offline
NAXJA Forum User
 
Join Date: Apr 2008
Location: Grants Pass, OryGun
Posts: 13,746
Re: AW4 Solenoids?? NSS??? Both???

x2., NSS does not effect shifting.
Reply With Quote
  #7  
Old January 29th, 2009, 09:15
rogersjeep's Avatar
rogersjeep rogersjeep is offline
NAXJA Forum User
 
Join Date: Oct 2006
Location: Pearland Texas
Posts: 339
Re: AW4 Solenoids?? NSS??? Both???

Pull your trans cover and remove and check the soleniods.
I checked mine by just adding power from the batt. And if it clicks its good. No click its bad. Replace as needed.
Reply With Quote
  #8  
Old January 29th, 2009, 12:19
searchingforXJ searchingforXJ is offline
NAXJA Forum User
 
Join Date: Apr 2008
Location: Canada
Posts: 129
Re: AW4 Solenoids?? NSS??? Both???

Quote:
Originally Posted by rogersjeep View Post
Pull your trans cover and remove and check the soleniods.
I checked mine by just adding power from the batt. And if it clicks its good. No click its bad. Replace as needed.
You don't need to do all that to test the solenoids. All you need is a ohm-meter to check them from inside the jeep. Find the harness that plugs into the TCM and you check a few wires there, I did it this past summer on my brothers jeep. I'll see if I can find the wiring diagram.

Edit: Sorry, I meant TCU.

Last edited by searchingforXJ; January 29th, 2009 at 12:33.
Reply With Quote
  #9  
Old January 29th, 2009, 12:22
jeepman121's Avatar
jeepman121 jeepman121 is offline
NAXJA Forum User
 
Join Date: May 2007
Location: Ohio
Posts: 614
Re: AW4 Solenoids?? NSS??? Both???

It only does it randomly...I'm wondering if they would still click even though they are bad.
Reply With Quote
  #10  
Old January 29th, 2009, 12:32
winterbeater's Avatar
winterbeater winterbeater is offline
NAXJA Forum User
 
Join Date: Jul 2008
Location: Royal Oak, Michigan
Posts: 5,315
Re: AW4 Solenoids?? NSS??? Both???

Random = wires/connections. Have you cleaned the contacts on the plugs going to the solenoids. At least unplug and plug them several times to scrape the contact surfaces of the plugs.
Reply With Quote
  #11  
Old January 29th, 2009, 12:35
searchingforXJ searchingforXJ is offline
NAXJA Forum User
 
Join Date: Apr 2008
Location: Canada
Posts: 129
Re: AW4 Solenoids?? NSS??? Both???

Quote:
Originally Posted by jeepman121 View Post
It only does it randomly...I'm wondering if they would still click even though they are bad.
In my brothers Jeep he would lose 2nd & 3rd randomly for a few weeks before they disappeared for good.
Reply With Quote
  #12  
Old January 29th, 2009, 12:42
4LowandGo's Avatar
4LowandGo 4LowandGo is offline
NAXJA Forum User
 
Join Date: Jan 2008
Location: Kennesaw, Georgia
Posts: 479
Re: AW4 Solenoids?? NSS??? Both???

Mine is doing the same thing as the first post states. Please PM me with instructions on checking the TCU harness with an Ohm-meter.

I have a '92 HO with an AW4.
Reply With Quote
  #13  
Old January 29th, 2009, 12:49
searchingforXJ searchingforXJ is offline
NAXJA Forum User
 
Join Date: Apr 2008
Location: Canada
Posts: 129
Re: AW4 Solenoids?? NSS??? Both???

Every time I try to post with a link the post disappears, what's up with that?
Reply With Quote
  #14  
Old January 29th, 2009, 19:27
winterbeater's Avatar
winterbeater winterbeater is offline
NAXJA Forum User
 
Join Date: Jul 2008
Location: Royal Oak, Michigan
Posts: 5,315
Re: AW4 Solenoids?? NSS??? Both???

Quote:
Originally Posted by searchingforXJ View Post
Every time I try to post with a link the post disappears, what's up with that?
copy shortcut, open thread, paste.

http://www.naxja.org/forum/showthread.php?t=982600
Reply With Quote
  #15  
Old January 29th, 2009, 19:34
searchingforXJ searchingforXJ is offline
NAXJA Forum User
 
Join Date: Apr 2008
Location: Canada
Posts: 129
Re: AW4 Solenoids?? NSS??? Both???

Quote:
Originally Posted by winterbeater View Post
copy shortcut, open thread, paste.

http://www.naxja.org/forum/showthread.php?t=982600

Here it is. Just take out the space. I tried to post it once, and the post didn't appear. I then edited a post to include it, and the post was removed instantly.

http://www.great lakesxj.com/tech/TCU4.jpg
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB: AW4 solenoids bigalpha Wanted: Private Party Only 0 October 5th, 2008 20:42
AW4 Solenoids Twistedlink OEM Tech Discussion 2 August 9th, 2008 07:39
AW4 Solenoids Zick OEM Tech Discussion 15 July 21st, 2007 09:58
AW4 solenoids TwistedSymphony OEM Tech Discussion 26 June 23rd, 2007 09:28
aw4 solenoids jeffnun OEM Tech Discussion 3 June 14th, 2005 07:43


All times are GMT -7. The time now is 00:55.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014