NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old September 27th, 2008, 11:23
RANSOM's Avatar
RANSOM RANSOM is offline
NAXJA Forum User
 
Join Date: Jul 2006
Location: south jersey
Posts: 81
blinker, hazard, marker light issues

2000 xj, 4.0, 4x4...

All fuzes and bulbs are fine.

Here's my issue... My left front and rear marker lights (including tag lights)are out. The bulbs are new. In addition, when I turn my LEFT turn signal on BOTH REAR lights flash, BUT only the LEFT FRONT flashes ...NOT the RIGHT FRONT.... Its an intermittent problem, but it does it more times than not.

ALSO... when I turn my hazzard switch on.. somtimes it functions normal. Other times not at all OR it just flashes the LEFT.

What's the deal? Could it be the multifunction turn/hazard switch?
Reply With Quote
  #2  
Old September 27th, 2008, 13:53
8Mud's Avatar
8Mud 8Mud is offline
NAXJA Forum User
 
Join Date: Sep 2003
Location: Central Germany
Posts: 8,515
Re: blinker, hazard, marker light issues

I'm not at all familiar with the 2000 models, or much the solid state blinker systems.
Whenever the wrong bilb lights, I usually go imediatly to the bulb socket grounds. It is common for a bad ground in one blub to cause the system to find odd grund paths (often through another bulb) farther down the system.
I imagine this could also affect the solid state components some, they are likely designed for a certain amp load and when it isn't present odd things happen. Not Jeep specific knowledge, but I've seen it before in other manufactures vehicles.
Reply With Quote
  #3  
Old September 29th, 2008, 18:28
RANSOM's Avatar
RANSOM RANSOM is offline
NAXJA Forum User
 
Join Date: Jul 2006
Location: south jersey
Posts: 81
Re: blinker, hazard, marker light issues

I've seen weird stuff like that before as well... I had '79 f-250 that had and 1157 bulb in the tail light with the two filaments touching. When I hit the brakes the interior lights would go on! And when I turned on the left blinker the interior lights would flash! hahahah!... Gotta love a "hoopy!"

I checked all the bulb, grounds, and the checked out fine. I figured it would be the multifunction switch because of the hazard switch working intermittently. I have to throw the switch back and forth a couple of times to get it to work...
Reply With Quote
  #4  
Old September 29th, 2008, 19:24
Crabapple Crabapple is offline
NAXJA Forum User
 
Join Date: Dec 2007
Location: Greensboro, North Carolina
Posts: 463
Re: blinker, hazard, marker light issues

I have a VERY similair problem with my '99. Espicially when tryin to use the hazard switch.
Reply With Quote
  #5  
Old September 30th, 2008, 13:08
LVJimmy LVJimmy is offline
NAXJA Forum User
 
Join Date: Aug 2007
Location: Las Vegas, NV
Posts: 15
Re: blinker, hazard, marker light issues

Quote:
Originally Posted by Crabapple View Post
I have a VERY similair problem with my '99. Espicially when tryin to use the hazard switch.

If I try and turn on the hazzards on on my '99 they don't work. Both turn signals also stop working until I turn off the hazzards and turn off the car. When I restart everything is fine.
Reply With Quote
  #6  
Old September 30th, 2008, 13:52
UNCC_99XJ's Avatar
UNCC_99XJ UNCC_99XJ is offline
Twisted Up
 
Join Date: Jan 2005
Location: Harrisburg, NC
Posts: 8,892
Re: blinker, hazard, marker light issues

Quote:
Originally Posted by RANSOM View Post
Here's my issue... My left front and rear marker lights (including tag lights)are out. The bulbs are new. In addition, when I turn my LEFT turn signal on BOTH REAR lights flash, BUT only the LEFT FRONT flashes ...NOT the RIGHT FRONT.... Its an intermittent problem, but it does it more times than not.
Turn signal switch is bad......very common on the 97+'s. I can't tell you how much the switch was to replace or how hard, as mine was covered under warranty when I bought the Jeep...but I can't imagine it being that bad or hard.
__________________
-Timbo -
-'99 Sport, RE 4.5" and a few other things
-'13 Performance Blue Ford Focus ST. DD & Race Car.
-'17 Ruby Red F150 Lariat. Tow rig and occasional DD
Reply With Quote
  #7  
Old September 30th, 2008, 13:53
Idiot Wind's Avatar
Idiot Wind Idiot Wind is offline
NAXJA Member
 
Join Date: Apr 2003
Location: Littleton, Colorado
Posts: 358
Re: blinker, hazard, marker light issues

Quote:
Originally Posted by LVJimmy View Post
If I try and turn on the hazzards on on my '99 they don't work. Both turn signals also stop working until I turn off the hazzards and turn off the car. When I restart everything is fine.
my 2000 does the same thing...has for years now. outside of changing fuses for the hell of it and replacing the combination flasher, I got nothing...still have the problem.

just read above post. I will have to look into how hard that is to switch out.
Reply With Quote
  #8  
Old September 30th, 2008, 16:05
4wheelnfun's Avatar
4wheelnfun 4wheelnfun is offline
NAXJA Forum User
 
Join Date: Aug 2008
Location: Up-State New York
Posts: 35
Re: blinker, hazard, marker light issues

I just fixed a similar electrical problem with my 96.
My front parking lights did not work, but the signals and flashers did OK.
The problem was with the large connector on the wire harness feeding all the front lights, located under the air filter box.
It was massively corroded.
The 12v line for the parking lights had broken off the pin, and fell out of the connector.
To fix it, I cleaned out the green junk from the remaining good pins, and soldered in a jumper around the connector for the 12v line.
Works OkeeDokee now.
Reply With Quote
  #9  
Old October 8th, 2008, 19:12
RANSOM's Avatar
RANSOM RANSOM is offline
NAXJA Forum User
 
Join Date: Jul 2006
Location: south jersey
Posts: 81
Re: blinker, hazard, marker light issues

I replaced the turn signal/ hazard relay (lists for 39$) first and it didn't fix it. Chrysler replaces and average of 64 per week, nationally.

Then I bought a new combo switch from chrysler (retails for $62.50) and that solved it. It turns out that Chrysler replaces 152 units on average per week, nationally. Definately common problem in '97+.
Reply With Quote
  #10  
Old October 8th, 2008, 20:08
Grover728 Grover728 is offline
NAXJA Forum User
 
Join Date: Apr 2007
Location: Inland Empire
Posts: 62
Re: blinker, hazard, marker light issues

Same problem. Took the switch apart and found the contact grease was dried up. Cleaned the switch and spent 3 times the amount of time getting the switch back together.
Reply With Quote
  #11  
Old October 8th, 2008, 21:04
RANSOM's Avatar
RANSOM RANSOM is offline
NAXJA Forum User
 
Join Date: Jul 2006
Location: south jersey
Posts: 81
Re: blinker, hazard, marker light issues

Quote:
Originally Posted by Grover728 View Post
Same problem. Took the switch apart and found the contact grease was dried up. Cleaned the switch and spent 3 times the amount of time getting the switch back together.

Yeah. Mine was the same. I found out after the fact of buying the new one. It was a pain to get back together so I trashed it.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB: side marker light billyjp2 NAC Classifieds 1 July 20th, 2007 07:35
XJ wagoneer front marker light needed! WTF Wanted: Private Party Only 1 February 6th, 2007 08:40
blinker issues ChipsXJ OEM Tech Discussion 8 May 27th, 2005 10:54
blinker to hazard lights shimmy OEM Tech Discussion 13 February 2nd, 2005 20:47
Front Marker Light Replacement viennatech Tow Rigs and Trailers 1 August 3rd, 2004 14:57


All times are GMT -7. The time now is 14:28.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014