NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old March 23rd, 2016, 10:39
SBpunk SBpunk is offline
NAXJA Forum User
 
Join Date: Jan 2013
Location: Enid, OK
Posts: 339
4.0 Issues on idle/power

1992 w/ 4.0 AX15 231

So having a rough idle and a few other things I'll list below. Worried the issue might be more than I can deal with in the garage. Hoping its just a fuel injector or spark plugs so going to be changing them out.

Rough Idle
Oil w/ Gas smell
Sometimes hard start (have to hit the gas pedal)
Backfire through intake (this one scares me a bit)
Lack of power (gearing and tires suck but still lacking)

Things I'm hoping would solve it is replacing the tail pipe after the muffler since theres some holes from rust. Testing out the fuel injectors to see if one is leaking/not working at all. Changing spark plugs because I'm pretty sure the PO said he put the 4 point ones in. Other than messing with the rotor, cap, wires and other general tune up stuff I'm concerned the problem might be in the pistons or valves.
Reply With Quote
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Idle Issues Turncoat_Reno OEM Tech Discussion 0 July 27th, 2012 00:29
Idle Issues Stroker 4.7 Modified Tech Discussion 1 April 9th, 2009 11:35
Idle Issues BADaXJ Modified Tech Discussion 3 November 12th, 2008 16:47
AW4/Idle Issues IHWheelin OEM Tech Discussion 3 February 1st, 2007 23:50
Idle Issues cmeuzelaar OEM Tech Discussion 3 January 17th, 2005 20:22


All times are GMT -7. The time now is 01:00.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014