NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #16  
Old October 31st, 2019, 01:09
Ralph77 Ralph77 is offline
NAXJA Forum User
 
Join Date: Dec 2015
Location: East Coast
Posts: 436
Re: Jeep shuts off, I searched

Quote:
Originally Posted by blackxjmn View Post
Hey,
I have been having issues recently with my 2000 xj shutting off while driving. Usually I can put it in park and crank it and it will turn back on. When it dies the tach simply drops, no sputtering or anything it just turns off. I am speculating that it is the CPS but am not sure because it works some of the time. My Jeep did not throw a code except a couple EVAP fuel system leaks and a cylinder 3 misfire. Sorry for repeating any previously asked questions I just want a solid answer.

Thanks in advance
'00 was kind of doing the same thing. When she would reach operating temperature. Pretty sure my CPS was experiencing thermal failure.
Doing the resistance test it came up good, assuming I did it right, but that kind of makes sense cause it was done when cold.
Can read a little more about my experience with it here.

https://www.cherokeeforum.com/f2/cut...riving-241745/
Reply With Quote
  #17  
Old November 2nd, 2019, 21:19
cemeyer's Avatar
cemeyer cemeyer is offline
NAXJA Forum User
 
Join Date: Mar 2009
Location: CO
Posts: 94
Re: Jeep shuts off, I searched

Good evening, I hope maybe one of you guys can point me in the right direction. My 98 had a dead battery, I jump started it the other day to move it up into the garage to replace the badly cracked APN header. Today I stuck the charger on it, turned the charger to high amp for engine start, it did not start. It cranks, but will not fire. The fuel gauge doesn’t register, the volt gauge reads nothing, the ASD relay and the fuel pump relay do not pull in. All fuses check good. I pulled a cover off a relay, stuck it in fuel pump slot, tripped it, fuel pump does run. I unplugged the CPS, the one on the fly wheel, it did not change anything. The CPS ohm’s open. Where should I look next? Could I have fried the ECM, when I turned the charger to boost or when I ran it on a dead battery after I jump started it?
Thanks in advance for your help!
Reply With Quote
  #18  
Old November 2nd, 2019, 21:24
cemeyer's Avatar
cemeyer cemeyer is offline
NAXJA Forum User
 
Join Date: Mar 2009
Location: CO
Posts: 94
Re: Jeep shuts off, I searched

I forgot to add, I cannot get the scan tool to connect to the ECM either.
Reply With Quote
  #19  
Old November 3rd, 2019, 08:04
Tim_MN's Avatar
Tim_MN Tim_MN is offline
Freakish Hand Strength
 
Join Date: Mar 2003
Location: Minneapolis, MN
Posts: 6,759
Re: Jeep shuts off, I searched

The symptoms suggest a faulty CPS, or another OBD-II sensor that is short circuited, but you should always suspect the most recent repairs or modifications as a primary suspect. Did you forget to reconnect any OBD engine sensors or wire harness connectors your removed for the repairs ? Have you inspected all the wire plugs for pushed back wire pins or corrosion, inspected all the wire harnesses for chafed/melted wire insulation or any other damages that may have been present, or may have occurred during the repairs ?

I would specifically look at and continuity test: 1) the wire harnesses at the rear of the valve cover, 2) the O2 sensor wire harness, 3) the wire harness for the throttle body and sensors on top of the engine.
__________________
.
.

Quote:
Originally Posted by bimmerjeeper

Go ahead and slam the liftgate down on a blanket, and see how long you are laughing.
Quote:
Originally Posted by soyjer

Tim MAY be 100% correct, but why would a person automatically pick him as the expert .....
Reply With Quote
  #20  
Old November 3rd, 2019, 08:47
cemeyer's Avatar
cemeyer cemeyer is offline
NAXJA Forum User
 
Join Date: Mar 2009
Location: CO
Posts: 94
Re: Jeep shuts off, I searched

The no start issue occurred before I disassembled anything for the header swap.
Reply With Quote
  #21  
Old November 3rd, 2019, 12:22
cemeyer's Avatar
cemeyer cemeyer is offline
NAXJA Forum User
 
Join Date: Mar 2009
Location: CO
Posts: 94
Re: Jeep shuts off, I searched

Just did some more testing. I unplugged all sensors, and used a ecm pin out diagram. I have power into pcm, but no 5V voltage output. I’m leaning more heavily to the pcm as being the culprit. Unless anyone has more that you think I can test, I’m probably going to gets ecm ordered up.
Reply With Quote
  #22  
Old November 3rd, 2019, 17:04
Heavyopp Heavyopp is offline
NAXJA Member
 
Join Date: Jan 2017
Location: Middlesex, NJ
Posts: 814
Re: Jeep shuts off, I searched

Might do better starting your own thread with a proper title instead of hijacking this one
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Jeep shuts off when driving! DetroitJEEP OEM Tech Discussion 14 August 10th, 2009 13:09
Help, the jeep just shuts down Semper Fi OEM Tech Discussion 7 April 1st, 2009 13:39
jeep shuts off matthagey OEM Tech Discussion 2 March 23rd, 2009 11:18
Jeep Shuts Off While Cornering zfinger OEM Tech Discussion 10 February 20th, 2007 10:20
jeep shuts off when... TsizeXJ Modified Tech Discussion 9 May 17th, 2006 12:24


All times are GMT -7. The time now is 00:28.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014