NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > Modified Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

Modified Tech Discussion Forum for Tech related discussion for Modified XJ's and MJ's.

Reply
 
Thread Tools Display Modes
  #1  
Old November 9th, 2021, 18:33
Pkurzok Pkurzok is offline
NAXJA Forum User
 
Join Date: Dec 2020
Location: Brisbane
Posts: 7
sway bar problem

hi guys
i have 1996 xj with a two inch lift.
i am having a problem sway bar disconnects hit the track bar holder it seems the sway bar is 50 mm to narrow . i have photos but can seem to post them
Reply With Quote
  #2  
Old November 9th, 2021, 19:01
IslanderOffRoad's Avatar
IslanderOffRoad IslanderOffRoad is offline
NAXJA Member
 
Join Date: Apr 2006
Location: Houston, Tx
Posts: 9,303
Re: sway bar problem

How’s the other side look? Is the bar centered?
__________________
John V.
RRC VP
01 XJ Sport 2 door 5spd/4WD- 5" lift, SFR Long Arm, Deavers, Rubi wheels/tires JCR bumpers/sliders, armor, Rubi 44, Ford 8.8, 4.56's, ARBs.
Reply With Quote
  #3  
Old November 10th, 2021, 04:47
Tim_MN's Avatar
Tim_MN Tim_MN is offline
Freakish Hand Strength
 
Join Date: Mar 2003
Location: Minneapolis, MN
Posts: 7,482
Re: sway bar problem

Pictures need to uploade to a hosting service like imgur.com and then a link to the picture is posted here.


When the lift was installed, what was done with the trackbar to adress re-centering the axle ?
__________________
.
.

Quote:
Originally Posted by bimmerjeeper


Go ahead and slam the liftgate down on a blanket, and see how long you are laughing.
Reply With Quote
  #4  
Old November 10th, 2021, 05:34
75SV1 75SV1 is offline
NAXJA Member
 
Join Date: Sep 2004
Location: Hope,IN
Posts: 951
Re: sway bar problem

https://comancheclub.com/topic/67793-sway-bar/

I don't know if this is the same person.
Reply With Quote
  #5  
Old November 10th, 2021, 12:40
XJI6191's Avatar
XJI6191 XJI6191 is offline
NAXJA Forum User
 
Join Date: Mar 2013
Location: between London & South Devon, England
Posts: 109
Re: sway bar problem

Quote:
Originally Posted by Tim_MN View Post
. . When the lift was installed, what was done with the trackbar to adress re-centering the axle ?
It's only 2" so that really shouldn't be a problem (if the 2 I have are anything to go by)

If they don't have the offset that the OEM ones do, that might explain it.
Reply With Quote
  #6  
Old November 10th, 2021, 13:58
maxbraketorque maxbraketorque is offline
NAXJA Forum User
 
Join Date: Jul 2020
Location: PDX
Posts: 599
Re: sway bar problem

Since the sway bar is mounted to the frame, whether or not the sway bar hits the track bar mount shouldn't be affected by the position of the axle. Seems more like the sway bar is shifted too far to one side if that's even possible. Maybe the OP is using RC quick disconnects where the ball joint mechanism has to be installed outboard of the sway bar. If those are installed on the inboard side of the sway bar, I could see those hitting.
Reply With Quote
  #7  
Old November 10th, 2021, 15:19
Pkurzok Pkurzok is offline
NAXJA Forum User
 
Join Date: Dec 2020
Location: Brisbane
Posts: 7
Re: sway bar problem

yes i have posted this on the comanche forum as i get photos on there easier
Reply With Quote
  #8  
Old November 10th, 2021, 15:25
Pkurzok Pkurzok is offline
NAXJA Forum User
 
Join Date: Dec 2020
Location: Brisbane
Posts: 7
Re: sway bar problem

here are some photos
https://ibb.co/PY05Z98
https://ibb.co/TmLqbR7
https://ibb.co/fD9Sjq6
Reply With Quote
  #9  
Old November 10th, 2021, 15:32
Pkurzok Pkurzok is offline
NAXJA Forum User
 
Join Date: Dec 2020
Location: Brisbane
Posts: 7
Re: sway bar problem

more photos

https://ibb.co/GxHTtmJ
https://ibb.co/bbJF9kg
Reply With Quote
  #10  
Old November 10th, 2021, 15:42
RCP Phx RCP Phx is offline
NAXJA Forum User
 
Join Date: Mar 2003
Location: Phoenix,Az
Posts: 15,351
Re: sway bar problem

Get some sway bar relocation brackets!!!!
https://www.quadratec.com/products/16311_700.htm
Reply With Quote
  #11  
Old November 10th, 2021, 16:36
Pkurzok Pkurzok is offline
NAXJA Forum User
 
Join Date: Dec 2020
Location: Brisbane
Posts: 7
Re: sway bar problem

https://ibb.co/Y0NgSbT
got them already fitted
Reply With Quote
  #12  
Old November 10th, 2021, 17:33
Tim_MN's Avatar
Tim_MN Tim_MN is offline
Freakish Hand Strength
 
Join Date: Mar 2003
Location: Minneapolis, MN
Posts: 7,482
Re: sway bar problem

Are the links adjusted to the install instructions, at 10 - 15 UP angle on the ends ? >>> https://jksmfg.com/products/quicker-...kee-zj#install


They look too short here >> https://ibb.co/GxHTtmJ


I have JKS disconnects on my 2000 with the stock swaybar. That combination worked fine at 3.5" of lift, and still works just fine at 5.5" of lift.


.
__________________
.
.

Quote:
Originally Posted by bimmerjeeper


Go ahead and slam the liftgate down on a blanket, and see how long you are laughing.

Last edited by Tim_MN; November 11th, 2021 at 14:56.
Reply With Quote
  #13  
Old November 11th, 2021, 13:42
denverd1 denverd1 is offline
NAXJA Forum User
 
Join Date: Dec 2013
Location: Tyler, TX
Posts: 1,096
Re: sway bar problem

mine works best in the scrap pile
Reply With Quote
  #14  
Old November 11th, 2021, 14:11
XJI6191's Avatar
XJI6191 XJI6191 is offline
NAXJA Forum User
 
Join Date: Mar 2013
Location: between London & South Devon, England
Posts: 109
Re: sway bar problem

I thought maybe I'd misunderstood the problem 'cos I couldn't visualise the install in sufficient detail. Now I've seen the pics I'm just confused, as not sure what they're supposed to illustrate. To me it looks like the links are suspended from the bar - but not otherwise attached to the vehicle. Either my eyesight, brain or cognitive ability are failing me so I'm out of this for a couple days then I'll check out the answer from those who know so much more than I.
Reply With Quote
  #15  
Old November 11th, 2021, 14:43
75SV1 75SV1 is offline
NAXJA Member
 
Join Date: Sep 2004
Location: Hope,IN
Posts: 951
Re: sway bar problem

Quote:
Originally Posted by XJI6191 View Post
I thought maybe I'd misunderstood the problem 'cos I couldn't visualise the install in sufficient detail. Now I've seen the pics I'm just confused, as not sure what they're supposed to illustrate. To me it looks like the links are suspended from the bar - but not otherwise attached to the vehicle. Either my eyesight, brain or cognitive ability are failing me so I'm out of this for a couple days then I'll check out the answer from those who know so much more than I.
I think you see fine. What I see is the OP measured one side a 50mm space. The other side looks less.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
i have a sway problem dustin1216 Modified Tech Discussion 8 June 18th, 2015 15:28
Sway Bar Link problem gregruot7 Modified Tech Discussion 15 May 15th, 2011 11:20
Sway Bar Interference problem. BlueCuda Modified Tech Discussion 8 April 2nd, 2008 04:56
sway bar linkage problem montysbxj Modified Tech Discussion 1 August 4th, 2005 22:27
problem with sway bar or something else? jhillia2 Modified Tech Discussion 3 October 20th, 2003 10:27


All times are GMT -7. The time now is 05:47.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014