NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old June 13th, 2005, 14:21
Maz Maz is offline
NAXJA Forum User
 
Join Date: Oct 2003
Location: LaCanada, CA
Posts: 709
Unhappy All 4 turn signals stopped working

Hi all;

Search didn't turn up anything related.

Just last week, I checked all the lights on my '89 XJ and everything worked.

Yesterday, when I started her, none of the 4 front and rear turn signals worked. I checked all the fuses under the dash, and they were all OK. I cleaned the grounds at the dip stick, firewall and by the windshield washer bottle. Still no signal light.

I haven't checked the bulbs yet, but was wondering if one burnt out bulb would cause all 4 not to work.

What else should I check? Is there a common ground to all 4 that would cause this?

Any pointers or wags would be very much appreciated.

Thanks .. Maz
Reply With Quote
  #2  
Old June 13th, 2005, 14:32
Kejtar's Avatar
Kejtar Kejtar is offline
PostMaster General
 
Join Date: May 2002
Location: Westminster, SoCal
Posts: 18,496
Re: All 4 turn signals stopped working

Quote:
Originally Posted by Maz
Hi all;

Search didn't turn up anything related.

Just last week, I checked all the lights on my '89 XJ and everything worked.

Yesterday, when I started her, none of the 4 front and rear turn signals worked. I checked all the fuses under the dash, and they were all OK. I cleaned the grounds at the dip stick, firewall and by the windshield washer bottle. Still no signal light.

I haven't checked the bulbs yet, but was wondering if one burnt out bulb would cause all 4 not to work.

What else should I check? Is there a common ground to all 4 that would cause this?

Any pointers or wags would be very much appreciated.

Thanks .. Maz
how about the flasher? Find out where that's at in yours and maybe swap it with the emergency one.
Reply With Quote
  #3  
Old June 13th, 2005, 14:49
cykaaro's Avatar
cykaaro cykaaro is offline
NAXJA Forum User
 
Join Date: Dec 2004
Location: ontario, canada
Posts: 530
Re: All 4 turn signals stopped working

Quote:
Originally Posted by Kejtar
how about the flasher? Find out where that's at in yours and maybe swap it with the emergency one.
Exactly what I was thinking. Had the same problem with mine until I put in a new one.
Reply With Quote
  #4  
Old June 13th, 2005, 15:12
Maz Maz is offline
NAXJA Forum User
 
Join Date: Oct 2003
Location: LaCanada, CA
Posts: 709
Re: All 4 turn signals stopped working

Quote:
Originally Posted by Kejtar
how about the flasher? Find out where that's at in yours and maybe swap it with the emergency one.
I forgot to check the flasher. What do you mean by the "emergency one"?
Reply With Quote
  #5  
Old June 13th, 2005, 15:15
AZ Jeff's Avatar
AZ Jeff AZ Jeff is offline
NAXJA Forum User
 
Join Date: Apr 2003
Location: Gilbert, Arizona
Posts: 784
Re: All 4 turn signals stopped working

There is a flasher "can" that actually causes the bulbs to flash. It's located on the fuse panel, and can "burn out".
Reply With Quote
  #6  
Old June 13th, 2005, 15:20
cykaaro's Avatar
cykaaro cykaaro is offline
NAXJA Forum User
 
Join Date: Dec 2004
Location: ontario, canada
Posts: 530
Re: All 4 turn signals stopped working

I upgraded to the electronic type than the regular. I find they last me longer. Maybe as they can handle more lights. A wee bit more to buy, but I really don't like to be without my turn signals, or hazards.

Easy way to check, do your hazards work? If so, switch the flashers. If your turn signals work and your hazards don't, you know it's the flasher.
Reply With Quote
  #7  
Old June 13th, 2005, 16:14
5-90's Avatar
5-90 5-90 is offline
NAXJA Forum User
 
Join Date: Mar 2003
Location: Hammerspace
Posts: 18,821
Re: All 4 turn signals stopped working

There are two flashers - one for turn signals, and a separate unit for the hazzard lights. You can, in a pinch, use the hazzard flasher to restore the turn signals. Typically, you'll know what you lose a bulb because one side will flash at a different rate than the other.

Old-style "thermal" flashers are tank circuits tied through a relay, and depend on the resistance of the bulbs to set the flash rate - changing the number of lights changes the flas rate (and that's why those units act silly when towing.)

The electronic flashers are nice (the flash timing is set by electronics rather than external resistance, and also do well for towing and can handle more lights) but they don't give you the "warning" that you've got a light out and you've got to stay on top of that yourself. Having said that, I've switched over to electronics (Tridon EL12 - about $9 each) and I also do monthly light checks anyhow.

If you are willing, I'd suggest the electronic units, they DO last longer and they don't care if you tow, change to LED lights, use "slave lights" when you flat tow or dolly tow, or pretty much anything else. Of course, Murphy's law being what it is, I never lose a flasher as long as I keep a spare (thermal) in the glove box.

Quick test - hit your hazzards. If they work, buy a new flasher.

5-90
Reply With Quote
  #8  
Old June 13th, 2005, 16:58
Maz Maz is offline
NAXJA Forum User
 
Join Date: Oct 2003
Location: LaCanada, CA
Posts: 709
Re: All 4 turn signals stopped working

Quote:
Originally Posted by cykaaro
Easy way to check, do your hazards work? If so, switch the flashers. If your turn signals work and your hazards don't, you know it's the flasher.
Quote:
Originally Posted by cykaaro
Quick test - hit your hazzards. If they work, buy a new flasher.
5-90
I hit the hazard flasher and it worked, all 4 signal lights. I replaced the "turn signal flasher can" with the "hazard flasher can"; turn signals still don't work.

Is the problem in the steering stalk? When using the turn signal lever, the one-click sound is still there.

I appreciate the quick replies guys. Any other suggestions before I take her in for a steering column tear-up?

Thanks .. Maz
Reply With Quote
  #9  
Old June 13th, 2005, 17:03
5-90's Avatar
5-90 5-90 is offline
NAXJA Forum User
 
Join Date: Mar 2003
Location: Hammerspace
Posts: 18,821
Re: All 4 turn signals stopped working

Lemme peruse wiring diagrams after trig - PM me a reminder in a couple hours or so and I'll see if I can give you a couple tests to isolate the problem.

5-90
Reply With Quote
  #10  
Old June 13th, 2005, 17:18
Maz Maz is offline
NAXJA Forum User
 
Join Date: Oct 2003
Location: LaCanada, CA
Posts: 709
Re: All 4 turn signals stopped working

Quote:
Originally Posted by 5-90
PM me a reminder in a couple hours or so and I'll see if I can give you a couple tests to isolate the problem.
5-90
Will do and standing by. Thanks very much. Did you get my PM this morning?

-Maz
Reply With Quote
  #11  
Old June 13th, 2005, 18:50
cykaaro's Avatar
cykaaro cykaaro is offline
NAXJA Forum User
 
Join Date: Dec 2004
Location: ontario, canada
Posts: 530
Re: All 4 turn signals stopped working

Interesting. Hopefully 5-90 can isolate it. In the steering column, there's the small mechanism that mkes the turn signals work, and the two little springs that turn them off after turning. Only thing I know of in the column. [but I'm pretty new to this and still learning lots] The springs tend to go after a while, and have to be replaced. One of mine went about a month ago, so just did both, but I don't know if that mechanism could cause your problem at all. I know the spring going will still allow the signal lights to work.
Reply With Quote
  #12  
Old June 13th, 2005, 20:26
Maz Maz is offline
NAXJA Forum User
 
Join Date: Oct 2003
Location: LaCanada, CA
Posts: 709
Re: All 4 turn signals stopped working

Quote:
Originally Posted by cykaaro
.....but I don't know if that mechanism could cause your problem at all.
Yeah, I agree, I am not sure either.

Went to store and bought a replacement canister (AKA "can" as Remi called it )anyways. It didn't fix the problem. I am thinking bad wire, but where?

-Maz
Reply With Quote
  #13  
Old June 14th, 2005, 07:52
Maz Maz is offline
NAXJA Forum User
 
Join Date: Oct 2003
Location: LaCanada, CA
Posts: 709
Re: All 4 turn signals stopped working

Well, I didn't do a good search. Found this post that points to a number of possibilities. I'll be checking the stuff mentioned in there.

http://www.naxja.org/forum/showthrea...hlight=flasher

-Maz
Reply With Quote
  #14  
Old June 17th, 2005, 23:01
Maz Maz is offline
NAXJA Forum User
 
Join Date: Oct 2003
Location: LaCanada, CA
Posts: 709
Re: All 4 turn signals stopped working

Update and resolution;

I was probing around the fuse box and under the dash with my multimeter, following Jon's (5-90) instructions (mega thanks 5-90) when for some reason I tried a fresh 20amp fuse for the Turn/Backup fuse. What do you know, the blinkers started working. I was very surprised since the old fuse looks perfect and you can see pic of it. I guess a fuse can go bad and still look OK.



Pic:
http://pg.photos.yahoo.com/ph/entani...48.jpg&.src=ph
Reply With Quote
  #15  
Old June 18th, 2005, 08:26
cykaaro's Avatar
cykaaro cykaaro is offline
NAXJA Forum User
 
Join Date: Dec 2004
Location: ontario, canada
Posts: 530
Re: All 4 turn signals stopped working

Gremlins in there??
Glad you got it going ok!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
'91 Electrical issue- LOTS of stuff just stopped working... Umrswimr OEM Tech Discussion 3 December 10th, 2005 15:58
Why don't my turn signals work? getoffmylawn23 OEM Tech Discussion 1 February 28th, 2005 23:29
TJ Turn Signals 01-XJ Tow Rigs and Trailers 2 January 4th, 2005 06:42
98+ cherokee front turn signals jay diemme For Sale: Private Party Only. XJ ITEMS ONLY 0 November 13th, 2004 17:36
No turn signals Green 96 Sport4x4 OEM Tech Discussion 5 October 21st, 2003 00:09


All times are GMT -7. The time now is 15:27.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014