NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old July 12th, 2017, 07:44
Jimmothyb Jimmothyb is offline
NAXJA Forum User
 
Join Date: Jun 2017
Location: JBLM WA
Posts: 1
Turn signals not working

I have a 1990 jeep cherokee 4.0L manual and 2 days ago my turn signals stoped working. My hazards work just fine so it's not any of the bulbs and since then I've replaced the fuse, flasher relay and the turn signal switch and still no luck and the old fuse was blown and there was light corrosion on the contacts. The turn signal switch looked in good condition.
Reply With Quote
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signals not working flingshot OEM Tech Discussion 1 June 22nd, 2016 18:53
99 with non-working turn signals Ben824 OEM Tech Discussion 6 November 4th, 2012 19:38
Turn signals only working for 1-5 flashes NYPDJeep OEM Tech Discussion 8 November 23rd, 2007 10:32
Turn signals not working quite right...help?! CoastieJ OEM Tech Discussion 4 June 29th, 2007 22:27
All 4 turn signals stopped working Maz OEM Tech Discussion 14 June 18th, 2005 08:26


All times are GMT -7. The time now is 15:41.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014