NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old January 14th, 2004, 23:24
VTJeepr VTJeepr is offline
NAXJA Forum User
 
Join Date: Jun 2003
Posts: 8
broke off oil pressure sending unit

Today i was doing an oil change and when I was taking out the old oil filter i wasn't paying attention and broke off the plastic part of the oil pressure sending unit. I realized what had happened after i turned it on and saw oil spewing out of it. Does anyone know if a new one can be screwed into the metal part of it? Or does the whole assembly have to be replaced. Pictures would help too, thanks

Paul
Reply With Quote
  #2  
Old January 15th, 2004, 05:47
a-mechanic a-mechanic is offline
NAXJA Forum User
 
Join Date: Jun 2002
Location: ga
Posts: 360
Re: broke off oil pressure sending unit

A new sender can be installed.and will be replaced as a unit. once you have the new part on hand, you should be able to see how it is installed and removed.
Reply With Quote
  #3  
Old January 15th, 2004, 11:36
piperRonnie piperRonnie is offline
NAXJA Forum User
 
Join Date: Nov 2003
Location: NW Chicago Subs
Posts: 44
Re: broke off oil pressure sending unit

Be aware that a thin membrane may be the only thing keeping your oil in the engine. You may remove the stub left in the block and temporarily place a M10 screw in to seal the oil in.
Yep, I speak from experience.
Reply With Quote
  #4  
Old January 15th, 2004, 12:50
pancake's Avatar
pancake pancake is offline
NAXJA Forum User
 
Join Date: Sep 2003
Location: Seattle, WA
Posts: 325
Re: broke off oil pressure sending unit

I'm not trying to poke any fun at you...

but that sucks. I'll have to be more careful because I hadn't even thought of it.
Reply With Quote
  #5  
Old January 15th, 2004, 14:57
CaptTrev's Avatar
CaptTrev CaptTrev is offline
NAXJA Forum User
 
Join Date: Nov 2002
Location: Long Island
Posts: 643
Re: broke off oil pressure sending unit

yeah, you'll have to get a ride to the stealership---you dont want to drive it like that!!
(i also speak from experience!


yeah--the plastic piece had a small metal threaded fitting on it--you'll figure it out really easy when u get the new piece in hand--like a-mechanic said

IIRC the part from jeep was about $30-35, but this was 3 years ago. . .

good luck!

CaptTrev
Reply With Quote
  #6  
Old January 15th, 2004, 17:58
nitrogt101's Avatar
nitrogt101 nitrogt101 is offline
NAXJA Forum User
 
Join Date: Oct 2003
Location: Ventura County, So CA
Posts: 627
Re: broke off oil pressure sending unit

I just bought a new one from a local auto parts store for $35(doing a guage swap so I needed one for the new set). I didn't even bother to check with the dealer but I'm guessing they should be anywhere from $40-60.

Good luck.
Reply With Quote
  #7  
Old January 16th, 2004, 19:12
Yucca-Man's Avatar
Yucca-Man Yucca-Man is offline
NAXJA Member # 683
 
Join Date: Jul 2003
Location: Castle Rock, CO
Posts: 6,251
Re: broke off oil pressure sending unit

Quote:
Originally Posted by CaptTrev
yeah, you'll have to get a ride to the stealership---you dont want to drive it like that!!
Actually, you can drive it to the stealership (I speak from experience also) Only needed 25 cents and a bit of JB Weld.


http://www.yuccaman.com/jeep/oilsend.html
Reply With Quote
  #8  
Old January 16th, 2004, 19:17
Codeman Codeman is offline
NAXJA Forum User
 
Join Date: Jan 2004
Location: Cincinnati, OH
Posts: 235
Re: broke off oil pressure sending unit

i replaced mine 2 weeks ago for $20 at autozone
CODEMAN
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:19.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014